-   Mandriva (
-   -   System hang on boot (

jmrich 06-16-2004 11:39 PM

System hang on boot
Man this becoming very aggravating. I have installed freshly about 7 times now but when I boot it hangs at the same place every time. The last message I see is "Activating Swap Partition......[OK]". I would love to hear any suggestions and/or be pointed in the direction of some suggestions. Note that I have tried almost everything that I have seen using Google and search through this forum. I will post my system specs. in case they will be needed: Pentium4 3c, gig of RAM, Asus P4S800D-E Deluxe mobo, 9600XT. My setup is: Win XP Pro on 120GB SATA (no raid) on SiS 180 chipset (Linux doest even see this drive and I have tried disabling the SATA from the BIOS and get the same problem), Mandrake 10 Official on PATA133 with mounted partitions /, /swap, /home, /usr. I would be happy to provide any info if needed. THX

otish1000c 06-17-2004 04:07 AM

check in your BIOS if you APIC & if it's enabled. if you do & it is, disable it. also, how big of a /swap did you make?


gowator 06-17-2004 04:15 AM

first try the above!!!!

Also choose the option for interactive boot
press esc when the splashscreen comes up and then I (when prompted)
of course try saying N to swap file but it is equally likely its the NEXT command fsck'ing everything.

Once you know which it is then you can reboot, press tab when the splash comes up and type
linux 1
this brings you to RL 1 instead of 5 ... at this point youll need to have posted back which command is hanging....

you can just temp rename the file in /etc/init.d for that service to get it working in RL 5 then work out the problems

motub 06-17-2004 05:04 AM


gig of RAM

Does the default Mandrake install kernel recognize 1GB (or more) of RAM, and have SATA drivers, or does one have to pick a custom kernel prior to install? Is a large memory, SATA enabled kernel even available from the install disks?

I'd suggest running the install (again), but this time hitting F2 at the opening screen to see what your boot options are, or even surfing the Mandrake site or package list to see what kernels are available during install and how to choose a different one, as I think that's the problem.

jmrich 06-17-2004 12:21 PM


Originally posted by otish1000c
check in your BIOS if you APIC & if it's enabled. if you do & it is, disable it.

I did the above and everything seems to be working just fine for now.

cyborg_jt 06-17-2004 06:05 PM

I tried this but I can no longer boot into windows, is this normal?

Alakazam 06-17-2004 09:56 PM

I'm pretty new here but it's my understanding that if Windows was installed with acpi and it's now turned off in bios, it will not boot. I'm sure I read a workaround for this problem somewhere but I just can't remember where, you know how us old folks are.

OverlordManny 06-18-2004 06:53 AM

I am having the same problem with hanging after the swap partitioned is 'ok'ed. I look in my bios and the only options i have for acpi is S1, S3, and AUTO. I have tried them all but still get a hang on boot. Any more Ideas?

System stats.

Mobo = MSI K8T Neo
Proc = AMD64 3200+
Ram = Danelec 2x 512m ( this was used in another system and no problems)

Everything else never had problems with linux, I just upgraded Mobo and Proc.

All times are GMT -5. The time now is 12:22 PM.