LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-04-2005, 08:33 PM   #1
flatloop
Member
 
Registered: Jul 2004
Location: Port Huron, MI
Distribution: Debian 'testing'
Posts: 31

Rep: Reputation: 15
Angry su not working in KDE


I'm having a very strange problem... I can't su while in KDE. I don't have any other window managers loaded, so I don't know for sure if KDE is to blame, but it seems to be the likely suspect. I can logon with root locally, through WEBMIN and SSH but when I'm logged in and running X, with KDE I cannot su any of the KDE admin packages, or in a terminal window. Does this even sound feasable? I'm getting kinda frustrated with Mandrake in general, and this is just one more reason for me to switch...





...to Debian.

Thanks for any assistance or Ideas everyone.
 
Old 01-04-2005, 10:49 PM   #2
jrtayloriv
Member
 
Registered: Jun 2004
Location: Inland NW, US
Distribution: Ubuntu
Posts: 366
Blog Entries: 1

Rep: Reputation: 44
wheel

Is the user you are logged in as a member of the group "wheel"? This group allows users to su to root.

type "groups" at shell to find out. If wheel is not listed as a group, log in as root and enter "gpasswd -a <username> wheel"

hope this helps,
jrtayloriv
 
Old 01-05-2005, 06:57 AM   #3
flatloop
Member
 
Registered: Jul 2004
Location: Port Huron, MI
Distribution: Debian 'testing'
Posts: 31

Original Poster
Rep: Reputation: 15
jrtayloriv,

Thanks for the suggestion. I'm a wheel member now, but it does not seem to help. It still tells me 'incorrect password' I'm being VERY careful when I type the password, so that I am certain not to fat-finger it. I guess I should have been a little more precise in my description, I'm sorry for any vagueness.

This mornign when I tried your solution, I SSH'd to my box from work, loging in as myself, checking my group membership. I logged out, started SSH again and this time logged in as root. The password worked then. I made the changes you suggested, and logged out and then back in as myself. As myself I checked my group membership and then tried to su. It asked for the password, I gave it the same one I used to login as root earlier, and it comes back with an incorrect password statement.

At this point I should add, this was working fine, up until a couple of weeks ago when the system locked up tight. Not being incredibly patient at the time I started another terminal (alt-F2) logged in as root, and told the PC to reboot. If memory serves, I believe that my other login was doing some sort of su oriented task (I have no idea whether or not this has any bearing on the problem or not). Since then su has not worked. I've gone into WEBMIN a couple of times to change the root password, to make sure that I have not forgotten it, but it always says incorrect password when I try to do anything su oriented.

Is there a password file in my profile somewhere that I can delete, or fix or something? With that thought I'm going to create a new user and see if it can su.

Thanks for the feedback,
 
Old 01-30-2005, 11:43 PM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 212Reputation: 212Reputation: 212
Have you looked at the SSH server module in Webmin, I had the exact same problem and I found that I hadn't set the permission for root login from one of my computers!! Hope this helps :-)
 
Old 01-31-2005, 01:52 AM   #5
sgrayban
Member
 
Registered: Nov 2004
Location: Spokane, WA
Distribution: Debian 6.0
Posts: 369

Rep: Reputation: 30
KDE uses "kdesu" program to start things like Install Packages which needs root access
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE: <> not working eantoranz Linux - Software 1 10-28-2005 04:31 PM
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker SUSE / openSUSE 1 02-13-2005 08:01 PM
kde not working mardanian Linux - Software 2 03-19-2004 04:16 AM
KDE not working s1353 Linux - Newbie 2 07-19-2003 01:42 AM
Help me get KDE working therion12 Linux - General 5 01-01-2002 08:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration