LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   startx doesn't startx for user (https://www.linuxquestions.org/questions/mandriva-30/startx-doesnt-startx-for-user-252033/)

vdemuth 11-07-2004 03:20 AM

startx doesn't startx for user
 
Hi all,
Just upgraded to MDK10.1 to see if it is any improvement and it will just not go graphical unless I am root.
Issuing startx as a user shows the NVIDIA splash screen, swiftly followed by the usual background you would normally get as the login manager gets set to do its stuff. Then it just drops back to a console prompt, almost as if I had issued ctrl+alt+backspace. As root, no problems, logs in runs normally. The xorg log file shows no errors, a couple of warnings about missing fonts, but other than that no clues.
Any one any suggestions what this might be?

TIA

jonr 11-07-2004 02:00 PM

As I recall, the same thing happened to me when I was (futilely) trying out Mdk 10.1 Community recently.

I'm almost certain it was because the system had shut down abnormally the last time, and there was a lock file that was locking me as normal user out of starting X, because the system was told I was already running X. As root I located the lock file and deleted it and then I was able to start X as normal user.

I wish I remembered the details, but at least this is a clue for you that might help.

(Edit: I have just searched and haven't located any such file. So... ? I'm virtually certain this is in essence what happened, but I have no idea what file I was able to delete in order to fix it.)

vdemuth 11-07-2004 03:17 PM

Hi,
The lock file you refer to is /tmp/X0-lock which doesn't appear to be the cause of this problem as it isn't present prior to me issueing the startx command, and when that fails, the lock file is automatically removed. Have you any more ideas?

jonr 11-07-2004 03:30 PM

Really out of ideas, but I'm grateful for your reassurance I wasn't losing my mind--that there is such a file.

What I'm virtually certain of, is that it was an authority problem. Root could start X but normal user could not because authority was lacking. I wish I could remember what I did to fix it! I remember feeling very clever about it, because I was unable to get online to seek help, and I solved the problem all by myself (a rare event). Now I feel lacking in cleverness.

Please post what you find out if you do solve this problem.

Any others have ideas?

opjose 11-07-2004 04:07 PM

Yeah, it also may be that the system does not recognize the user's rights to his own configuration files in his home directory.

Try this...

Log in as root and change to the user's home directory.

e.g.

cd /home/USERNAME

then

find . -exec chown USERNAME {} \;

and

find . -exec chgrp USERNAME {} \;

Then try again.

jonr 11-07-2004 08:00 PM

That kinda rings a bell, too. I think maybe I had to basically change some permissions and ownerships that got screwed up somehow. Which is similar to taking a lock off the files!

jonr 11-08-2004 05:03 PM

OK, by chance I experienced the same problem I referred to above, again today.

I was playing around with other distributions and when I came back to Mandrake root could start X but as a normal user I couldn't, and got a timeout on the Xauthority file.

The solution: as root, change owner of jon's home directory to jon; and then give u+rxw permissions to the directory.

That fixed it. I could startx again as jon.

This may not be a problem identical to the one starting this thread, but it is what happened a few weeks ago, and same immediate easy solution.

The question is how the permissions and ownership ever got changed in the first place. I may never know.

greenmeanie 11-08-2004 06:42 PM

upgrade
 
when i did the upgrade i was getting a pink background?
never figured it out.

jonr 11-08-2004 08:18 PM

Re: upgrade
 
Quote:

Originally posted by greenmeanie
when i did the upgrade i was getting a pink background?
never figured it out.

As root I get a red background, as normal old me, I get a really ugly blue one. :)

opjose 11-08-2004 08:30 PM

As normal old me I get a lovely blue background, as root I get a really ugly red one...

:D :D :D :D :D :D

jonr 11-08-2004 08:41 PM

Quote:

Originally posted by opjose
As normal old me I get a lovely blue background, as root I get a really ugly red one...

:D :D :D :D :D :D

Trade ya computers! :)


All times are GMT -5. The time now is 04:56 AM.