LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-06-2004, 10:44 PM   #1
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Rep: Reputation: 35
Soyo Motherboard SY-KT600 Dragon slays Mandrake?


Hey Guys,

I swapped out my Albatron-Motherboard for this Soyo SY-KT600 Plus V2.0 and kept all my same hardware and just transfered them back on this Soyo board. My big fear was with Windows not accepting the chip set of the new board. To my surprise, Windows has accepted the transfer of hard-drives with Windows XP, but Mandrake Linux did not.

I have attempted to reinstall Mandrake 10.1 Official 4 different times and it appears my graphic card is not allowing the Nvidia splash screen to boot up to my desktop. Just right before it gets to that point, my monitor turns grayish black. I have done a complete new install.

I have attempted to boot into failsafe and all the modules are installed, but it just boots to a grayish black screen with no prompts.

Any idea what might be going on here? This exact same card worked before with Mandrake 10.0, but it was on the Albatron motherboard.

I am stuck and don't know what else to do.

d-1
 
Old 11-07-2004, 03:32 PM   #2
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
A black grey screen normally indicates that the system is FINE but the video resolution and clock timings exceed your monitor's capabilities.

When you get to the grey screen hit [CTRL][ALT][F1] to get to a console.

Log in as root and type in

service dm stop

now run XFDrake and TEST each configuration or setting, particularly the monitor.

Choose a slightly inferior monitor if needed to have the timings adjusted properly for yours, as often X chooses the absolute limits of your monitors capabilities.

Run each test but once started do not hit any yes on the keyboard.

If the monitor goes black wait 12 seconds for the text screen to return.

Once you do see the rainbow test screen immediately click OK to accept the new settings.

Save and exit.

Now type

service dm start

and away you go.
 
Old 11-07-2004, 08:27 PM   #3
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
( post #14)


I have tried different combinations in test mode and I have not been successful. When I run a Test I get this error message:




Code:
(EE) Problem parsing the config file
(EE) Error parsing the config file try to change some parameters.

Anytime I try to change the resolution of monitor, lets say to 1024X768 8bbps or 24 the screen goes gray again and nothing happens, even if I hit the CTRL+Alt-F1 keys.

Any other suggestions?

I have a Samtron 76DF monitor
and a Best Data MX 440 video card with maxium 3D/2D resolution of 2048X1536 @75 HZ witn Nvidia Gforce2.

d-1







Last edited by dolphans1; 11-07-2004 at 10:06 PM.
 
Old 11-07-2004, 08:38 PM   #4
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
When I say "gray" I mean a charcol black color. Not deep black like the color of Konsole or DOS screen.

Every test I try I still get that (EE) Problem parsing the config file.

???

d-1



Last edited by dolphans1; 11-07-2004 at 10:06 PM.
 
Old 11-07-2004, 10:12 PM   #5
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
Opjose,

I found this post and was wondering if this might help me solve my problem?


Re: error trying to run lg3d-session

Posted: Oct 24, 2004 11:42 PM



Reply




On Sun, Oct 24, 2004 at 11:30:19PM -0400, lg3d-interest@javadesktop.org wrote:
> my xf86Config-4 configuration file is:
I think I see.
Since the release of 0.5.1 lg3d makes use of the xorg server, not the
xfree86 x server. With this the config file has changed, it is
xorg.conf, not XF86Config-4. In terms of the configuration parameters,
they should all be the same as in the XF86Config-4 file, except that the
'keyboard' driver is no longer available and should be replaced with the
'kbd' driver, as ddew suggested.

So if you copy you /etc/X11/XF85Config-4 to /etc/X11/xorg.conf and
change the keyboard config to:
Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

You should be able to run the lg3d-session.

Hope that helps,

Kirk

---------------------------------------------------------------------
To unsubscribe, e-mail: interest-unsubscribe@lg3d.dev.java.net
For additional commands, e-mail: interest-help@lg3d.dev.java.net







masdc


Posts: 8
From: Colombia
Registered: Oct 24, 2004


Re: error trying to run lg3d-session

Posted: Oct 25, 2004 1:01 PM



Reply




Hi Kirk:

yes, that was the error. I copy the file to xorg.conf and changed the Keyboard driver and it worked. Thank you so much.

Thanks also to David.

Bye,
 
Old 11-07-2004, 10:42 PM   #6
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
OPjose,

When I type startx in login screen area I get the following error - that /etc/X11/xorg.conf is incomplete, it says at least one Device section is required. Atleast one device section is required. EE Problem parsing the config file, EE Error parsing the config file. Fatal server eror: no screens found, Please consult the X.Org Foundation support at http://wiki.Org for help also check the log file at "/var/log/Xorg.0.log" for additonal information. X10: fatal error 104 (Connection reset by peer) on xserver "0.0" after 0 requests (0 unknown processed) with 0 events remaining.

d-1
 
Old 11-08-2004, 01:37 AM   #7
allforcarrie
Member
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 157

Rep: Reputation: 30
Are you running onboard sound on your soyo board?
 
Old 11-08-2004, 05:14 AM   #8
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Quote:
Originally posted by dolphans1
OPjose,

When I type startx in login screen area I get the following error - that /etc/X11/xorg.conf is incomplete, it says at least one Device section is required. Atleast one device section is required. EE Problem parsing the config file, EE Error parsing the config file. Fatal server eror: no screens found, Please consult the X.Org Foundation support at http://wiki.Org for help also check the log file at "/var/log/Xorg.0.log" for additonal information. X10: fatal error 104 (Connection reset by peer) on xserver "0.0" after 0 requests (0 unknown processed) with 0 events remaining.

d-1
Hmmm...

XFDrake should rebuild the file for you automatically whenever you select a new or different video card.

Also you should be able to delete the file and then run XFDrake which is supposed to rebuild it as needed.

You can always test the configuration(s) by typing X at the prompt, after shutting down the X display manager with

service dm stop

It sounds like the XFDrake command may not be correctly building the configuration file.
 
Old 11-09-2004, 05:45 PM   #9
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
Here is where I stand today. I installed "Thiz-Linux" 7.0 and it installed perfectly. Now Thiz-Linux does not have the NVIDA driver modules. The kernel version is 2.4.18-12Thiz and may explain why. So I can boot into Windows and Thiz, but not Mandrake.

d-1



Quote:
Originally posted by opjose
Hmmm...

XFDrake should rebuild the file for you automatically whenever you select a new or different video card.

Also you should be able to delete the file and then run XFDrake which is supposed to rebuild it as needed.

You can always test the configuration(s) by typing X at the prompt, after shutting down the X display manager with

service dm stop

It sounds like the XFDrake command may not be correctly building the configuration file.
 
Old 11-09-2004, 07:06 PM   #10
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Mandrake also provides the correct modules and drivers, but unfortunately only on the "official" release disks and powerpacks.

This makes the community edition somewhat difficult for a first time user... sigh.
 
Old 11-14-2004, 09:27 AM   #11
allforcarrie
Member
 
Registered: Sep 2004
Distribution: Ubuntu
Posts: 157

Rep: Reputation: 30
http://www.linuxquestions.org/questi...hreadid=248323 This may help.
 
Old 11-15-2004, 06:27 PM   #12
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
Thanks for your message. Just to set the record straight, I have Mandrake 10.1 Official DVD. I read that thread and it appears he never solved his problem with his sound. I am trying to locate and different motherboard and see if that works....

Any suggestions on any other boards that may be compatable?

I called Soyo and they had not clue and to what is going on.

d-1




Quote:
Originally posted by allforcarrie
http://www.linuxquestions.org/questi...hreadid=248323 This may help.
 
Old 11-15-2004, 07:24 PM   #13
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Under the Intel realm I haven't had any problem with motherboards based upon the following chipsets.

Intel 815
Intel 845
Intel 850
Intel 865
Intel 875

All hardware seem to be supported, even using the (lame) on board video and sound when purchased that way.

Also remember that the HCL (Upper right side of this page) also lists user success with different motherboards.

Remember though that often the people who post the HCL reviews are not looking to far past getting Linux up and running.

E.G. they are not posting the hardware list to determine if ALL mainboard components are recognized (which they should).

With the above chipsets and the later kernels, I see no unsupported devices appearing.
 
Old 11-16-2004, 06:57 AM   #14
dolphans1
Senior Member
 
Registered: Jun 2003
Location: LoneStar
Distribution: Mandriva & Ubuntu
Posts: 1,040

Original Poster
Rep: Reputation: 35
Do you then recommend running Intel over AMD? Also do you know what type of motherboard you have?

d-1


Quote:
Originally posted by opjose
Under the Intel realm I haven't had any problem with motherboards based upon the following chipsets.

Intel 815
Intel 845
Intel 850
Intel 865
Intel 875

All hardware seem to be supported, even using the (lame) on board video and sound when purchased that way.

Also remember that the HCL (Upper right side of this page) also lists user success with different motherboards.

Remember though that often the people who post the HCL reviews are not looking to far past getting Linux up and running.

E.G. they are not posting the hardware list to determine if ALL mainboard components are recognized (which they should).

With the above chipsets and the later kernels, I see no unsupported devices appearing.
 
Old 11-16-2004, 03:45 PM   #15
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
I'm not particularly recommending one over the other, just relaying my experiences.

I often deploy Linux systems as boundry servers and for other tasks.

I tend to stick with the more conservative Intel approach as these things end up running 24/7 w/o any user intervention whatsoever. To make my life easier I need these things running flawlessly. Usually they are only noticed when someone stupidly disconnects the machine(s).

I've used just about every Intel manufactured motherboard which use the listed chipsets w/o any problems and with seemingly full support by the kernel, especially the later ones.

That said, I've also have had sucess with non-intel boards (which I usually do not use for servers) set up as workstations, that employ the same Intel chipsets.

Go to the Intel Products page and select any Workstation and Server board based upon everything from the 440bx up thru the 875 series, and I've used them with Linux w/o problems. Even those server boards with dual 10/100baseT and Gigabit Ethernet interfaces built in work fine.

I have not yet tried the 9xx series with the newest prescotts.... so I don't know how the PCIe units will behave.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Soyo Dragon 2 Lan driver help fifthgear Linux - Hardware 10 05-24-2005 08:09 AM
Sound with Soyo Dragon Plus MB AMD arst05 Fedora 0 11-30-2004 07:39 AM
Problems with nVidia drivers on Soyo KT600+, Apollo FX5200 PeaceTank Linux - Games 5 03-20-2004 07:46 PM
Soyo KT400 Dragon Ultra SLaCk_KiD Slackware 4 01-31-2003 05:13 PM
Soyo Dragon Lite and Raid FunkyBunnies Linux - Hardware 0 12-26-2002 06:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration