LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-23-2004, 05:24 PM   #1
fadedmaster
LQ Newbie
 
Registered: Jan 2004
Posts: 6

Rep: Reputation: 0
Unhappy Sound not working on CrystalClear SoundFusion


Alright, I'm very new to Mandrake Linux. I just got it installed and the sound isn't working. I can find it in the Control Center, but when I try to change the volume or do anything involving audio, I get the following error message:

"Couldn't open mixer device /dev/sound/mixer"

I've read a lot of stuff about how to fix this, and don't understand a lick of it. From what I understand it's a problem with kernal, or from what I can gather anyways. I was wondering if there was a way to fix this. And if you could, please tell me in terms I'd understand.
 
Old 01-26-2004, 10:02 AM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Does it say "Permission denied"?

Could be that you need to give yourself permission to access the /dev/dsp, /dev/mixer, /dev/midi etc devices.

As root, do:
adduser some_user audio
chmod g+rw /dev/dsp /dev/mixer /dev/midi

This assumes your devices are of group audio, which they shoudl be. the chmod should also be redundant, but just put it there for kicks.

--Rounan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel sound not working, usb modem not working. siriusb Linux - Hardware 8 03-04-2006 11:16 PM
Sound not working in GNOME but sound card test works saravkrish Linux - Hardware 3 02-08-2006 12:03 PM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 02:02 PM
Crystal SoundFusion Sound Card Help ArcLinux Linux - Hardware 1 07-12-2005 11:13 PM
Sound was working.. rebooted.. alsa start errors... no sound now.. Zero-0-Effect Linux From Scratch 5 03-21-2004 10:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration