LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 08-05-2004, 10:53 AM   #1
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Rep: Reputation: 15
Sound Card


I cannot get the sound to work, in the configuration it has the correct driver and it has to be initialised (aTs) I have gone to System/ Configuration/KDE/Sound/Sound System but cannot find aTs to initialise it, can anyone help.. It is an Audigy card and I am using the Audigy driver.
 
Old 08-05-2004, 10:57 AM   #2
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
run aumix, set the levels, save the levels. aumix (if installed) is in kicker->multimedia->sound. if it's not there, then install it from the MDK CD's. either use urpmi aumix (from terminal as root) or MCC->software management->install.

if that didn't fix things, also check in KDE Kontrol Center->sound & try different sound drivers (arts, oss, etc.)

otis
 
Old 08-05-2004, 11:10 AM   #3
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Original Poster
Rep: Reputation: 15
Still no good, what I am trying to find is how to initialise arts .

Last edited by trackrat; 08-05-2004 at 11:25 AM.
 
Old 08-05-2004, 11:37 AM   #4
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
from terminal as root........

service alsa start

or.........

alsamixer (for mixer)

or.........

alsaplayer (for player)

oops........... you said aRts, not alas. use KDE Control Center->sound. choose arts, set the various actions you want. (i forget what they are right now........i'm at work). i think there's also a service for it in MCC->system->services, but not sure.

otis

Last edited by otish1000c; 08-05-2004 at 11:41 AM.
 
Old 08-05-2004, 11:44 AM   #5
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Original Poster
Rep: Reputation: 15
I think I am having a braindead day I opened a console went to root and typed alsa service start and got bash alsa command not found
 
Old 08-05-2004, 11:51 AM   #6
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
service alsa start

not

alsa service start

and make sure you are root.

otis
 
Old 08-05-2004, 12:01 PM   #7
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Original Poster
Rep: Reputation: 15
Told you I was having a braindead day when I retyped it it said the service was allready running, but still no sound. I have tried other drivers but no luck.
 
Old 08-06-2004, 07:12 AM   #8
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
is this card integrated with the board, or an add on? if it is an add on, do you also if have an integrated sound device? if so, it's prolly causing a conflict & you'd need to turn off the integrated one in the BIOS.

if that's not the case, please post the exact card make/model. if it's an Audigy SBlive card, you may want to try the emuk101 drivers. if it' an older ISA slot/integrated card, you could also try running from terminal as root sndconfig & see if it detects that card.

otis
 
Old 08-06-2004, 11:53 AM   #9
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Original Poster
Rep: Reputation: 15
The card is an Creative SB Audigy live.
I tried the emuk101 drivers but still no good.
 
Old 08-09-2004, 06:27 AM   #10
zero0w
Member
 
Registered: Aug 2003
Posts: 76

Rep: Reputation: 15
Try lspci and post the information here:

$ lscpi
 
Old 08-09-2004, 07:26 AM   #11
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Original Poster
Rep: Reputation: 15
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS]: Unknown device 0963 (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0016
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 90)
00:0b.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
00:0b.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03)
00:0b.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port
00:0d.0 Unknown mass storage controller: Integrated Technology Express, Inc.: Unknown device 8212 (rev 11)
01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0342 (rev a1)
 
Old 08-09-2004, 10:58 PM   #12
zero0w
Member
 
Registered: Aug 2003
Posts: 76

Rep: Reputation: 15
Well it looks like your soundcard should be well supported w/ ALSA under Mandrake Linux >=9.1

Try this

$ su
# modprobe snd-emu10k1

See if there's any response from the soundcard.

Note: snd-emu10k1 and emu10k1 are different drivers: all ALSA modules starts with snd- while other non-ALSA modules without it.

If it works, then in Mandrake specific configuration tool, you can try:

# draksound

And then choose 'snd-emu10k1' as the sound module.

Also, make sure 1) you have disabled the onboard sound, if any existed; 2) your mixer (eg. Kmix) is not muted when you are trying to play audio to test your Audigy card.

Last edited by zero0w; 08-09-2004 at 11:02 PM.
 
Old 08-10-2004, 07:36 AM   #13
trackrat
Member
 
Registered: Feb 2004
Location: Birmingham UK
Posts: 148

Original Poster
Rep: Reputation: 15
Tried modprobe - no response, checked Kmix and it was muted so I put that right..
The driver was audigy so I changed it to snd-emu10k1 but it still will not work.
The problem is it says I have to start aRTs but I have followed the route given in a mandrake magazine but cannot find aRTs to initialise it.
Thanks for your help, have you any more ideas, I am sure it is something simple that I just cannot see.

Last edited by trackrat; 08-10-2004 at 07:37 AM.
 
Old 08-10-2004, 07:41 AM   #14
otish1000c
Member
 
Registered: May 2004
Location: Pennsylvania, USA
Distribution: dual boot.... Mandrake 10.0OE/10.xcooker
Posts: 611

Rep: Reputation: 30
some parts of aRts may need to be installed, as they aren't during a normal install (even if you select all apps during the install process). use MCC->software installer, type arts in the search, install all arts related packages. you can choose arts through KDE's Kontrol Center->sound module. there are also aRts controls in kicker->multimedia->sounds, provided you have them installed.

otis
 
Old 08-10-2004, 11:42 AM   #15
zero0w
Member
 
Registered: Aug 2003
Posts: 76

Rep: Reputation: 15
Quote:
Originally posted by trackrat
Tried modprobe - no response
If it has no error message, that means the module is working
No response is a good sign.

Quote:
The problem is it says I have to start aRTs but I have followed the route given in a mandrake magazine but cannot find aRTs to initialise it.
Well aRTs initialised fine in my case as I see it running under GNOME System Monitor. So I am not sure what else went wrong. But I recommend you to stick with 'snd-emu10k1' driver as I can confirm it works for SB Audigy - and it has other feature such as MIDI support.

Don't know if it would help, but you may want to look at this ALSA wiki page:

http://alsa.opensrc.org/index.php?page=emu10k1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-31-2005 12:35 AM
sound card help ESS1978 Sound Card - maestro driver fatrandy13 Linux - Hardware 1 05-03-2005 02:43 AM
Changing primary sound card or disabling a sound card tfr Linux - Hardware 2 02-10-2005 09:33 AM
If you have a PCI sound card, should you disable the on-board sound card? jtp51 Linux - Newbie 1 10-06-2004 11:42 AM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 03:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration