LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Sound Blaster Live! Audio Problem in Mandrake 10CE (https://www.linuxquestions.org/questions/mandriva-30/sound-blaster-live-audio-problem-in-mandrake-10ce-187182/)

DaveThePuzzled 06-04-2004 08:27 PM

I did go into Harddrake and under the config tool for sound, it does provide a few troubleshooting steps and it did mention something about the runlevels and for alsa, 3-5 are on for sound and alsa. But I will shuffle through the filesystem and see what I can find.

DaveThePuzzled 06-04-2004 08:32 PM

I did find the file, it is called alsa under /etc/rc.d/init.d and it is a bunch a C/C++ language which I have no idea how to read it to determine what to do with it.

DaveThePuzzled 06-04-2004 09:07 PM

One last thing then I am giving up for the day.......would it be easier or better to get a Sound Blaster Audigy card.....and another I have been meaning to ask about....you know how Dell was/is using untrue Sound Blaster cards...that they use a different chipset....referred to as EMU10K1X?? I go into alsamixer and it tells me the chipset says Sigmatel STAC9721/23. Does anyone know anything about that chipset...and where in the ALSA website do I find anything about the chipset that Dell uses?? I want to do some definate comparisons so I can see if my card is compatible and would work because I get no errors....it just looks like it is muted....even aRTs shows some response but still no sound. I turn down and then up the volume and I get the thump....I have even tried different jacks on the sound card but still no sound so I think I am in the right jack because of the colors matching...from the speakers to the jack itself.

Anyway...let me know

bibilit 06-05-2004 02:21 AM

Hi,

Audigy card is using the same module as the one you have, you will probably have the same trouble anyway ( except if the problem is coming from the Dell source).

One thing strange about your modules is :

alias char-major-14 soundcore
alias sound-slot-0 snd-emu10k1

should be

alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

Is all i see strange, the other thing is strange to me is that you cannot play any cd - don't need to have sound modules fixed, to have sound from your cd player ... everything was wrong for me except that, and get sound as long as the fine cable to the mother board was connected !!

DaveThePuzzled 06-05-2004 02:39 PM

And I have a cable going from the CD drive to the sound card and it is connected correctly too....so that is strange then....now bibilit, what if I were to make those changes in /etc/modules.conf, would that change anything??

DaveThePuzzled 06-05-2004 03:14 PM

Well....lets just say that it didn't.....I even double-checked my cd cable and still nothing....ya know....I am tired of this....I am just going to go back to WinXP and stay there....no one has been of any help....well...I don't mean that, you guys have been of help but no progress whatsoever so I am going back to WinXP and staying there....I'm tired of dealing with this crap.............................

Nubbin49 06-29-2004 09:44 PM

Same Problem as this guy
 
OK, I have the same problem as this guy and have done all the things that sounded promising with no results. . . one thing that I noticed when looking at alsamixer is that my motherboard integrated sound card is listed at the top as the driver used and I havn't found a way to view emu10k1 settings in the alsamixer. The crazy thing about this problem is that when I first installed Mandrake I would have sound. I don't have it anymore except this REALLY loud and REALLY annoying beeping noise that is constant until the GUI is started.

--Nubbin

bibilit 07-03-2004 12:16 PM

Did you try using OSS, can be the solution ( was for me )

MDK control center>sound> and change to Oss

nemoswitch 07-03-2004 03:07 PM

Quote:

Originally posted by bibilit
Did you try using OSS, can be the solution ( was for me )

MDK control center>sound> and change to Oss

I agree with your there. I have ran man 9.2 and even 10. but here. snd-emu10k1 does not work. But the emu10k1 driver works very well. never had a problem with it. snd-emu10k1, it would load and all that. but no sound. sorta like the other person is experiencing. Now with XP. to listen to a audio CD. that is not a mp3 cd. I am talking about a standard audio cd. XP & even ME. has not used the audio cable from the cdrom to the soundcard, It may use it as a last resourt. though, It has not used it for awhile.
I may get flamed for that. Oh well. I do not use a audio cable between the cdrom and the soundcard. I never bothered to put one in anymore due to XP doing this. So saying that you get sound from XP with a audio disk. does not really mean much if it was a audio cd. Now mandrake. I have seen some volume mixers that had cd audio disabled. That was kde though. back to the snd-emu10k1, and emu10k1 drivers. I have a few machines that I threw mandrake on, as well as other linuxes/Freebsd. These all used sb live cards. None would work with snd-emu10k1 driver. About 5 different machines. Maybe "Canada made" SB live cards were a touch different. I don't have a answer for that. Sometimes in verbose boot. the driver would sometimes say OK. or it would say FAIL. OSS does work well. Except in wine. where you have to create a new symbolic link. Since it uses the old symbolic links for other mandrakes/linux's.

I hope you get it to work.

DaveThePuzzled 07-04-2004 02:11 AM

I found out what my problem was. It is my speakers....not the modules. My speakers are set up for a digital output but when I attach a standard cable with two 3.5mm male connectors from my PC to my speakers, they work!!

Thanks All!
DaveThePuzzled
:newbie:
:D :D :D

nemoswitch 07-04-2004 02:39 AM

:) good to hear that you got it to work :P

bibilit 07-04-2004 06:40 AM

Pleased to know about it.

Cannot understand why wasn't working, all information was present !

motub 07-04-2004 07:52 AM

:D Sometimes, it's the simple things......

Glad you've got sound now! :)


All times are GMT -5. The time now is 03:55 AM.