-   Mandriva (
-   -   Sound Blaster Live! Audio Problem in Mandrake 10CE (

DaveThePuzzled 06-03-2004 06:32 PM

I went into the console, ran xmms as ROOT and tried to play a song from XMMS and did not hear any sounds or music. I have a dual boot with WinXP and sound works perfectly from audio CD to wave music and mp3's but nothing from Mandy so it cannot be cable connections. I open my computer and have done so twice in the last week to check my card, to see who the manufacturer is, get numbers and things off of the card itself and seems to be authentic. I have even so much as disconnected and reconnected my speakers to make sure they are connected and make sure there is a truer connection. Everything is unmuted, I even made sure aumix was installed and made sure everything was unmuted and turned up to 100% there

As far as MDK doing the changes in /etc/modules.conf, I do the changes, MDK does not do any changes. I even reboot after doing the changes manually and it does nothing.

The following lines are the output of lsmod having to do with sound, that I could tell.

emu10k1 69348 1
soundcore 9248 2 emu10k1
ac97_codec 17804 1 emu10k1

This is the modified changes to /etc/modules.conf that are in effect right now.

alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

Just to make sure you know, I know A LOT about computers and I know how to edit and make changes to things. I am learning more and more about Linux and I love it other than having sooooo much trouble with my sound card that I am ready to just dump my current card and get another card.

ANY help would be greatly appreciated from ANYONE on this issue.

bibilit 06-04-2004 02:20 AM

Thanks for the reply.

I'm not a100 % sure but your modules are strange, as far as i can see the portion you gave to me is for oss, not alsa.

Moreover, if it 's for oss... a part of it is missing !!

Not so long ago i was in the same boat as you are now.

Did you see anything in dmesg telling you the sound card was detected ??

bibilit 06-04-2004 02:30 AM

Just something else, did you try to play a cd with Kscd... you always try with xmms.( try another player )

Also, is xmms set to play with alsa or oss ?? go to options in xmms and try a change.

Last thing, in kde control center you should find something like files association > sound ... is everything associated ??

DaveThePuzzled 06-04-2004 04:02 AM


Yes, the sound card is detected. Here is the lines saying it was detected.
Creative EMU10K1 PCI Audio Driver, version 0.20a, 07:21:39 Mar 2 2004
PCI: Found IRQ 10 for device 0000:00:0f.0
emu10k1: EMU10K1 rev 7 model 0x8031 found, IO at 0x10a0-0x10bf, IRQ 10
ac97_codec: AC97 Audio codec, id: 0x8384:0x7609 (SigmaTel STAC9721/23)

XMMS is using OSS. I did go into KDE Control Center and it was set for ALSA but changed that to OSS and still did nothing. I checked on those associations and not all of them were associated. What does associations have to do with not getting sound??

motub 06-04-2004 04:42 AM

OK, yes, you are using the OSS driver; the OSS driver is emuk101 and the ALSA driver is snd-emuk101.

billibit is right, it certainly looks like part of your /etc/modules.conf is missing, most notably

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

(This is an ALSA setup, and even were you using ALSA, you might not have all of these, as I have a different card from you, but you should have snd-mixer-oss, snd-seq-oss and snd-pcm-oss at least once)

Basically you've loaded the drivers, but no modules to access the sound card via the mixer, sequencer or volume.

Have you run sndconfig to configure the OSS driver?

The thing is, though-- you're using the 2.6 kernel, and if you're using the 2.6 kernel, you should be using ALSA and OSS emulation (OSS is deprecated and moving swiftly towards obsolete).

You should in fact not have any OSS drivers enabled (I don't even have OSS core enabled in my kernel).

Here's my modules.conf (for a VIA 8233 onboard sound chip, under Gentoo, 2.6.5 kernel):


# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##  ALSA portion
alias snd-card-0 snd-via82xx
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
##  OSS/Free portion - card #2
## alias sound-service-1-0 snd-mixer-oss
## alias sound-service-1-3 snd-pcm-oss
## alias sound-service-1-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

### modules-update: end processing /etc/modules.d/alsa

bibilit posted the settings for your card, as listed on the ALSA site, previously.

I would suggest that you switch back to the ALSA driver (snd-emuk101), via either HardDrake or a kernel recompile (it can't use the OSS drivers if they aren't there, after all), run alsaconf if available (if not, install the alsa-utils package; the kernel only has the drivers, not alsa-libs or alsa-utils) and/or edit modules.conf to conform with the ALSA settings given by bibilit, and see what happens.

bibilit 06-04-2004 03:45 PM

You are very close i think.

Card is detected as that is a good point.

Concerning file association, try to associate all related files ( all sound files ) with your player ( wav,...)

You did not say if you get sound with Kscd, probably not, that was the first step for me.

Good luck.

bibilit 06-04-2004 03:56 PM


Found that on Oss site, maybe can help :
This document is for the SBLive soundcards that come pre-installed
in some Dell machines. Due to differences with the standard SBLive
and Audigy soundcards, we call this the EMU10K1X device.

- The analog front and rear speaker signals will get mixed together (both
signals can be heard from both speakers).

- There is no volume control for PCM rear or PCM Center/LFE channels.

- No S/PDIF mixer support.

Channel allocation:
/dev/dsp0 is front playback and recording.
/dev/dsp1 is rear playback.
/dev/dsp2 is center/lfe.

There is one options.cfg setting. emu10k1x_spdif_enable=0 disables S/PDIF
and enables the analog center/lfe output (digital center/LFE output will
always work). emu10k1x_spdif_enable=1 (default) enables S/PDIF and
disables analog center/LFE.

If somebody using same or analog device can give you some clues !!

DaveThePuzzled 06-04-2004 05:48 PM

KsCD does not give any sound either....

motub 06-04-2004 06:00 PM

Yes, but that could also be due to the lack of an audio cable (is there a thin cable plugged into your CD-ROM that connects to a pair of pins on your sound card? Such a cable is necessary to hear CD audio direct from the CD-ROM drive generally, though they are becoming obsolete, slowly).

DaveThePuzzled 06-04-2004 07:03 PM

Yes, there is a cable from both CD-ROMs to my cd connections to my sound card because I get sound from a CD-ROM in WinXP. My prob is probably going to be either a module or driver problem. Everything works as far as sound in WinXP, CD, Wave, everything but not in Linux.

DaveThePuzzled 06-04-2004 07:08 PM

I ran alsaconf and it reconfigured and filled in the /etc/modules.conf file and looks good, like...
probeall scsi_hostadapter imm ppa
probeall usb-interface usb-uhci
alias eth0 sundance
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-emu10k1
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-emu10k1

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
above snd-emu10k1 snd-pcm-oss

Looks complete like biblit's post on the first page of this thread. I still do not have sound and have gone through and made sure that everything was unmuted and turned up as high as possible.

motub 06-04-2004 07:40 PM

And that your speakers are plugged into the right port, I presume ;) ?

Errors? Or just no sound? Do you have sound as root?

Basically, we're just going to go through the troubleshooting steps again, to see if we have any improvement whatsoever, so please be patient :) . Or... even more patient.

DaveThePuzzled 06-04-2004 07:53 PM

No sound...not even as root, no sound. Speakers are plugged in correctly because occasionally, I do get a like popping sound, more like a thump....I also went in a did alsactl restore and Master and PCM came up muted so I went into alsamixer, made sure they were unmuted and did alsactl store to make sure it stores that info and I am going to reboot to see if it does anything there.

DaveThePuzzled 06-04-2004 07:54 PM

Believe me, I have a lot of patience but I can tell you that it is wearing thin but I will do my best to have tons more patience

motub 06-04-2004 08:11 PM

OK, the thump thing is good. That's a channel initializing, but kind of incorrectly, so it's not passing the sound through properly, but at least it's there.

Don't worry about your patience; getting sound working under Linux is more often than not much much more trouble than any reasonable or unreasonable person should have to deal with for something so relatively stupid. We all like music, but let's face it, it's not literally essential to the operation of the system as a whole.

OK, back to the issue at hand.

Now I hate to tell you, but your reboot may have done you no good, because alsactl store is really only useful if alsactl restore is run at boot (or shortly thereafter). The loading of ALSA drivers and the restoration of the ALSA mixer levels saved at shutdown is supposed to be handled by a script, which should be somewhere in wherever Mandrake keeps its list of daemons (services, in Windows terms) that are to be run at the various stages of startup.

Off the top of my head I don't know where this is, but I'm almost positive that there is a Runlevel Editor somewhere in the Mandrake Control Center (or in Linuxconf, which is also installed by default iirc).

That's the good news. The bad news is that I don't know what Mandrake calls this script (though it obviously is going to be called something containing "alsa"). On Gentoo, it's called "alsasound". Under Mandrake it might just be called alsa. Anyway, this thing needs to run during the boot process, probably should be set to the boot runlevel or runlevels 3 through 5... it depends on how Mandrake 10 is organized-- I didn't use it long enough to take much note of the differences between 9.2 and 10 in this respect, and I didn't have sound problems, so I didn't look to see where things were stored or what they were named.

So if you don't feel like trawling around through your filetree, you can, as an alternative task (should you choose to accept it), go through the KDE Control Center=>Sound and Multimedia=>Sound I/O, the XMMS preference menu, and the Options menu of any other sound apps you might use and make sure that they are all using the ALSA plugin, or that at least aRTs is using ALSA and not Autodetect, and that the applications are then using the aRTs sound server.

In addition, you can swing by the MDK Control Center=>HardDrake and make sure that it is set to use the ALSA driver for your sound card (to prevent MDK from overwriting your manual settings).

And then do something fun having nothing to do with your PC, just for a change ;) .

All times are GMT -5. The time now is 03:08 AM.