LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Sound Blaster Live! Audio Problem in Mandrake 10CE (https://www.linuxquestions.org/questions/mandriva-30/sound-blaster-live-audio-problem-in-mandrake-10ce-187182/)

DaveThePuzzled 05-30-2004 01:58 PM

Thank you guys. I will try that and let you know how it goes. I have a friend that has a spare sound card lying around that he will give to me so I can get this working. It is maybe alittle older than the card I have, 'bout couple mos.

DaveThePuzzled 06-01-2004 02:48 AM

I did paste the above ALSA lines in modules.conf but still no sound.

Let me ask you, if I were to upgrade to the official version, could be sound card work better there?? I am asking before I upgrade so I don't have any problems there.

adz 06-01-2004 05:17 AM

I looked around and it seems that Dell soundblasters use a different chipset and are therefore not supported by the emu10k1 driver. Therefore upgrading to the official version would probably do nothing.

motub 06-01-2004 05:28 AM

No, it's really not necessary to upgrade your whole distro just for the sound card, although the Official apparently does fix a lot of bugs in CE, so you might want to upgrade for that reason.

You pasted the lines in modules.conf, but did you then reboot? Or insert the module using modprobe snd_emuk101? You really shouldn't have to do this, as your lsmod shows that the module is loaded and running (as does the fact that the sound apps do play, rather than returning errors).

/etc/modules.conf is only read at boot, so nothing would have changed simply by adding the lines to the file.

Really, really stupid question, but are your speakers plugged into the proper connector, plugged in (if necessary) and turned on?

Second, less stupid, question-- you say that you unmuted alsamixer, but have you rebooted since you did so? In order for alsamixer to retain settings, there is a script/daemon which must run at boot (alsactl). The alsactl store command stores the settings at logoff (or you can do this manually), and the alsactl restore command restores the saved settings on boot (or, again, you can do this manually). Otherwise alsamixer will revert to the only settings it knows, which atm are ... muted.

Mandrake has, in the past, been good about adding the script that runs alsactl during the boot sequence to the default runlevel, but this may be one of the little bugs that got by.

I'm not using MDK atm, so offhand I can't tell you where it lives, but I'd try running alsactl manually (store after changing alsamixer settings, then restore after a reboot) to see if that's even the issue before trying to figure out how to add the script to the boot sequence.

motub 06-01-2004 05:46 AM

Quote:

Originally posted by adz
I looked around and it seems that Dell soundblasters use a different chipset and are therefore not supported by the emu10k1 driver. Therefore upgrading to the official version would probably do nothing.
Yipes, that sucks. Is it possible that another driver supports the Dell chipset? If not (or if it's not worth looking), I guess that original idea of buying an SBLive! wasn't too far off the mark at all.

DaveThePuzzled 06-02-2004 01:48 AM

Well....I know it is a problem with Dell but my computer is a Gateway bought in 2000 and Windows recognizes it as SBLive, not Sound Blaster Live! so I am thinking it might be along the same lines of Dell, as that is why I brought that up, but I am looking to just buy a Sound Blaster Live! RETAIL box to make sure it is the REAL thing. I hate these manufacturers sometimes.

motub 06-02-2004 04:06 AM

Gateway, iirc, uses a similar technique of "re-branding" or "tweaking" hardware so that you can't use standard parts in a Gateway either-- you have to buy upgrades from them for the parts to work. For all we know, the Gateway part might have been bought from Dell and had a new label slapped on it; Dell buys a lot of parts and gets them very cheap for that reason, and what would they do with any extras but sell them to like-minded companies?

I think the easiest and most sensible all around solution is to get a real SB Live (the 5.1s and the Players are still around and quite cheap since they're getting a bit long in the tooth in terms of release cycle. But if you don't need an Audigy, I don't see why they wouldn't be just fine.

DaveThePuzzled 06-02-2004 04:28 AM

Well, as a request from a guru in this forum, I opened the case and pulled the card to look at the biggest chip on the sound card to see if it was a card like Dell uses and Creative made the card, says Creative on it and even has the driver name of EMU10K1 on it, so I think it is authentic, no some forgery that Dell/Gate use...

adz 06-02-2004 07:50 AM

Well some people have reported that messing with the 3D slider and the external amp settings did something for their sb live.

ryan00davis 06-02-2004 11:23 PM

i know for the dell card (which i have) you can get it to work by using the driver from opensound.com. the only downside is that it will only work for so long, because they want you to pay for it. i am also looking into buying a new card, i rather spend a little more money and then a new card then buy the driver, but it is a temporary fix for now. if anyone knows of a free driver for the dell soundblaster card, let me know.

ryan

bibilit 06-03-2004 01:36 AM

Did you try using OSS ??

I talked about ALSA because mdk is using it by default, but OSS can maybe your solution ( i'm using oss, alsa never worked for my sound card !! )

go to mdk control center>and try to change from alsa to oss>log out and in >report any change !

DaveThePuzzled 06-03-2004 03:23 AM

bibilit,

I only gives my a different driver to try. I doesn't tell me if it is OSS or what. It does tell me that snd-emu10k1 that it is using is ALSA and using it by default but it gives me an option for emu10k1 and audigy but neither says that it is OSS. But I will try those others, log out and restart and I will tell you what happens.

adz 06-03-2004 03:39 AM

Well you could do it manually. Remove all the ALSA drivers (all the ones starting with "snd") and do a modprobe emu10k1.

DaveThePuzzled 06-03-2004 04:14 AM

This is the message I get for trying to use OSS...

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such file or directory)
The sound server will continue, using the null output device.

So I am switching it back to ALSA where I do not have any messages come up.

bibilit 06-03-2004 03:21 PM

Did you have any changes in /etc/modules.conf when switching from alsa to oss ? ( mdk do the changes for you )

I had that message many times, until modules where right, then no more ...but get sound !! ( i'm still smilling ).

Problem with sound in Linux, is that it can be long to fix...

When everything is right, dmesg should return to you that kind of message :

emu101k: card found at 0xf11xxxxx and xxx , IRQ XX

You can try several modules until the problem is solved.

Let me know the following points :

# have you sound when root ?

# can you hear music from your cd player ( with the small wire connected )

# is everything unmuted ( kmix/aumix/alsamixer and volumes 100 % )

# output of lsmod


All times are GMT -5. The time now is 03:53 AM.