LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-05-2003, 07:49 AM   #1
prctom
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Rep: Reputation: 0
Question Sos! X /kde


Last weekend I built another PC,assembled in almost similar array of hardwares as last time, which's following:EPOX-8RDA3G plus ATI Radeon9200(AGP8X).

Having installed with Mandrake linux 9.1(3 cds, Bamboo edition) ,I downloaded "fglrx-glc22-4.3.0-1.2.0.i586.rpm" file from ATI's website and tried to install driver to ATI Radeon9200,
I started with foollowing command and carry on its instruction:
-----------------------------------------------
rpm -i --force <ati_package_name>.rpm
.............................................
----------------------------------------------
then Run fglrxconfig to configure XFree86 installation and
Responded to the questions of the fglrxconfig program
, Saved the settings to /etc/X11/XF86Config-4.

Once I tried to start KDE/X server again, always failed after many attemps of reconfig-fglrx.

Could anybody kindly help me out and grasp my desktop/monitor back? as indeed I'm not familia with those lines of linux commands.......
By the way ,the current monitor model is
"Nanao flexscan 340i-w", under win98se I set it as "800x600"/100hz (refresh rate).
is it possible to apply ithis setting under Mandrake linux 9.1?100hz 's healthy for eyes....................

Best Regards!

Tom
(e-mail: shew@hotpop.com)

5/10/2003.......
 
Old 10-07-2003, 01:06 AM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
dont know if this helps
but
installing the nvidia drivers, whether it's the new unified pkg or the old kernel and GLX pkg, they had to be installed while X was NOT running.
terminal, su to root
type
telinit 3
then install
then edit XF86Config
then
telinit 5
to go back to X

(like i say, don't know if this holds for ATI)
 
Old 10-07-2003, 08:12 PM   #3
CyberDoc
Member
 
Registered: Oct 2003
Location: usa
Distribution: slackware, ubuntu server, kali linux
Posts: 42

Rep: Reputation: 15
i would also like to add that you did a force install on the rpm. Which may or may not mean your depend's are not right i.e. your needing some other file for the driver to run you may want to uninstall the rpm and reinstall w/o the force prefix to see if it has unsatisfied dependicies if it does get the files it needs. By the way what were the output error's for X. and in the case of nvidia drivers you had to edit the xf86config file manually under device change A to B etc.... is ati the same?
 
Old 10-09-2003, 09:25 AM   #4
prctom
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Question X/KDE back but only in VESA

Hi!,

Apparently, KDE/X is back to normal by chosing the right setting of mouse under command "mcc" , althoght I had many attemps of instalation of binary driver from ATI and the only driver working is STILL Vesa.


Firstly I typed in console 'uname -a' and note the kernel version number and write this down!
2.go back into the mandrake GUI and go to Control Center, Software, Add RPM software.
3. search ALPHABETICALLY for 'kernel-source' and find the matching version number in first step . Select that version and install it.
4. after installing, go back to KONSOLE to the ATI driver file and type 'rpm -i --force <file name>.rpm'
5. it did its thing and saw a bunch of text that made no sense.
6.typed 'fglrxconfig' in the KONSOLE and went through the text based set up.

Here's screen-shot of it as following:
------------------------------------------------------------------------
root@localhost tmp]# rpm -i --force fglrx-glc22-4.3.0-3.2.5.i586.rpm
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
probing for VMA API version...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
doing script based build for kernel 2.4.x and similar
compiling 'agpgart_be.c'...
compiling 'agp3.c'...
compiling 'i7505-agp.c'...
compiling 'nvidia-agp.c'...
compiling 'firegl_public.c'...
linking of fglrx kernel module...
duplicating results into driver repository...
done.
==============================
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.21-0.13mdk/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.21-0.13mdk/kernel/drivers/char/drm/fglrx.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/drivers/char/drm/fglrx.o failed
modprobe: insmod fglrx failed
failed.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===
[root@localhost tmp]#

-----------------------------------------------------------------------------
By the way Could you give your installation process of ATI Radeon 9200SE step by step ? as I 'm not familiar with those linux command .


Expecting your Prompt reply ASAP!

Best Regards!


Tom
9/10/2003...............21:00

------------------------------------------------------------------
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Leadtek Winfast 2000 Delux on Mandriva LE 2005 in KDE - not recognized, SOS! Newbe. myongoh Linux - Hardware 0 06-19-2005 07:22 PM
DNS need help ? pls help me ! SOS SOS AngelOfTheDamn Linux - Networking 2 02-23-2004 12:13 PM
Sos milot Linux - Laptop and Netbook 0 10-16-2003 10:54 AM
Sos dahmad Linux - Newbie 6 02-25-2003 10:30 PM
sos i need help xnet_online Linux - Distributions 4 10-23-2002 01:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration