LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Shorewall, Samba, XP, Internet Sharing - MDK10 (https://www.linuxquestions.org/questions/mandriva-30/shorewall-samba-xp-internet-sharing-mdk10-192893/)

dickohead 06-13-2004 01:13 AM

Shorewall, Samba, XP, Internet Sharing - MDK10
 
I'm hoping i'm not the only person having issues with all of this! Here is the situation:

I am running dual boot MDK10/XP the other computers have XP, when i am in XP everything runs, and runs well. Yesterday, i had Samba working, i also had internet connection sharing working, but not at the same time, for some weird reason, nut now, i can ping the other machine, i can view the web page set up on it through IIS (but not in a borwser for some strange reason, it wans me to download it... retarted!), however, the other machine cannot see anything of mine, no samba shares, no web server set up (which worked yesterday), and it will occasionally ping.

It will also sometimes, see my web server, and i will sometimes see the other machines samba shares.....

If it helps - i have disabled Shorewall, as it was stopping the other computer from pinging me. I have also stopped it from booting at startup. If anyone can send me somewhere so i can figure out how the hell to share the internet connection (reliably) and use Samba (reliably) i would be very greatful!!! I had them working at one point, but not together, and now nothing is working at all, or some things will work, when others don't - it's a very confusing situation, and i think shorewall has something to do with it!

I am running MDK10 Official on an Athlon 2500, i am using KDE and SMB4k to view the samba shares (smb:/ also works in konqueror, but only when SMB4k works)

So as you can see my issue isn't a small one... but it may be the result of something i have overlooked... can anybody lend a hand?

mascdman 06-13-2004 11:02 PM

Could you explain how your computers are connected to each other and to the internet?

--mascdman

dickohead 06-14-2004 12:59 AM

The network is just a standard 10/100 NIC which i have as eth0 is connects to the other computers through my switch, and the internet is shared through me, i'm on 56k dial-up. All hardwrae has been picked up correctly and is working fine, but i am just having trouble getting linux and windows to communicate (as i have always had trouble, but now i have gotten close)

*edit*

And another thing is that when i am online, eth0 picks up an address of:
fe80::20c:6eff:fe03:b37a/64

Which is not the 192.168.0.1 it should be! Or the 192.168.0.252 that DHCP should assign it at boot time.

mascdman 06-14-2004 02:00 AM

Okay so you've got:
Code:

    56k dial-up  ---  MDK10/XP  ---  Switch  ---  Other computers
To let the other computers access the internet through the dual boot machine, run as root:
Code:

iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -A FORWARD -i eth0 -o ppp0 -m state --state NEW -j ACCEPT
iptables -P FORWARD REJECT
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

Note: the above commands don't do all the other stuff shorewall adds (bogus packet checking, etc...). They just forward traffic from your other machines to the internet and back. You should also add rules to the INPUT chain to keep stray connections from the internet out (especially with the Samba configuration I've given below)

As for the samba stuff, I set up my samba shares using webmin. I think it's installed by default on Mandrake 10.0. Clicking here should open a connection to your webmin server. Log in as root and go to Servers->Samba Share Manager then create your shares. To get mine to work, I needed to make a couple changes:
  • Under Samba Share Manager->Windows Networking Options, I changed Workgroup to be the same as the other computers
  • Under Samba Share Manager->Windows Networking Options, I changed Security to Share Level
  • Under Under Samba share manager->Share Name->Security and Access Control, I set Guest Access to Yes
Note: This should allow anyone on your Workgroup to access and make changes to anything in that share. I tried to get individual user accounts to work, but I couldn't get the passwords to work properly (the user names were valid, but I couldn't figure out where the passwords were stored). My setup was "good enough" since I could trust everyone that had access (connections from anyone else were blocked by iptables). If anyone else knows how to get user accounts working, let me know or post a link.

To access Samba shares on your other computers, assuming they'll allow you to connect, you can use DrakConf. It's in the Applications->System->Configuration->Configure Your Computer menu. Click on Mount Points->Samba Mount Points then choose Search Servers. A list of available shares should pop up and you can configure mount points for them. (I've done this for NFS shares, but not Samba shares)

--mascdman

dickohead 06-14-2004 02:09 AM

that's all god and well.. .but iptables and dhcpd won't start... what now?

mascdman 06-14-2004 02:17 AM

Are there any error messages given by either one?

--mascdman

dickohead 06-14-2004 02:23 AM

yes, they both say failed to start, and dhcpd gives me this:

Internet Software Consortium DHCP Server V3.0.1rc13
Copyright 1995-2003 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP
/etc/dhcpd.conf line 8: expecting a parameter or declaration
option domain-name "dicko.net";;
^
Configuration file errors encountered -- exiting

If you did not get this software from ftp.isc.org, please
get the latest from ftp.isc.org and install that before
requesting help.

If you did get this software from ftp.isc.org and have not
yet read the README, please read it before requesting help.
If you intend to request help from the dhcp-server@isc.org
mailing list, please read the section on the README about
submitting bug reports and requests for help.

Please do not under any circumstances send requests for
help directly to the authors of this software - please
send them to the appropriate mailing list as described in
the README file.

exiting.


And iptables, under mandrake control centre services, is listed as stopped, but to start on boot, and it never gives me a failed message on boot....

dickohead 06-14-2004 02:30 AM

masquerading is also already set up, and it was working. See- i had the entire entwork running very well, it shared the internet, samba worked and everything, but now nothing will work - and i've not changed a thing. DHCPD won't start, but it did, samaba won't list the other computers, but it did, and ping doesn't work either way, but it did..... :(

mascdman 06-14-2004 02:48 AM

That extra semi-colon on line 8 may be the problem for the dhcpd (I'd need to see more of the configuration). For iptables not starting, run
Code:

/etc/init.d/iptables status
as root.

--mascdman

dickohead 06-15-2004 03:32 AM

after playing around with DHCP i have discovered that when and if DHCP works - so too does everything els,e but for some reason, it doesn't like starting unless i reconfigure the NIC and internet connection sharing each time. So for now, i will just leep doing this, untill i can find a better soultion, and hopefully understand better how shorewall, internet connection sharing and dhcp work together.

Thank you very much for your help! It was greatly appreciated and Webmin is proving to be a valuable resource!

Thank You.
Dickohead.


All times are GMT -5. The time now is 02:23 PM.