LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-22-2004, 09:37 PM   #1
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Rep: Reputation: 30
Screensavers refuse to run


I'm running mandrake 10.1 Community and I cannot get any of the screensavers to start automatically. The display gets blanked and locked, but nothing is displayed on the screen.

In the KDE Control centre i can choose the screensaver, and preview it, and see it's tiny preview in the control centre, and even configure it, but no matter what I try i still cannot get the things to run.

Any ideas??
 
Old 10-22-2004, 09:41 PM   #2
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Yeah this is a permissions issue not yet fixed in 10.1 CE (likely to be fixed in the Official release).

Try running xscreensaver-demo or xscreensaver-command as root for information on what the screensavers require.

Read the warning messages it will pop up.
 
Old 10-22-2004, 09:46 PM   #3
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
check this out --->http://www.jwz.org/xscreensaver/faq.html#root-fail

instead of Xscreensaver
u can use Xlockmore --->http://www.tux.org/~bagleyd/xlockmore.html
 
Old 10-23-2004, 08:43 PM   #4
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Original Poster
Rep: Reputation: 30
The messages given by xscreensaver-demo and xscreensaver-command when run as root weren't helpful. Running them as a non-root user gave the same error messages, that the xscreensaver daemon wasn't running and did i wish it to be started. Saying yes to that still made no difference, neither did giving root access to my non-root user display.

I'm totally lost now. Perhaps a regression to 10.0 Official is in order....

Last edited by nafan; 10-23-2004 at 08:44 PM.
 
Old 10-23-2004, 09:03 PM   #5
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
I am using xscreensaver on my system under Mandrakelinux 10.1 (Community) with no troubles at all. If you want the xscreensaver software to start at every boot, create a text file named start-xscreensaver.sh containing the following command:

xscreensaver -nosplash

put the file in ~/.kde/Autostart

This presumes you are using the KDE desktop. This command starts xscreensaver with no splash screen. If you want to see the splash screen at system start, do not include the -nosplash part.

HTH,
 
Old 10-23-2004, 09:09 PM   #6
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Quote:
Originally posted by nafan
The messages given by xscreensaver-demo and xscreensaver-command when run as root weren't helpful. Running them as a non-root user gave the same error messages, that the xscreensaver daemon wasn't running and did i wish it to be started. Saying yes to that still made no difference, neither did giving root access to my non-root user display.

I'm totally lost now. Perhaps a regression to 10.0 Official is in order....
This should have taken you to information about fixing the permissions so that what the prior posted mentioned would NOT have been required.

Did you see the references to this in the error messages?

Usually it's pretty obvious about this.
 
Old 10-24-2004, 06:45 AM   #7
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Original Poster
Rep: Reputation: 30
opjose There were *NO* other error messages.

ernie The xscreensaver daemon is already running as I started it manually when given the option after running screensaver-command

Sod it. Something is rotten in my system so I'll be reformatting this PC later this afternoon
 
Old 10-24-2004, 07:43 AM   #8
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Weird.

Usually in the text console from which you launched xscreensaver-demo, you'll see it complaining about the permissions and it gives you several suggestions on how to fix this.
 
Old 11-13-2004, 08:33 AM   #9
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Original Poster
Rep: Reputation: 30
After downloading the 10.1 Official CD's and 1 reinstall later the problem still existed. After a bit of messing about, and making the script to start the xscreensaver daemon when I login, I eventually got it working. I found that I had to uncheck the boxes in the KDE screensaver control panel otherwise nowt happened.

I also created two new application links for my desktop, one pointing at xscreensaver-demo to let me choose which screensaver(s) to run, and theit timeout options. The other link pointed to a little script that waited 5 seconds and then ran "xscreensaver-command -lock" to start the screensaver immediately and have it lock the desktop.

It's just a pity that xscreensaver isn't better integrated with KDE as it was in the past.

Thanks to opjose and ernie for their help
 
Old 11-13-2004, 08:48 AM   #10
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
I tried out xscreensaver briefly--no great problems getting it to run--but was disturbed at how hot it made the CPU run with all the graphics/computation intensive work it was doing. So though some of the screensavers were VERY pretty and I really liked seeing them, I went back to xlockmore, which runs cool even if it's not as cool to look at!
 
Old 11-13-2004, 05:01 PM   #11
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Most but not all of the xscreensavers are now part of the KDE distribution and should show up in the KDE control panel.

Except for Atlantis (which runs poorly for some reason) all of these barely increase CPU utilization on my GoFX5700 equipped laptop.

How little CPU utilization they use seems to depend upon how much work can be offloaded to the GPU.
 
Old 11-13-2004, 05:47 PM   #12
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by opjose


Except for Atlantis (which runs poorly for some reason) all of these barely increase CPU utilization on my GoFX5700 equipped laptop.

How little CPU utilization they use seems to depend upon how much work can be offloaded to the GPU.
I never thought of that. I have a pretty primitive graphics setup, ATI Rage 128 and that's about it. Probably more sophisticated graphics hardware would incrase efficiency a lot.
 
Old 11-14-2004, 05:15 PM   #13
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by opjose
Most but not all of the xscreensavers are now part of the KDE distribution and should show up in the KDE control panel.
They show up ok, the mini-previews go ok, the settings are changeable, but it just don't start by itself, nor do they start when the preview button is clicked. This might be more of a Mandrake cock-up though...
 
Old 11-14-2004, 07:30 PM   #14
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
You might check to see if the screensaver service is set to start at boot, and is running, by using the Mandrake Control Panel. Click on "start" if it shows it in the list and shows it "stopped." Then try your menus again.
 
Old 11-15-2004, 12:32 PM   #15
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Original Poster
Rep: Reputation: 30
jonr, that could be quite difficult, as there is no screensaver service. Neither is there a control script in /etc/rc.d/init.d/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
some programs refuse to open dianat100 Linux - Newbie 5 06-08-2005 06:29 AM
No Screensavers. Screensavers Diaspearerd! raid517 Linux - Software 1 04-23-2005 01:32 AM
Burners refuse to burn... Riallin Linux - Hardware 4 04-05-2005 03:20 AM
Xserver Refuse Connection ..:eMa:.. Debian 3 04-14-2004 04:58 PM
An offer you shouldn't refuse! taz.devil Linux - General 0 11-14-2001 11:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration