LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 02-16-2004, 06:05 AM   #1
Ragnaar
LQ Newbie
 
Registered: Feb 2004
Location: England
Distribution: Madrake 9.2
Posts: 6

Rep: Reputation: 0
Unhappy Screen scolling problem / resolution issue? - Mdk 9.2


Hi. This problem suddenly raised it's head after I had installed the Radeon drivers from the ATI site.

I have a Radeon 9200, and have managed (i think) to get it working.. at least HardDrake seems to think it is.. My major issue is that I can't seem to fit 1024 screen resolution on my monitor - I get a scrolling effect, both to the right and downwards. I know the monitor supports 1024 (a Samtron 55e, it's set up as plug'n'play).

It's almost like something thinks that my resolution should be 800x600 (which fits fine)

Any help would be gratefully accepted (bear in mind I've only been using linux for 1 week now)

Here are the relevant sections of my XF86Config4 file:

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Samsung Samtron 55(M)E (Plus)"
HorizSync 30-61
VertRefresh 50-120

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
BoardName "ATI Radeon (fglrx)"
Driver "fglrx"
Option "DPMS"
Option "CenterMode" "off"
Option "TVHSizeAdj" "0"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAACustomizeMSPos" "no"
Option "TVColorAdj" "0"

# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
Option "FSAAMSPosY3" "0.000000"

# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
Option "TVVPosAdj" "0"

# === TV-out Management ===
Option "NoTV" "yes"
Option "TVVSizeAdj" "0"
Option "FSAAMSPosY2" "0.000000"
Option "TVStandard" "NTSC-M"
Option "TVHStartAdj" "0"
Option "TVHPosAdj" "0"
Option "VRefresh2" "unspecified"
Option "FSAADisableGamma" "no"
Option "GammaCorrectionI" "0x00000000"
Option "ForceGenericCPU" "no"

# === disable PnP Monitor ===
#Option "NoDDC"
Option "UseInternalAGPGART" "no"

# === QBS Support ===
Option "Stereo" "off"

# === OpenGL specific profiles/settings ===
Option "Capabilities" "0x00000000"

# === disable/enable XAA/DRI ===
Option "no_accel" "no"
Option "FSAAMSPosX0" "0.000000"
Option "MonitorLayout" "AUTO, AUTO"
Option "BlockSignalsOnLock" "on"
Option "FSAAMSPosY5" "0.000000"

# === Misc Options ===
Option "UseFastTLS" "0"
Option "no_dri" "no"
Option "FSAAMSPosX2" "0.000000"
Option "GammaCorrectionII" "0x00000000"
Option "IgnoreEDID" "off"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "StereoSyncEnable" "1"
Option "FSAAMSPosX3" "0.000000"

# === FireGL DDX driver module specific settings ===
# === Screen Management ===
Option "DesktopSetup" "0x00000000"
Option "HSync2" "unspecified"
Option "ScreenOverlap" "0"
Option "FSAAMSPosX1" "0.000000"

# === FSAA ===
Option "FSAAScale" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection
 
Old 02-17-2004, 03:02 AM   #2
tk31337
Member
 
Registered: Oct 2003
Location: Tucson, AZ
Distribution: Linux Mint
Posts: 194

Rep: Reputation: 32
Just to get this out of the way:
Could it be possible that you just need to do CTRL+ALT+(+/-)? If not (which I kinda doubt it would be), you might try changing all the "Virtual" lines to "Mode" lines (i.e Mode "1024x768" "800x600" "640x480")
 
Old 02-17-2004, 04:02 AM   #3
Ragnaar
LQ Newbie
 
Registered: Feb 2004
Location: England
Distribution: Madrake 9.2
Posts: 6

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks for the tip! You're right - it wasn't the ctrl-alt +-, it was the XF86 config file that needed altering

Basically I needed to add a modeline declaration for 1024x768 and then reference that in the Display subsection i.e. Modes "1024x768" - instead of Virtual 1024x768

Many thanks!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with screen resolution... mahamkali Debian 9 08-22-2004 01:57 PM
Major screen resolution issue JimBass Linux - Newbie 5 06-05-2004 08:02 PM
Problem with Screen Resolution.. k0ljat Slackware 1 12-12-2003 07:57 AM
screen resolution problem 4of11 Linux - Newbie 2 11-12-2003 02:55 AM
KDE Screen Resolution MDK 8.2 jwbogart Mandriva 1 09-02-2003 01:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration