LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-06-2006, 05:39 PM   #1
lebabyg
Member
 
Registered: Mar 2006
Location: UK
Distribution: Ubuntu Feisty
Posts: 272

Rep: Reputation: 30
screen goes blank when left idle


Hey,

I need some help in resolving a major annoyance i have with mandriva. For whatever reason the screen goes blank when a key or mouse is not moved for some time. This is really annoying when watching a film or whatever, and i can't figure out how to turn it off as there is no option in the power management section. Anybody got any ideas??
Cheers
Graham
 
Old 11-06-2006, 05:53 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
It sounds like it's your screen blanker kicking in. Some video players have a comand line option to disable the screen blanker. Otherwise, you can look in the powersaver section of your setup and disable it there.

If you are running kpowersave, then you can select the "presentation" profile. The blanker will be disabled in this mode.
 
Old 11-06-2006, 06:12 PM   #3
lebabyg
Member
 
Registered: Mar 2006
Location: UK
Distribution: Ubuntu Feisty
Posts: 272

Original Poster
Rep: Reputation: 30
Amazing!! I didn't have powersave installed, so i've installed it and set it to presentation. Cheers for the quick response, it was a really minor thing, but so annoying!!

Edit: Might have spoken too soon, the screen still goes blank, how do i stop this and make sure kpowersave overrights other options.
Cheers
Graham

Last edited by lebabyg; 11-06-2006 at 06:46 PM.
 
Old 11-07-2006, 12:37 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
A) Check in the MCC configuration for settings on screen blanking. I don't know whay kpowersave doesn't do it. Maybe you need to install the acpi support.

B) Check your bios. It may be doing it there as well. I think some older Dell laptops did that.

C) Some BIOSes didn't do a good job with the ACPI functions in the BIOS and a BIOS upgrade may fix the problem.

Last edited by jschiwal; 11-07-2006 at 12:39 AM.
 
Old 11-07-2006, 05:58 AM   #5
lebabyg
Member
 
Registered: Mar 2006
Location: UK
Distribution: Ubuntu Feisty
Posts: 272

Original Poster
Rep: Reputation: 30
Hey,

From what i can understand on my notebook, acpi is a bit broken: [URL="http://gentoo-wiki.com/HARDWARE_Gentoo_on_HP_Compaq_nx6325"]
However, i've flashed the bios so its the most recent, but i don't know if acpi is working or not. How do i check this, and if it is broken how do i fix it??
Cheers
Graham
 
Old 11-09-2006, 11:27 AM   #6
miclem
Member
 
Registered: Jan 2005
Distribution: Mandriva 2009 Powerpack x64
Posts: 80

Rep: Reputation: 15
Have you tried System > Prefererences > Screensaver then unchecking the 'Activate screensaver when idle' box (for Gnome)? If I remember rightly it can be done with a rightclick > Desktop Settings > on the desktop in KDE...
 
Old 11-09-2006, 08:18 PM   #7
Cara25
Member
 
Registered: Mar 2006
Location: Nashville, Tennessee
Distribution: Salix 13.37 with KDE
Posts: 258

Rep: Reputation: 36
Running Mandriva 2007/KDE 3.5, During the install and configuration of 2007, turning off the screensavers cured my problem with the screen going black without any input for a short time, I normally don't use the screensavers so I don't know how it works when I turn it back on.
 
Old 11-10-2006, 07:14 AM   #8
lebabyg
Member
 
Registered: Mar 2006
Location: UK
Distribution: Ubuntu Feisty
Posts: 272

Original Poster
Rep: Reputation: 30
Problem Solved:

xset s off

I also added this to my ./xinitrc

setterm -blank 0 -powersave off -powerdown 0
xset s off

and in the monitor section of /etc/X11/xorg.conf

Option "DPMS"

Then in serverlayout of xorg

Option "BlankTime" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"

Probably overkill but it seems to have sorted it as when i do
sleep 1; xset s activate

nothing happnes. Didn;t realise that there was an option to turn off screensavers in the post install config, but that would have helped. Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen goes blank after being idle 4 a long time & then all input devices freeze! hari_seldon99 Linux - General 10 07-13-2005 12:31 AM
Screen goes blank after being idle 4 a long time & then all input devices freeze! hari_seldon99 Linux - Newbie 2 01-28-2004 07:45 PM
Left idle a few minutes and freezed up d4d4n9 Mandriva 15 11-19-2003 09:34 PM
KDE/Gnome Desktop blank on left side JakeFarley Linux - Newbie 4 11-07-2002 05:31 PM
pc idle & black screen appears.. sapilas Linux - Distributions 9 05-13-2002 04:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration