LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   sash glibc circular dependencies (https://www.linuxquestions.org/questions/mandriva-30/sash-glibc-circular-dependencies-214774/)

twosider 08-07-2004 04:47 PM

sash glibc circular dependencies
 
Using Mandrake 9
[root@inspiron berck]# uname -a
Linux inspiron 2.4.19-16mdk #1 Fri Sep 20 18:15:05 CEST 2002 i686 unknown unknown GNU/Linux


Trying to update quota package from 3.07 to 3.09:

[root@inspiron berck]# rpm -i quota-3.09-1mdk.i586.rpm
error: failed dependencies:
libc.so.6(GLIBC_2.3) is needed by quota-3.09-1mdk


[root@inspiron berck]# rpmquery glibc
glibc-2.2.5-16mdk

[root@inspiron berck]# rpm -i glibc-2
glibc-2.3.3-10mdk.i586.rpm glibc-2.3.3-13mdk.i586.rpm

[root@inspiron berck]# rpm -i glibc-2.3.3-13mdk.i586.rpm
error: failed dependencies:
sash >= 3.6 is needed by glibc-2.3.3-13mdk
rpm >= 4.2.2 is needed by glibc-2.3.3-13mdk
ldconfig >= 6:2.3.3-3mdk is needed by glibc-2.3.3-13mdk
initscripts < 6.91-18mdk conflicts with glibc-2.3.3-13mdk

[root@inspiron berck]# rpm -i sash-3.6-5mdk.i586.rpm
error: failed dependencies:
glibc < 6:2.3.3-2mdk conflicts with sash-3.6-5mdk



So glibc 2.3.3 needs sash 3.6, which needs glibc 2.3.3.

Yow.

doug_s 08-07-2004 06:26 PM

Are you trying to install a Mandrake 10.0 rpm on a Mandrake 9.0 system ? That might be the cause of your problems because 10.0 uses newer c libraries and a newer compiler.

If that's what you're doing downloading the quota package source and compiling might be faster than fixing all the dependency problems. An alternative might be to get the source rpm and try to rebuild it.

twosider 08-09-2004 03:58 AM

That's right. okay. i'll try to compile it. thx


All times are GMT -5. The time now is 06:54 AM.