LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 12-03-2006, 12:18 AM   #1
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Rep: Reputation: 30
Question Samba and accessing Windows?


Two things... how can I share out my home dir just for one user so Windows machines can see it? I did it before in Mandrake 10, but in 2006 I couldn't get it to work and in 2007 came thing.

From the Mandriva machine when I go into smb2k double dlick on one of the XP machines I get NT_STATUS_LOGON_TYPE_NOT_GRANTED.
 
Old 12-03-2006, 01:27 AM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

Perhaps you can try this on your XP host:
http://pcal.net/blog/archives/2004/1...amba_woes.html
 
Old 12-03-2006, 11:44 AM   #3
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by paulsm4
Hi -

Perhaps you can try this on your XP host:
http://pcal.net/blog/archives/2004/1...amba_woes.html

I tried that and I don't thinkt he person writing that has it right... There is no corresponding entries under Administrative Control Panel.
 
Old 12-03-2006, 03:01 PM   #4
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
C'mon, Snump!

You know what a comically stupid UI Windows is. Just because a command is useful, doesn't mean you should expect to find that command in a reasonable place, does it?

Try "[Start], Run, secpol.msc".

Which, I believe, is precisely what the link suggested that you do in the first place.

Now ... whether or not that actually SOLVES the problem .. is a completely different question.. Because Windows isn't just a stupid UI. It's also a comically stupid OS. The underlying cause can be any of a zillion things, each unlikelier than the next.

Anyway, please check the "security policy" entries as suggested in the link. Be sure to reboot after changing your settings.

And good luck!
 
Old 12-03-2006, 04:14 PM   #5
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
You'll also have to make sure that the directory that you want to be shared is listed in the smb.conf file with all of the corrseponding entries. Then you will have to make sure that the linux users/groups all have the correct permissions. Then make sure that the Windows users and the linux users are all sync'd up so that Samba will know which Windows users are which Linux/Samba users. Restart your windows machines, restart Samba and you should be good to go.
 
Old 12-03-2006, 08:47 PM   #6
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by paulsm4
C'mon, Snump!

You know what a comically stupid UI Windows is. Just because a command is useful, doesn't mean you should expect to find that command in a reasonable place, does it?

Try "[Start], Run, secpol.msc".

Which, I believe, is precisely what the link suggested that you do in the first place.

Now ... whether or not that actually SOLVES the problem .. is a completely different question.. Because Windows isn't just a stupid UI. It's also a comically stupid OS. The underlying cause can be any of a zillion things, each unlikelier than the next.

Anyway, please check the "security policy" entries as suggested in the link. Be sure to reboot after changing your settings.

And good luck!

fromt he article:
Code:
There seemed to be two changes I had to make. First,

  Security Options - Network Access: Sharing and Security for local accounts

was set to 'Guest Only - local users authenticate as guest'. It needed to be changed to 'Classic - local users authenticate as themselves.' Secondly,

  User Rights Assignment - Access this computer from the network

Needs to include the user you're trying to login as. This was blank in my settings.
]
The second part: there is no user rights assignment in there.
 
Old 12-03-2006, 09:05 PM   #7
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
If I understand what you are trying to do (allow Samba users access to someone's home folder other than the Linux user so named after) then yes, you will have to list it in the smb.conf and set up file permissions (possibly with the group setting) and make sure that the group has access to the needed files. If you don't want them to have access to all the files then just don't set up the group permission. You can also tweak it down so that any file or directory they generate will have to have certain permissions, etc.

Otherwise, then the Windows user that corresponds to a Linux user will have access to their home folder by default.

Hope that helps!
 
Old 12-03-2006, 09:21 PM   #8
Snump
Member
 
Registered: Sep 2004
Location: Pennsylvania, USA
Distribution: Trying to decide
Posts: 229

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by ScooterB
If I understand what you are trying to do (allow Samba users access to someone's home folder other than the Linux user so named after) then yes, you will have to list it in the smb.conf and set up file permissions (possibly with the group setting) and make sure that the group has access to the needed files. If you don't want them to have access to all the files then just don't set up the group permission. You can also tweak it down so that any file or directory they generate will have to have certain permissions, etc.

Otherwise, then the Windows user that corresponds to a Linux user will have access to their home folder by default.

Hope that helps!

Yes, I understand. The users on windows and Linux sides are exactly the same.
But for now I'm trying to access WIndows shared on trhe linux side.
We'll cross that other bridge when the time comes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba: trouble accessing windows share linmix Linux - Software 8 10-12-2006 03:42 PM
accessing samba shares from windows xubuntu_idiot Linux - Software 1 09-05-2006 12:25 PM
Accessing samba shares from a windows machine lacitpo Linux - Software 2 12-13-2004 06:47 AM
Accessing Samba FROM Windows XP box dhatcher2 Linux - Networking 11 11-06-2004 10:31 AM
Accessing Samba through Windows scottie Linux - Networking 6 12-12-2003 06:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration