LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 11-17-2005, 08:18 PM   #1
qizhang
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
RPM - Won't Install, Won't Uninstall


Hi,

I'm trying to downgrade my installation of gcc since vmware 5.0 won't compile vmmon on my current version of gcc (4.0.1) which I recently installed (and which I now can't uninstall either because of dependencies that I'm surprised even exist, as I've installed nothing else since...)

I've downloaded gcc-3.4.1-4mdk.i586.rpm but when I try to install with urpmi I get this:

[root@localhost jazzman]# urpmi gcc-3.4.1-4mdk
Everything already installed

And when I try to uninstall, I get this:

[root@localhost jazzman]# urpme gcc-3.4.1-4mdk
unknown package: gcc-3.4.1-4mdk


RPMdrake is no better, and a grep of my rpm list gives this:

[root@localhost jazzman]# rpm -qa | grep gcc
gcc-cpp-4.0.1-5mdk
libgcc1-3.4.1-4mdk

Any ideas as to why this might happen?

Thanks in advance,
Neil
 
Old 11-17-2005, 11:24 PM   #2
Lakota
Member
 
Registered: Oct 2003
Location: London, ON, Canada
Distribution: Mandriva 2007 Free
Posts: 507

Rep: Reputation: 30
-

Last edited by Lakota; 11-18-2005 at 01:27 AM.
 
Old 11-18-2005, 12:02 AM   #3
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 52
Quote:
[root@localhost jazzman]# urpmi gcc-3.4.1-4mdk
Everything already installed
Version 4.01 of the gcc package is already installed so that's why it comes back with this. gcc-3.4 (from 2005LE) and gcc-4.0 (from 2006) are the same package - gcc, they are just different versions of it. You can't have 2 versions of the one package installed at the same time like this so if one's already installed it will tell you that.

Quote:
[root@localhost jazzman]# urpme gcc-3.4.1-4mdk
unknown package: gcc-3.4.1-4mdk
Fine, since gcc-3.4.1 was never installed in the first place.

Quote:
Any ideas as to why this might happen?
You're going about it the wrong way There are a couple of compatability packages you can try in 2006 to get an old gcc. You can try installing either gcc2.96 or gcc3.3 to get the older gcc in a way that doesn't interfere with your existing gcc version 4 package. Goto http://easyurpmi.zarb.org if your urpmi can't find these - they are in the main and contrib repos respectively.

I'd say try the gcc3.3 first.

Last edited by tkedwards; 11-18-2005 at 12:03 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM or Install/Uninstall Manager ? pandasonic Fedora 2 11-19-2004 03:52 AM
RPM Install and Uninstall problems. pradsy90 Linux - Software 1 09-12-2004 12:44 AM
RPM install/uninstall jonlake Linux - Software 2 06-14-2004 08:45 PM
Kernel-Source rpm Install/Uninstall error in Fedora i286 Linux - General 1 12-29-2003 11:31 AM
install, uninstall rpm aizkorri Linux - Software 2 05-06-2002 12:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration