LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-07-2003, 08:45 AM   #16
sammckee
Member
 
Registered: Aug 2003
Posts: 59

Original Poster
Rep: Reputation: 15

The guy who set me up (this was about two-and-a-half years ago, btw) just run the extra cable line and brought me the box. I just let Windoze detect the card and clicked the "Obtain an IP address automatically" and "Obtain DNS server address automatically" radio buttons in the TCP/IP setup dialog.
 
Old 09-07-2003, 10:40 AM   #17
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Let me stick my nose in here for a moment. I am presently writing this post in Mandrake 9.0 connected through western ohio roadrunner. So it can be done.

Now, I am connected through a dlink firewall/router so my nameserver is my firewall address. My resolv.conf looks like this:

nameserver 192.168.0.1
search woh.rr.com

According to my router, the DNS addresses are these:

24.29.161.137 24.29.161.129 65.24.0.163

and the default gateway is this

24.209.104.1

subnet mask is

255.255.255.0

Of course, you have to enable DHCP.

Now, one place where you could easily get into trouble is your NIC driver. If you have the wrong driver you will sometimes find that ifconfig will appear to work, while not actually connecting you. What NIC do you have, and what driver are you using?
 
Old 09-07-2003, 01:44 PM   #18
sammckee
Member
 
Registered: Aug 2003
Posts: 59

Original Poster
Rep: Reputation: 15
I'm using a Linksys EtherFast 10/100, it Mandrake says it's using module "Tulip," whatever that is. Is that the driver? If not, how do I figure out what the driver is?

Do I need to set those DNS and gateway addresses explicitly? Or is it sufficient to put "nameserver 192.168.0." and "search woh.rr.com" in my resolv.conf?
 
Old 09-07-2003, 02:09 PM   #19
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
You would not put in nameserver 192.168.0.1 in your resolv since 192.168.0.1 is the address of my router, not roadrunner dns.

you would put this:

nameserver 24.29.161.137
nameserver 24.29.161.129
nameserver 65.24.0.163
search worh.rr.com

in your resolv.conf.

Now, the Mandrake networking setup tool should do this for you; why it isn't happening is a mystery to me. But, this *should* get you going.

The module tulip (not Tulip) is correct for the Linksys Etherfast card. Yes, that is the driver. Pay attention to case; Linux is very case sensitive.

If setting these values in resolv.conf doesn't get you going, then run linuxconf (mandrake gives a desktop icon for this). Select "networking", then select "Host name and IP devices". Then, you will have a tab for each NIC in your system; select the appropriate tab and fill out the table.

At a minimum you need to provide the netmask. the net device, the driver, and you need to specify that it uses dhcp and that it is enabled.
 
Old 09-07-2003, 07:46 PM   #20
sammckee
Member
 
Registered: Aug 2003
Posts: 59

Original Poster
Rep: Reputation: 15
Okay, I've tried all that and still get the same result. Being a Linux newbie I can't help but think I'm missing something obvious. ;(

Are other flavors of Linux this hard to configure? I'm thinking about trying one but don't want to waste my effort if it's going to be just as difficult.
 
Old 09-07-2003, 07:54 PM   #21
wyohman
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Mandrake 2006
Posts: 66

Rep: Reputation: 16
Quote:
Originally posted by sammckee
Okay, I've tried all that and still get the same result. Being a Linux newbie I can't help but think I'm missing something obvious. ;(

Are other flavors of Linux this hard to configure? I'm thinking about trying one but don't want to waste my effort if it's going to be just as difficult.
Just like with any installation I've had a couple of problems but with a little research (and sometimes patience with new software) I 've solved a vast majority of them.

I looked back at the posts and noticed that you have two Ethernet cards. Are they the same model? Is the other card configured for DHCP or are you using a static IP address?

Cheers.
 
Old 09-07-2003, 08:41 PM   #22
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
;(
Quote:
Okay, I've tried all that and still get the same result. Being a Linux newbie I can't help but think I'm missing something obvious. ;(
Probably. from a console window as root, what is the response when you enter the command ifconfig ?

Please copy and paste the entire response - every line - here.
 
Old 09-07-2003, 09:33 PM   #23
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
You know, I thought of something.

I couldn't get my system to reliably start my network until I placed the line

alias eth0 tulip

in my /etc/modules.conf file

Now, you would do this if your eth0 is using tulip; if your eth1 is using it, make the appropriate change.
 
Old 09-07-2003, 11:22 PM   #24
sammckee
Member
 
Registered: Aug 2003
Posts: 59

Original Poster
Rep: Reputation: 15
I removed the second ethernet card a couple days ago to avoid confusion. I already have the "alias eth0 tulip" line in the modules.conf file.

I can't copy-paste my ifconfig because I can't post to here from Linux. I printed it out, and I'll retype as carefully as possible.

eth0 Link encap:Ethernet HWaddr 00:04:5A:77:0C:29
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:11 dropped:0 overruns:0 carrier:22
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:9 Base address:0xe800

eth0:9 Link encap:Ethernet HWaddr:00:04:5A:77:0C:29
inet addr:169.254.215.253 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:9 Base address:0xe800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:22 errors:0 dropped:0 overruns:0 frame:0
TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1446 (1.4 Kb) TX bytes:1446 (1.4 Kb)
 
Old 09-07-2003, 11:44 PM   #25
wyohman
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Mandrake 2006
Posts: 66

Rep: Reputation: 16
Quote:
Originally posted by sammckee
I removed the second ethernet card a couple days ago to avoid confusion. I already have the "alias eth0 tulip" line in the modules.conf file.
Is the card you removed the same model as the one in it right now?

Cheers.
 
Old 09-08-2003, 12:16 AM   #26
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Quote:
eth0:9 Link encap:Ethernet HWaddr:00:04:5A:77:0C:29
inet addr:169.254.215.253 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:9 Base address:0xe800
Well now.

This is certainly wrong.

This entry should not be here. I am not sure why you have it but it surely suggests some configuration confusion to me.

Try this.

Enter this command:

ifdown eth0

Then, enter another ifconfig and see if the eth0 entries are gone (you should only have lo, the loopback address).

Once you have established that the interface is gone, enter the command

ifup eth0

then, again, look at ifconfig and see if the results look more normal.

Here is the output of my own ifconfig and you should see something that looks like this:

eth0 Link encap:Ethernet HWaddr 00:04:5A:7D:FC:A4
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:78151 errors:0 dropped:0 overruns:0 frame:0
TX packets:52895 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:35512429 (33.8 Mb) TX bytes:5973720 (5.6 Mb)
Interrupt:10 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5060 errors:0 dropped:0 overruns:0 frame:0
TX packets:5060 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3496901 (3.3 Mb) TX bytes:3496901 (3.3 Mb)
 
Old 09-08-2003, 09:48 PM   #27
sammckee
Member
 
Registered: Aug 2003
Posts: 59

Original Poster
Rep: Reputation: 15
Okay, I downed eth0 and did an ifconfig. As expected it contained only the loopback interface. I did an ifconfig eth0 up, and it looks exactly as it looked before.

The card I removed is not the same model, nor did Mandrake use the same driver for it (I forget which one it used, but it was one with a string of letters and numbers, not a word like tulip).
 
Old 09-08-2003, 09:50 PM   #28
wyohman
Member
 
Registered: Aug 2003
Location: Texas
Distribution: Mandrake 2006
Posts: 66

Rep: Reputation: 16
Quote:
Originally posted by sammckee
The card I removed is not the same model, nor did Mandrake use the same driver for it (I forget which one it used, but it was one with a string of letters and numbers, not a word like tulip).
I would recommend a quick change of cards and see if that makes any difference.

Cheers.
 
Old 09-08-2003, 10:31 PM   #29
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
You and I are running the same card, on the same version of Mandrake, on the same ISP. This simply should not be tough.

Try this. Do an ifdown eth0.

Then, from your desktop, go into LinuxConf. Select "Networking" then select "Host name and IP devices"

The first tab is named "Hostname". It will show your machine name and your domain. On my system it says Dadsbox.Homegroup. Yours should say something appropriate.

The second tab is labeled Adaptor 1. Click on it.

It should be shown as enabled. If not, make it so. It should show that you are using DHCP. If not, make it so.

Then, the fields should be blank down to subnet mask which should say 255.255.255.0 If not, make it so.

The net device should say eth0 - that is - eth zero. if not, make it so.

Next line is driver; should say tulip.

Other fields should all be blank.

The next tab says Adapter 2. Go there. It should not be enabled. If it is, uncheck the "enabled" box. Set "config mode" to "manual."

All other boxes should be blank. If not, make them so. I rather suspect your problem is here since you pulled another NIC.

Go to each of the next tabs (Adapter 3, Adapter 4, and so forth) and make sure that they are disabled, set to manual config, and contain no data.

Then save it. See if this helps.

Oh, BTW...this particular box used to be multi-homed; I had another NIC in it and used it as you wish to use yours. I finally reconfigured the LAN with a firewall/router and removed the other NIC. So I do know how to make that work too. At least, it worked here.
 
Old 09-08-2003, 10:35 PM   #30
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 115Reputation: 115
Wait a minute. That subnet mask on adapter 1 is right for my LAN; won't be right for RoadRunner.

Try it two ways; first, leave it blank. Second, use 255.255.252.0, which is my subnet mask on Roadrunner
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mid Ohio Valley Linux Users Group diensthunds Linux User Groups (LUG) 4 11-21-2013 03:21 PM
Columbus, Ohio linux users Poorman Linux - Newbie 5 04-22-2006 08:50 PM
Sombody in the Dayton Ohio area? cityroaste Linux User Groups (LUG) 1 04-22-2005 07:02 AM
CINCINNATI, Ohio eskiled Linux User Groups (LUG) 4 09-15-2004 10:07 PM
Mandrake 7.2 and Roadrunner Errsta_Fonzarelli Linux - Networking 5 05-02-2001 06:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration