LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Rescue disk (https://www.linuxquestions.org/questions/mandriva-30/rescue-disk-212339/)

UmneyDurak 08-01-2004 10:27 PM

Rescue disk
 
Hi.
I had dual boot 98se and XP. In the process of installing XP I had to stop.
So now I don't have any working windows on my computer. Anyway /mbr partition was overwritten so now I don't have lilo as a boot manager. I tried to boot with Mandrake rescue CD, I created few weeks back, to restore lilo, but it's giving me an error message.
Kernel panic: No init found. Try passing init= option to kernel.
Whats going on? Last time I had to boot up with rescue CD, it booted up
just fine.
I have a feeling this has something to do with windows partions been messed up, because I see this error messages before Kernel panic message: "mount: error 6 mounting ext2".
Thx.

ugenn 08-01-2004 10:35 PM

I think your windows installation might have wiped out your Linux partition.

UmneyDurak 08-02-2004 02:53 AM

It shouldn't have...
Before installation I only deleted the dos partitions.
Also I only recreated windows partitions on disk 1, my linux partitions are on disk 2.
EDIT. Ok I just run Mandrake install till it got to partion part, here what it shows:
Empty Size: 19GB (99%) Cylinder 0 to 39769-I"m assuming this is my 20 gig HD
Empy Size: 29GB(39%) Cylinder 0 to 60976 - Assuming this is some empty space on my second HD
hdb5 [c:] (19GB, /mng/windows, FAT32)-this is a 20 gig windows partition I left on second hd with my data
hdb2 (2.9GB /, Linux native)-root partition I created
Empty Size: 22GB(30 %) Cylinder 107712 to 155060-assuming more empty space on second drive
Now I have 20 gig HD and 80 gig HD. 20 Gig is accounted for on my first HD.
But adding up all the partition that are showing on my second HD, it comes out to only 72.9 with 7.1 GIG missing. Which corresponds to linux partitions that I had.
What a hell is going on here?

ugenn 08-02-2004 06:22 AM

It got wiped out somehow. Try mounting each of your partitions from the boot disk to verify.

UmneyDurak 08-03-2004 12:41 AM

Probably a stupid question but where do I enter the command.
When I boot up with rescue CD, first I see options what to boot: linux, diagnostic 1 & @
with boot: promt underneath where I can enter someking of options for kernel.
I tried entering text, but it didnt' work. I tried entering mount /dev/hda2, I just get no such image. [Tab] shows a list.

jomen 08-03-2004 02:49 AM

you will need to tell your rescue-CD the location of your root-partition...
The rescue disk boots the kernel it has - and then tries to continue by accessing your filesystem.
For that - it needs to know where to look for it. Your rescue discs have default values probably - they get used if you just do nothing...

to use the init= ...option you would type something like: init=1 which is supposed to put you in runlevel 1
mostly this is single-user mode to be able to fix problems and would not be helpful here - since it does not get this far...

what you would need to do (cannot be sure of exactly how to write this - because I don't know your rescue-CD) is write something like this at the boot prompt:

rescue root=/dev/hdb2 - this is where (from what I gather) your root-partition is

in your case there seem to be two different systems available to choose from: diagnostic and linux
- with linux probably being the default

to use the diagnostic system you would have to type that in...diagnostic - (this is "rescue" in my example above)

and to use linux and tell it that your system-root is on /dev/hdb2 you would use:

linux root=/dev/hda2

surely your rescue-CD has some kind of help-system and or explanations to it (F1 F2 ...) try to find out, what commands to use when you want to boot up using it

if you can - read though "man bootparm" - this is very much info but will give you some insight how to specify extra commands at the boot-prompt


All times are GMT -5. The time now is 08:19 AM.