LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-02-2003, 05:58 AM   #1
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Rep: Reputation: 15
Post Recording CDs using CDRW and CDROM devices


Hi,

I have a LG CDROM and a LG DVD/CD-RW Combo installed on the machine but I cannot manage to record directly from CDROM to CD-RW as people usually do in MsWindows.

Both are reconised by the system. I can read from both using the file managers (in GNOME or KDE) so they are installed.

The various burners recognise the CDWriter but they don't show the CDROM as a source, only the harddisk.

Is this normal? In order to copy a CD directly to a new CD I must always copy contents to harddisk first? If not, what is needed to configure it.

A propos... I'm a , so detailed info could be required.

Thanks in advance.

Lopo
 
Old 09-02-2003, 07:02 AM   #2
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
OK, if you are using lilo as a bootmanager, do this -
edit the file /etc/lilo.conf (as root).
There is a line that begins
append= ............
on that line you will see something like hdc=ide-scsi
You will need to add an almost identical entry, of the type hdx=ide-scsi
hda=primary master
hdb=primary slave
hdc=secondary master
hdd=secondary slave
So, if your writer is sec master and your cdrom is sec slave, you must make the line look like this -
append="quiet noapic devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=off"
The additional stuff in my line may not be in yours - don't copy that, just the part about ide-scsi.
Once you've done that, in a terminal, as root, type lilo - that will activate the changes. Then you need to reboot, and you should be sorted.
 
Old 09-02-2003, 12:40 PM   #3
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Thanks!

It worked fine

Now both drivers are visible to Recorders.

I will test with some "Chinese Tea Ballads" and GnomeToaster (didn't managed to configure K3b )

Lopo
PS: get an Affero account. It's free
 
Old 09-03-2003, 09:08 AM   #4
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
It worked.

Thank you. Thank you and thank you

There's no smilie for jumping for happiness so I can't show it here

1,

Lopo
 
Old 09-03-2003, 01:04 PM   #5
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Unhappy Another prob with CD Drives

Hi again!

Now I have another problem...

Although I can hear my music CDs and Write to the CDWriter, I stop having access to them to read data using the file managers

If you can help once more I had here below my lilo.conf and my fstab
PHP Code:
  /etc/lilo.conf
-----------------------------
keytable=/boot/pt-latin1.klt
prompt
nowarn
timeout
=100
message
=/boot/message
menu
-scheme=wb:bw:wb:bw
image
=/boot/vmlinuz
        label
="linux"
        
root=/dev/hda1
        initrd
=/boot/initrd.img
        append
="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=off quiet"
        
vga=788
        read
-only
image
=/boot/vmlinuz
        label
="linux-nonfb"
        
root=/dev/hda1
        initrd
=/boot/initrd.img
        append
="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=off"
        
read-only
image
=/boot/vmlinuz
        label
="failsafe"
        
root=/dev/hda1
        initrd
=/boot/initrd.img
        append
="devfs=nomount hdc=ide-scsi hdd=ide-scsi acpi=off failsafe"
        
read-only
other
=/dev/fd0
        label
="floppy"
        
unsafe

  
/etc/fstab
-----------------------------
/
dev/hda1 ext3 defaults 1 1
none 
/dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
none 
/mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
none 
/mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
none 
/mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,umask=0 0 0
none 
/proc proc defaults 0 0
/dev/hda5 swap swap defaults 
Of course this is not PHP code but it was the only way to preserve some formating

Thanks in advance for your help.

1,

Lopo
 
Old 09-03-2003, 02:50 PM   #6
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Yep, the problem is in fstab. Your cdrom is now /dev/scd1 not /dev/hdd. Change that line in fstab, and all should be fine, I hope.
 
Old 09-03-2003, 02:56 PM   #7
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
Just a thought... shouldn't it be: dev/hdc?? is secondary master
 
Old 09-03-2003, 04:49 PM   #8
humaneasy
Member
 
Registered: Aug 2003
Location: Moita, Portugal
Distribution: Mandrake 9.2 / Mandrake 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
I will try it...

Quote:
Originally posted by RockmanExe
Just a thought... shouldn't it be: dev/hdc?? is secondary master
Hi,

I have:[list=a][*]HD which is /dev/hda [*]LG CDROM 52x which is and IDE CDROM configured as secondary master in /dev/hdc (/mnt/cdrom)[*]LG DVD/CDRW Combo which is and IDE CDROM configured as secondary slave in /dev/hdd (/mnt/cdrom2)[/list=a]

And the problem now is that GnomeToaster can read music CDs and also read data from CDROM and write to CDROM2 without any fuss, but...
I cannot read or reach CDROM or CDROM2 with any filemanager or even using command line with root user

I will try your option of reverting /dev/scd1 to /dev/hdd but I don't think that the problem is here because I cannot use /dev/hdc also (except to hear music CDs)

1,

Lopo
 
Old 09-04-2003, 06:59 AM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 18,203

Rep: Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543Reputation: 2543
Look it the output of lsmod to see what modules are loading.
You need:
ide-scsi
scsi_mod
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
recording audio CDs, dev help with cdrecord gdiv Linux - Software 2 05-03-2005 05:20 PM
Recording audio CDs Nathaniel Firet Linux - Software 3 04-21-2005 01:23 PM
CDRW won't mount audio CDs Perrin7 Linux - Hardware 4 01-11-2005 12:13 PM
recording a multisession cdrom ksgill Linux - Newbie 1 08-10-2003 12:56 PM
cant mount cds after recording them bignester Linux - Software 1 06-28-2003 05:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 12:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration