-   Mandriva (
-   -   Qt libraries not found during compile - but libqt3-devel and libqt4-devel installed! (

prasadbrg 12-01-2008 04:33 AM

[SOLVED] Qt libraries not found during compile - but libqt3-devel installed!
Hello everyone,
Im running Mandriva 2009, and I'd like to compile Midingsolo ( (btw, I hope I'm doing this the right way... If there's a policy on how links and code are posted, please do let me know... I might have missed it).

The developer documentation page ( lists the following dependencies:

* qt3-mt for the GUI and the QThread class. (version 3.3.1)
* GL1/GLU1/glut3 for the QGLWidget (version ???)
* alsa2 the ALSA developpment library, for sound input (version 1.0.3)
* and/or
* jack the JACK developpment library, for sound input (version 0.94.0)

I didn't find anything called "qt3-mt" in the "Software Management" gui, nor did "urpmq --fuzzy qt3-mt" turn up anything.

Anyway, ./configure gives this error:

checking whether QTDIR environment variable is set... /usr/lib/qt3
checking for Qt library...
configure: error: Qt library not found. Maybe QTDIR isn't properly set or wrong --with-Qt-dir parameter.

I tried running configure using "-with-Qt-dir=/usr/lib/qt3" and "-with-Qt-dir=/usr/lib/qt4", with no results. I've installed both the libqt3-devel and libqt4-devel libraries (since I wasn't sure which qt version to compile with).

rpm -qa |grep libqt turns up this:


(oh yes, I even tried installing the qt3-static-devel libraries)
the $QTDIR variable points to /usr/lib/qt3, while the $QTLIB points to /usr/lib.
/usr/lib/qt3 has all those *.h files in it.

Any help would be appreciated.. I really need to use this program. Thanks in advance!

knudfl 12-01-2008 09:58 AM

Well, not impossible to compile, more difficult to run.

It's an old app, from 2005, in those days no Mandriva 2009
with a new location of "libqt-mt" files.
( Configure will look in /usr/lib/qt3/lib only )

So please do : # 'cd /usr/lib/qt3', # 'mkdir lib'
# 'cd lib' # 'ln -s /usr/lib/libqt-mt* .' ,
softlinking the files to the current directory (the dot)

You will also need : libalsa2-devel, libjack0-devel, fftw3-devel

Starting "midingsolo" after install, I get "Segmentation fault"

I found this link for other app's
( googling ... audio note recognition linux )

prasadbrg 12-01-2008 11:28 AM

Thanks knudfl, for the useful reply.
Yes, your workaround helped me get past the qt3-libraries issue, and the configure process was successful. However, I find that the urpmi database doesn't have the 'libfftw3-devel' rpm - it looks like this rpm doesn't exist yet for Mandriva 2009, although the libfftw3 rpm does! I searched and found an rpm for Mandriva 2007 (, which however depends on a different libfftw3 rpm (3.1.2-2) from the one installed on the system (3.1.2-11) - I've posted code below.
This is frustrating... could you suggest any workarounds? What system are you using, by the way?
Thanks for the links to the other software! I was not aware of most of them, and I will check them out meantime. Basically I require conversion of a pure sine-wave audio signal from a non-midi keyboard to midi notes, in real-time. I had googled for pitch to midi, and audio to midi, I had missed audio to note! Thanks once again.

rpm -i libfftw3-devel-3.1.2-2mdv2007.1.i586.rpm
error: Failed dependencies:
libfftw3 = 3.1.2-2mdv2007.1 is needed by libfftw3-devel-3.1.2-2mdv2007.1.i586

rpm -qa |grep libfft

knudfl 12-01-2008 01:21 PM


I find that the urpmi database doesn't have the 'libfftw3-devel' rpm
I never said "libfftw3-devel" !!!

The package name is "fftw3-devel" ( unlike other mandriva's )
# urpmi fftw3-devel
( Do not read the command, just copy / paste it into a terminal, lol )

prasadbrg 12-01-2008 10:18 PM

Oops... now I am seriously embarrassed. All this is due to an unhealthy infatuation with Mandriva 2009's graphical 'Software Manager', which I assumed accurately reflected information in the URPMI databases. It appears that this is not true. The software manager shows only libfftw3 (no 'devel' package) when I searched for 'fftw3' (and not 'libfftw3') in names. Whereas urpmi fftw3-devel worked... incidentally, the rpm is named libfftw3-devel... I found this rather strange. I think I must report this as a bug in the software manager gui.

Anyways, the program has compiled successfully... and it also seems to be running! At least, the gui came up, and luckily, I didn't get any segmentation fault error.

knudfl, thank you very much for guiding me through this... you rock!

knudfl 12-02-2008 05:58 AM

Well, I am sorry, never thought of it as an error,
just guessed 'fftw3-devel' when nothing else worked
and then got 'libfftw-devel-3.1.2-11mdv2009.0
( I can see that now with 'rpm -qa | grep fftw' )

All times are GMT -5. The time now is 02:46 PM.