LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 01-25-2004, 03:44 PM   #1
adamis
Member
 
Registered: Oct 2003
Posts: 81

Rep: Reputation: 15
Problems with "resolving host" and Mozilla


I updated my Mozilla to the newest stable release and noticed that Mozilla spends most of it's time "resolving host" usually 10 to 20 seconds on a website. I've done some reading and found that this appears to be common to mostly Linux installs. I haven't found any reason or solution and was wondering if anyone else had the same troubles and perhaps a solution.

Finally one last note is my resolve.conf only contains my wireless router's IP. Should I perhaps throw in some other dns servers? I tried the dns names of my IP (SBC in the bay area) and it didn't seem to do much (although I only restarted my browser and not the whole system.) Do I have to restart the whole computer to get this data to take?

Mandrake 9.2 RC2, Emachines M5310 Laptop, Kernel 2.6 test 11 (working on 2.6.1 upgrade soon), Mozilla .8+ Athlon XP build

Last edited by adamis; 01-25-2004 at 03:47 PM.
 
Old 01-25-2004, 04:58 PM   #2
vincebs
Member
 
Registered: Oct 2003
Location: Mississauga, ON
Distribution: Ubuntu 9.04
Posts: 494

Rep: Reputation: 30
It happens to me in Konqueror and Opera too, so I doubt it's a browser problem. Did this problem happen to you before you upgraded Mozilla?

I posted a similar thread two weeks ago and no one has been able to fix the problem despite me bumping the thread 3 times.
 
Old 03-20-2004, 11:21 AM   #3
Axigrav
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Rep: Reputation: 0
Talking

I have a fix for this problem (at least in my case).

History:
I have a Linksys Switch connected to a cable modem. I've Been struggling with SLOW Internet surfing in all browsers I tried in Red Hat 9 (I use Mozilla in general). Windows on the same machine is like lightening. Previous versions of RH and Knoppix had the same problems so I knew it was a setup thing. Any time going to a new website "Resolving Host" would take a long time, as would "Connecting...", and the pages would generally load slow also. POP Mail was slow to connect to check messages. ping and traceroute were also slow. Using both DHCP and static settings had the same SLOW results.

Now everything is like lightening on RH.

Here is what I did:
In the Network panel (redhat-config-network on command line) the clincher was putting my WAN Default Gateway IP address in for the DNS Search Path. The WAN gateway being the "switch" at my cable provider which is my WHOLE network's gateway to the rest of the world. I previously had my LAN gateway address (the switch LAN address or internal IP gateway address). I expect that I am not the only one who made the same conceptual error.

For those who are looking for these IP addresses, I HTTP over to my switch configuration and check the STATUS page. Here is where one can find the DNS server IP addresses and WAN gateway address to use in the DNS setup.

Hope it helps!
Axigrav
 
Old 03-20-2004, 12:56 PM   #4
Healing Bear
LQ Newbie
 
Registered: Jan 2004
Location: Northern California
Distribution: Mandrake 9.2 - 10 Official, XP Pro
Posts: 29

Rep: Reputation: 15
I have been having the same problem lately too... Thought it got solved my replacing the dead cable moden... I have my IP Address, Net Mask and Gateway set manually... They are set the correct places... Using Mozilla 1.6... Also tried using Epiphany, got some slow results with no "resolving host" message ... XP was doing this too, now I can anly see a flash of the "resolving host" message then the page gets displayed...

Last edited by Healing Bear; 03-20-2004 at 03:43 PM.
 
Old 03-21-2004, 11:21 AM   #5
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
Axigrav,

Thank You sir. I was having the same problem since getting a US Robotics Router your fix is working like a charm. I have tried about everything even entering my ISP's DNS numbers but nothing helped, adding my cable boxes number did the trick, again thank you very much.
 
Old 03-26-2004, 04:54 PM   #6
Axigrav
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Rep: Reputation: 0
Great!

You're welcome...Glad it has helped!!
 
Old 04-24-2004, 01:21 AM   #7
godofmind
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9
Posts: 2

Rep: Reputation: 0
please help to solve mozilla/linux host resolving problem

Hi Axigrav,

Being a newbie I did not completely understand your solution.


I am using RH9, and is facing same problem which u have explained.
My setup is as follows, i use a wireless PCMCIA 64kbps modem to dialup
to my ISP.

From the PPP configuration, i know the address of their DNS.
Adding DNS address to /etc/resolv.conf is of no use regarding this
problem.

I checked, Network panel (redhat-config-network on command line)
in my system, But in that DNS search field path is empty.

Could you guide me in fixing this host resolving problem in mozilla/RH9

Thanks in advance

godofmind
 
Old 06-03-2004, 07:25 AM   #8
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
This might help

See if this helps:

http://www.linuxquestions.org/questi...hreadid=189202
 
Old 07-06-2004, 01:12 AM   #9
icenov
LQ Newbie
 
Registered: May 2004
Location: Sydney
Distribution: Mandrake 10.0
Posts: 2

Rep: Reputation: 0
slow site loading in mozilla

I have had a similar problem with mozilla 1.7 (and 1.6) under MDK10. While I am totally out of my depth here, apparently it can be caused by ipv6. Some posts talk about changing some conf files, but you can check, and in my case, fix, the problem by navigating to about:config (enter this in the address bar) and scrolling down to network.dns.disableIPv6. This is usually false, so change it to true (right click, modify, type true) and restart mozilla. I noticed an immediate improvement. This should fix the mozilla problem without affecting other network processes.
 
Old 07-12-2004, 05:31 PM   #10
DocFOC
LQ Newbie
 
Registered: Jul 2004
Location: Massachusetts
Posts: 1

Rep: Reputation: 0
Wink Resolving Host

I am running Windows XP, Mozille 1.7.1 with the same problem (I run Linux on all our data acquistion boxes). I applied the fix, use the DNS entries from my D-Link router, and web sites are suddenly found with no 20 second delay. Instantaneous. I.e. this problem is not unique to Linux. I don't recall this being an issue until perhaps Mozilla 1.7, not sure about 1.6, but this sure fixed it. I am not sure how to fix it on my eoaming notebook though. Thanks a thousand times for the DNS clue!!! DocFOC
 
Old 07-27-2004, 09:38 PM   #11
drsuse23
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
I had a similar problem with the "resolving host" delay of about 10 seconds per page change. I was irate! I tried everything and scanned the manuals and different forums for answers. I have SUSE 9.1 by the way.

As a last resort, I decided to remove my Network Card configuration completely and start over. To my surprise, I had 4 configurations setup for my Network Card! I deleted each and every one of them and then added back the detected Network Card accepting defaults using DHCP automatic assignment of IP stuff. To my surprise this did the trick.

I can only guess how I got 4 different Network Card configurations. It may have happened in the course of getting MYSQL or Tomcat or Eclipse setup or maybe even SAMBA. Whatever it works now.

Try it:
1- Go into YAST
2- Choose Network Devices...
3- Choose Network Card

You should see detected configurations at this point. If you have more than one, you may have the same issue.
 
Old 07-28-2004, 07:24 AM   #12
pongmaster
Member
 
Registered: Jul 2004
Location: London, England
Distribution: Mandrake 10.1
Posts: 300

Rep: Reputation: 30
Quote:
Originally posted by Axigrav
I have a fix for this problem (at least in my case).
Here is what I did:
In the Network panel (redhat-config-network on command line) the clincher was putting my WAN Default Gateway IP address in for the DNS Search Path. The WAN gateway being the "switch" at my cable provider which is my WHOLE network's gateway to the rest of the world. I previously had my LAN gateway address (the switch LAN address or internal IP gateway address). I expect that I am not the only one who made the same conceptual error.

For those who are looking for these IP addresses, I HTTP over to my switch configuration and check the STATUS page. Here is where one can find the DNS server IP addresses and WAN gateway address to use in the DNS setup.

Hope it helps!
Axigrav
I'm using Mandy 10.0 and in my network panel there doesn't seem to be an entry for DNS search path.
I connect via an ethernet card and router.
In my network setup box I have these options tabs: TCP/IP Options and Information.
On the TCP/IP tab I have these settings.
Device select: eth0
A subheading IP configurations. There's a Protocol setting button which is set to DHCP by default, and the only other option is 'static'. Also in this window I have boxes for IP address (which is set and 'greyed out' so I can't edit it). Netmask (which is also set and greyed out so I can't edit it) and Gateway. There's nothing in the Gateway box, but it's also greyed out and uneditable.
To the right there's a box for DNS Server which gives the IP address for my router. It's info only and not editable. Below that there's a Search Domain box which again, is info only and not editable, here it says 'none'.
The options tab doesn't have anything interesting - start at boot: enabled, network hotplugging: disabled and track network card ID: also disabled.
The information tab rehashes everything in the prior two boxes.
The greyed out boxes remain greyed out and uneditable whether I'm in usr mode or su.

Any suggestions?
Thanks in advance.

Last edited by pongmaster; 07-28-2004 at 07:26 AM.
 
Old 07-28-2004, 05:23 PM   #13
drsuse23
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
Mandrake question

There are two options when setting up your Network Card, Static IP Address where you supply the numbers and Dynamic using DHCP. I've heard that DHCP is safer, and sometimes necessary if you are going through a firewall or router. DHCP will automatically detect and set the appropriate settings each time you connect to your ISP.

That said, don't be concerned about the greying out. You probably do not want to change that stuff anyway. The solution you referred to above, setting the default gateway is a STATIC solution.

My suggestion is to look into why your DHCP is having problems resolving the Host IP Address information. In my case, I had several configurations conflicting with one another. If you see more than one, and perhaps even if you don't, I recommend deleting your Network Card configuration and re-detecting in. Mandrake should easily recognize your Network Card and set it up properly for you when you do this. Give it a shot.

Good Luck.
 
Old 07-28-2004, 06:52 PM   #14
pongmaster
Member
 
Registered: Jul 2004
Location: London, England
Distribution: Mandrake 10.1
Posts: 300

Rep: Reputation: 30
Quote:
Originally posted by drsuse23
had several configurations conflicting with one another.
Ah, yes... after checking my setting more thoroughly, I found a similar problem.
Mozilla/internet running 100% now.
Thanks for the heads up.
 
Old 08-01-2004, 07:55 PM   #15
grooney
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Re: slow site loading in mozilla

I just like to say that the advice I got below worked straight away and has saved me a lot of time and tears. I thought that the only solution for fixing my mozilla problem was to use squid to proxy the information to mozilla but this proved to be too awkward.

I like to give credit were credit is due.

GRooney

Quote:
Originally posted by icenov
I have had a similar problem with mozilla 1.7 (and 1.6) under MDK10. While I am totally out of my depth here, apparently it can be caused by ipv6. Some posts talk about changing some conf files, but you can check, and in my case, fix, the problem by navigating to about:config (enter this in the address bar) and scrolling down to network.dns.disableIPv6. This is usually false, so change it to true (right click, modify, type true) and restart mozilla. I noticed an immediate improvement. This should fix the mozilla problem without affecting other network processes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wvdial conects, browser gets stuck at "resolving host" caesius_01 Linux - General 7 06-04-2004 02:04 AM
Couldn't display "SMB:///" , No host "(Null)" could been Found?????? munkey Linux - Newbie 3 05-03-2004 04:30 PM
Couldn't display "SMB:///" , No host "(Null)" could been Found?????? help munkey Fedora 6 04-30-2004 06:04 PM
Possible solution for "resolving host" and Mozilla adamis Mandriva 2 01-26-2004 02:03 PM
"host" ok, but "ping" can't find ip address hardigunawan Linux - Networking 2 05-16-2002 05:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration