-   Mandriva (
-   -   Problems installing Mandriva on a Acer Timeline 3810T-6415 (

markw10 07-25-2009 11:45 PM

Problems installing Mandriva on a Acer Timeline 3810T-6415
I just purchased an Acer Timeline 3810T, the 6415 model. It comes with Vista but I want to install Mandriva on it.
I have had a lot of problems. In the past I've installed Mandriva on VMWare machines on a Mac, Acer Aspire One Netbooks, ASUS eeePC's, and MSI Wind's and never had an issue until now.
First, when I do the install I choose the KDE desktop and after the install is complete and I restart it offers to install extra mediums.
After doing that it gives an error:
Unable to import pubkey file of "Non-Free (Office 2009.1-45)"

I don't know if this is an issue but then it prompts me to install 4 updates:

Then after this update it says:
The installation is finished. everthing was installed correctly.
Some configuration files were created as 'rpmnew' or 'rpmsave'.
You may now inspect some in order to take actions.
It listed the file:
rpm-4.6.0-2.1mnb2;/etc/rpm/aacros (Inspect)

When I select to Inspect it gives 3 options:
-remove rpmnew
-use rpmnew as main file
-do nothing.

I have tried all 3 options but everything I rebooted it would not work.

The first few times I did this I would restart after this set of updates and it would not restart. It would start like normal and then go into a black screen and then a light grey screen and that's it, it never went further.

I don't now what's going on but now I am able to restart but then I get a large set of additional items to update. I do that and do the next restart.
Once again it restarts but this top goes to a black screen with the cursor blinking at the upper left but goes no farther.

I am puzzled because I have never had an issue installing Mandriva and it simply won't start after updates are installed. I don't know if one specific update is causing a problem and why. This is a very new model computer but I don't see why it would cause this issue.

Any idea of how I can find out what's causing this?

ernie 07-26-2009 10:59 PM

If you get a black screen after an update:
1. Switch to a console screen (CTRL+ALT+F2)
2. Log in as root
3. close any running Xorg session with the command telinit 3
4. Run the Mandriva Control Center at the command prompt with the command mcc
5. From the menu list select the display item (use the arrow keys on your keyboard to navigate).
Use the TAB key to jump to the OK button, then press the ENTER key to run the display configuration
tool. Make sure the correct video driver is selected, and that the configuration is correct. Before
exiting the Display configuration tool, test the configuration to make sure it gives a usable Xorg
6. When all is well, exit the display configuration tool
7. To start a normal GUI session, enter telinit 5.
8. Log in as usual at the graphical log in screen.

Note: After successfully logging in to a GUI session, switch back to the console screen (CTRL+ALT+F2) to end the root session (CTRL+D), then return to your GUI session (CTRL+ALT+F7).


markw10 07-27-2009 01:43 PM

I never thought of it being a display issue but that makes sense. The screen is 1366*768 and since the closest resolution offered is 1360*768 that's what I choose at install time.
The graphics processor is a Intel GS45 Express Chipset with 3D and an Intel GMA 4500MHD. I will try the above suggestion to see if it works.

markw10 07-28-2009 02:04 AM

I tried the above but which item would I select for a Intel G45 GMA 4500MHD? I tried several but none of them worked.

ongte 07-30-2009 10:19 AM

You should be choosing Intel - 810 and later.

Anyhow your problem is likely not with the Video card drivers but rather your LCD's native resolution.

It seems Mandriva does not detect the LCD's resolution of 1366x768. You cannot simply choose the closes resolution of 1360x768 because the LCD itself does not support this.
You may try a higher resolution under "Monitor" and then try to choose 1366x768 under "Resolution".

Otherwise, you will have to first try a lower standard resolution like 1024x768 or even 800x600.

Once you get Mandriva up & running you can search around for a possible solutions. This usually involves mucking around with the xorg.conf file.

markw10 07-31-2009 01:16 AM

I tried what you stated below. It has been using Intel 810 and later. I was hoping it would work and at install time I chose 1024*768. Since the screen's resolution is 1366*768 and I was prompted for 1360*768 I figured it would work since that fell within the range but I guess maybe the screen can't do that resolution. After it was finished installing I went into KDE 4.2's Configure Your Desktop icon and then chose Display. It had a selection called LVDS and it was showing 1366*768 so it seems it set it up correctly there. Is that how it should be set up in KDE 4.2?

I did a set of updates, did a reboot, and another set of updates. It was able to reboot again and I installed several programs, Twitux, gedit, gftp, banshee, vlc, rhythmbox, and thunderbird. Unfortunately when i did a reboot it didn't work. In the past though I was able to use Alt-Ctrl-F2 or Alt-Ctrl-F7 to get to a command prompt. Now I try those and other combinations and it seems the computer is locked up and won't do anything.

I did some research and it seems people who are using Ubuntu have had a lot of problems and that's where it was suggested to update to the 1.08 firmware. Also, people who updated to the 2.6.30 kernel had better success. Unfortunately at this time the 2.6.30 kernel is not available through Mandriva. I am hoping this is available soon and may help out with this issue.

I prefer using KDE 4.2 and had thought about Ubuntu or using Gnome or Fedora but I really would prefer KDE 4.2 and the only other distribution I'd probably look at is OpenSUSE but I really prefer Mandriva. I did a Live CD of Ubuntu 9.04 and it appeared to work fine on this machine.

ongte 08-03-2009 08:40 AM

I see. Good idea to update the BIOS.

I had the same problem on my Toshiba laptop with the Intel driver. KDE 4 would freeze up intermittently and there were all kinds of artifacts & performance issues.

This was resolved for me with the latest update that came through:

Your mileage may vary. Also, it's a good idea to avoid turning on KDE4's Desktop Effects. It's horribly buggy, occasionally freezing my machine.

ernie 08-03-2009 03:27 PM

kernel-2.6.31 is available in cooker, although I am not sure how well it will work. If you choose to try it, make sure you keep the grub entry that will load a known-to-work kernel (such as your current kernel). Also, remember that any software from cooker is under development and is not intended for use on a production system. Before using such software make sure you have a good (and current) backup of any data you do not want to risk losing. If updating your BIOS corrects your problem, I strongly suggest you forget experimenting with the above mentioned kernel.

All times are GMT -5. The time now is 03:01 AM.