LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 12-23-2005, 01:35 AM   #1
peterrom67
LQ Newbie
 
Registered: Jul 2005
Location: Romania
Distribution: Mandriva 2006.0
Posts: 20

Rep: Reputation: 0
Lightbulb Problem with tvtime


I' ve made a clean install of Mandriva 2006.0. Until this clean install my tvtime worked fine with Pinnacle MediaCenter 100i. Since this fresh install tvtime scramble the audio of tv channels. Standard is PAL.
 
Old 01-06-2006, 11:50 AM   #2
halvy
Member
 
Registered: Aug 2005
Location: Anchorage, Alaska (soon EU, hopefully)
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 918

Rep: Reputation: 42
take out tvtime (save your config if necessary) and compile it.

compiling is easy (3 steps from command line).. there are docs in every tar package to help you.

compiling will tell you what is wrong and even tell you what you may be missing in terms of features, before it actually 'installs'.

personally i think tvtime is much more advanced and easy to work with.

good luck.
 
Old 01-07-2006, 02:36 AM   #3
peterrom67
LQ Newbie
 
Registered: Jul 2005
Location: Romania
Distribution: Mandriva 2006.0
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for your answer but didn't solve the problem. I noticed something very interesting: I tried 3 tv-tuners: this Pinnacle MediaCenter 100i, a Pixelview Playtv Pro and a Wayjet (don't care about model) and every tv-tuner had the same behaviour: after three or four days of activity (and I mean every tuner worked well without any problem) at some point something crashes and begin major problems: tv channels have no sound or from about 45 channels tv software (any software not just tvtime) shows me just about 20 channels (without sound).
 
Old 01-07-2006, 04:40 PM   #4
halvy
Member
 
Registered: Aug 2005
Location: Anchorage, Alaska (soon EU, hopefully)
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 918

Rep: Reputation: 42
i'm sorry my answer did not 'fix' your problems, but frankly you will need to fix the problem eventully on your own.

first, mandrake is not what it used to be, i'd trash it for a real os.

two, unless you have very 'good' system (ie, very new, hi-end, with a compiled version of the multimedia packages.. you are going to have glitches like you are experiencing.

three, if you have done everything else that you think can help (ie did you actually compile tvtime?), then it is possible the drivers for cards you are using, are not the best.

you will need to check the net to see if others are eperiencing the type of issue you have presented.

but like i said above, multimedia is still quite new on linux and unless you take EVERY possible step to hem in the problems, you will experience less than perfect resutls, expecially when you try anything that will drive the system hard.

again, good luck and lettuce know
 
Old 01-09-2006, 01:09 AM   #5
peterrom67
LQ Newbie
 
Registered: Jul 2005
Location: Romania
Distribution: Mandriva 2006.0
Posts: 20

Original Poster
Rep: Reputation: 0
Yes, I tried everything... the problem was somewhere else. I installed a Pixelview Playtv pro and I noticed that when I try to activate lirc_gpio to support the remote control everything crashed (and it seems this happend with every tv tuner I tried). When I remove lirc_gpio everything come back to normal even the radio stations. Maybe I do something wrong with this lirc_gpio.
 
Old 01-09-2006, 10:13 PM   #6
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 52
Quote:
first, mandrake is not what it used to be, i'd trash it for a real os.
Its as good as its always been, what do you suggest as a 'real os' and what does it have that MDV doesn't?

Quote:
two, unless you have very 'good' system (ie, very new, hi-end, with a compiled version of the multimedia packages.. you are going to have glitches like you are experiencing.
There is no magic in recompiling something yourself. All the multimedia RPM packages are compiled as well, usually by someone who has a pretty good idea of the options to use. Also packages often contain little patches and bugfixes which weed out many glitches.

Quote:
peterrom67: When I remove lirc_gpio everything come back to normal even the radio stations. Maybe I do something wrong with this lirc_gpio.
Have you tried it with the Mandriva packages for both tvtime and lirc installed? Since they are both in main they have probably been tested to work together, which is not true if you're just downloading the latest source releases from websites and compiling them.
 
Old 01-09-2006, 11:47 PM   #7
halvy
Member
 
Registered: Aug 2005
Location: Anchorage, Alaska (soon EU, hopefully)
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 918

Rep: Reputation: 42
i used to use mandy until 10.x when i discovered that it has been bit by the corporate bug finally.

i'm sorry but i was not even able to get responses when i emailed them about issues.

anyway that is JUST my opinion.. sometimes i come off snotty because i still remember the bad experiences...sorry

as far as compiling, the reason i believe it MIGHT help is because it will detect glitches and possible points of interest that NO ONE RPM can do on everyones UNIQUE system.
 
Old 01-10-2006, 12:11 AM   #8
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 52
Quote:
i used to use mandy until 10.x when i discovered that it has been bit by the corporate bug finally.

i'm sorry but i was not even able to get responses when i emailed them about issues.
Yeah fair enough, I've had some frustrations when trying to report bugs and get them to pay attention to them. And the whole thing with the yearly release cycles caused my to give up on the club, at least for the time being. I still use the distro though, I think its still pretty good compared to other distros.

Quote:
as far as compiling, the reason i believe it MIGHT help is because it will detect glitches and possible points of interest that NO ONE RPM can do on everyones UNIQUE system.
Compiling would probably detect if the packager forgot to add a dependency - you'd get an error in the configure script. It would also detect if the program is incompatible with the GCC or glibc versions on the machine, but that wouldn't be a problem with any Mandriva packages as they were all built on the version of whatever distro they're for.
 
Old 01-10-2006, 01:36 AM   #9
peterrom67
LQ Newbie
 
Registered: Jul 2005
Location: Romania
Distribution: Mandriva 2006.0
Posts: 20

Original Poster
Rep: Reputation: 0
Tvtime works fine except cases when I try to activate lirc support. I've made the following experiment: I've installed the Pinnacle MediaCenter 100i (with ir receiver on COM1) and activated lirc support. Everything worked well for about 3 days (in the mean time I didn't change anything in tvtime or lirc configs) when tvtime seems that it didn't "see" any channel... it says "no signal" on all channels I had previous. I tried with Xawtv and Kdetv and ... the same result: no signal. I removed Pinnacle and I installed Pixelview Playtv Pro... (which has ir receiver integrated on tv card and requires lirc_gpio activated). Every program "saw" the tv card, scanned all channels without any problem and from here I tried the following:

I try to activate lirc_gpio support with: modprobe lirc_gpio,
I created a link in the /dev directory with: mknod /dev/lirc -c 81 0,
and when I tried to start lirc with "lircd" everything crashed as described into one post above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
tvtime problem huxus Linux - Software 1 03-25-2007 02:40 PM
re: tvtime sound problem! thomyorke38 Linux - Hardware 1 01-03-2006 02:31 PM
tvtime problem on Fedora Core 4 sonic872 Linux - Software 1 06-18-2005 05:37 PM
xawtv tvtime problem devone Linux - Software 1 04-18-2005 11:19 AM
SB Audigy 2 ZS + ATi TV Wonder in tvtime problem Flunk Linux - Hardware 1 09-21-2004 03:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration