-   Mandriva (
-   -   package installation (

irongiant 01-24-2004 09:42 AM

package installation
I have reacently installed Mandrake Linux 9.2 on a separate partition to Windows XP. I have a Sagem F@st 800 ADSL modem and have read on the internet that i had to install certain packages to get this to work on Mandrake, I opened the package installer in KDE and selected the necessary packages as well as going through to see what else i could have on. I selected a few more packages with games and toys and WINE and hit 'install'. The program asked me for my disks and then said 'installation succesful', I hit 'OK' and had a look on the menu for my newly-installed programs only to find that thare was less there than before! is this a common problem or am i doing something wrong? Is there any way to correct this problem?



carlywarly 01-24-2004 12:34 PM

Indeed it's a known bug. Open a console and type in update-menu -v Wait a while and then close the console. That should sort you out.

Nukem 01-24-2004 12:35 PM

Missing menu Items is a very common problem for Mandrake 9.2 . This happen to me all the time. I don't know what causes this, but what I do is just open menudrake and put them back. The only trouble that I'm having now is my screensavers. Be careful your screensavers might go missing too. I heard that this is kind of like a bug with 9.2, cauz they went bankrupt and stuff, and that is why cooker is around now. They say everything will be fine with version 10.

btw I tried carlywarly's method and the console was like frozen. I waited for about 10 minutes and pressed enter. It returned me to normal prompt. Nothig was changed.

irongiant 01-24-2004 01:00 PM


Originally posted by carlywarly
Indeed it's a known bug. Open a console and type in update-menu -v Wait a while and then close the console. That should sort you out.

thanks for that, only one problem, one of the menu items that isn't there is the console one!!! any other suggestions anyone?


irongiant 01-24-2004 01:02 PM


Originally posted by Nukem
open menudrake and put them back.
sorry, i'm a bit of a newb; could you tell me where to acces menudrake because i haven't seen it around and all my console and file managers/browsers have gone with the missing menu items


Nukem 01-24-2004 01:46 PM

Open up console and type menudrake. If you don't know how to open console (if your link to console is missing) and can't get to console, create a new link on you'r desktop to console. This is how..

right click on desktop --> Create New --> Link to Application -->

In the general section, type in the name for the shortcut.
Then click on execute tab.
Under the "Command" option, type "konsole" without quotes and all letters simple (no capital).
Click OK

Then you can open up the console and type menudrake. Now you can add change your options.
But when I changed these options under normal user, It seemed to have no effect. When I tried login at root it worked for me...

irongiant 01-24-2004 02:41 PM

thanks Nukem, i'll see if that works. :D


Nukem 01-24-2004 02:59 PM

no pb.. tell me if it works or not.

irongiant 01-24-2004 05:10 PM

yep, it worked alright. I didn't have any problems with my user account and didn't have to use root at all. just make sure that your shell is selected rather than 'all'.

next step is getting the Sagem F@st working on my box! :scratch:

Thanks :D

Nukem 01-24-2004 05:33 PM

Oh... thanks for the tip...

All times are GMT -5. The time now is 11:35 PM.