LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Nvidia. Xfree. No 'Driver' section. No 'Vesa' (https://www.linuxquestions.org/questions/mandriva-30/nvidia-xfree-no-%27driver%27-section-no-%27vesa%27-217524/)

mooreted 08-14-2004 11:38 AM

Nvidia. Xfree. No 'Driver' section. No 'Vesa'
 
In Mandrake 9.2, I had no trouble installing Nvidia drivers. In MDK 10.0, I cannot find where to add the driver parameters to the xfree86 config file. In 9.2 there was a driver section with 'nv' or 'vesa' and you changed that to nvidia, and so on. There is no 'driver' section for the video card. There is no 'nv' or 'vesa' argument to change. How do I edit the xfree config file in MDK 10.0?

Yes, I searched. I read posts. I googled. I have worked dilligently to solve it on my own.

Here is my xfree config file:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
HorizSync 30-80
VertRefresh 60-75

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "fbdev"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

mooreted 08-14-2004 11:46 AM

Never mind. On a lark, I thoght I would use Mandrake's hardrake gui to set up the card. That gave me the 'driver' section with 'nv' and allowed me to edit the xfree config. My system now passes the 'tux test'.

Have a good one.


All times are GMT -5. The time now is 11:01 PM.