-   Mandriva (
-   -   NVIDIA driver error, why? (

fogcat 05-20-2004 08:58 AM

NVIDIA driver error, why?
I have 10.0 official ,FX 5200 Ultra AGP, Athlon XP2500 w/1Gig RAM, dual installation XP & Mandrake on seprate drives(boot works just fine), kernel 2.6.3-9mdk-i686-up-4GB(including the proper source file). Now then........

Whenever I try to install the Nvidia driver (5336) I get an error message as follows:

Unable to determine the NVIDIA kernel module filename
make: ***[select_makefile] Error1

:eek: :eek: :eek:

What am I doing wrong? The install log seems to give me no clue as it just has the saame info as above. I am sure this is something fundamental that I am missing as I have followed all the posts about driver problems that I can find and seem to have eliminated the flaws seen there.(Yea right!)

TIA for any response.

Dan Mac :cry:

b0uncer 05-20-2004 10:38 AM

hmm...are you completely sure that the nvidia support is added in the kernel? one time in the past when I tried to install drivers for an old tnt2 I couldn't, because I didn't have the nvidia module added in the kernel when I compiled it. helped when I recompiled and added the right module, plus checked that I had everything else I need..

fogcat 05-20-2004 01:21 PM

I do not seem to have any Nvidia modules whatsoever. How can I fix this?

Dan Mac

b0uncer 05-20-2004 02:04 PM

hmm..if neither of these give you any nvidia-related module:

modprobe -l | grep nv

then I'd say it's perhaps best to surf to and download kernel sources, make them and check that the nvidia module comes along and after compilation, run the new kernel..I'm not that familiar with kernel patching or adding some modules afterwards or anything like that, so if it's about missing module, I'd get and compile a new kernel..that's one option, and not as difficult as it might sound.

fogcat 05-21-2004 04:36 PM

Is it possible to patch the kernel to add a module? I did have the 2.6.3-7 and installed the newer 2.6.3-9 per security upgrade notice from MDK. I would sure hate to trash my setup now that it does work so well(except that I can't use my video properly). I will check out and see whats there, but am hoping that an easier or safer? solution comes up. Thank you for such clear direction; it isn't always the case on these type of forums but there are always some who can! :cool:

Dan Mac

b0uncer 05-22-2004 06:08 AM

yes, of course the patching would be the easiest way of course, if this problem is because of a missing kernel module like it seems. I just don't know if there is a patch for nvidia's could try googling for it, of course (with keywords like "nvidia kernel patch" or "nvidia patch")...

if you have kernel sources in /src/linux (where linux can be linux-2.6.xx or something else, depending on version..or then just linux), check out if the directory also contains a file called .configure (dot-configure). if it does (it does, if you've compiled a kernel yourself, but may contain otherwise too), that's a good thing - then you can just d/load new kernel sources, copy the .configure file to the new source directory (which copies your current kernel settings), make the kernel and only add the nvidia module leaving everything else as it is, and compile the new kernel. this enables you to keep your current kernel quite exactly as it is, so that nothing basically changes, except that you get the nvidia module too..

but before doing that, try to google for the nvidia patch, if one happens to exist already..if not, then I'm afraid I can't help for that much more because I haven't written any patches for kernel myself.

I wish the best of luck to you...

fogcat 05-28-2004 12:04 PM

Yesterday I had enough, with all the fooling around with module building, etc.. I trashed the X system, sooo; I reinstalled with a complete reformat. Guess what?? Everything works just fine now. I don't know why it didn't the first time around unless there were some dependencies error or something simple in that regard that wasn't clear. Anyhow the problem was resolved. thank you for your advise, it was very informative and I have learned some valuable lessons here.

Dan Mac:cool:

gkurts 06-22-2004 08:29 PM

Had the same exact problem - had ran online update for mandrake and it updated my kernel sources from 2.6.3-7 to 2.6.3-13 --- I grabbed CD3 and did an "rpm -e kernel-source-2.6.3-13mdk" to remove the udpated kernel sources then did and "rpm -i /mnt/cdrom/Mandrake/RPMS3/kernel-source-2.6.3-7mdk.i586.rpm". After that I ran the installer and it worked great! If you previously had the nvidia drivers installed, you may have to do an "sh --uninstall" to remove it first...

Hope this helps someone.

All times are GMT -5. The time now is 12:48 PM.