Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 05-27-2005, 05:15 AM   #1
Registered: Apr 2005
Posts: 241

Rep: Reputation: 30
numlock is always lit on keyboard


I'm using PowerPack 10.1 and I may need to spend
sometime getting used to its environment, but my
keyboard's num lock is always lit when PowerPack
boot up.

My system BIOS has this num lock always off.

Where should I look in PowerPack 10.1 to see if I can
turn this num lock light off?

Old 05-28-2005, 01:56 PM   #2
LQ Guru
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
i do not know the std. way
but this is way to enable numlock maybe u would like to try opposite of this

Old 05-28-2005, 03:07 PM   #3
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi masand,

Thanks. I'll look into your suggestion.
Old 05-30-2005, 07:21 PM   #4
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi all,

Actually, there's a "numlock" module in the /etc/rc.d/init.d
that, I think, might have caused this numlock light always lit
during booting and throughout the PowerPack 10.1 session.

Since my install was the default install, I presume this numlock
module was built that way during the kernel build.

Anyway, now that I've found out the reason why to my original
question, if I just delete this numlock module at the /etc/rc.d/init.d,
will this cause any negative side effects now or in future?

Old 05-31-2005, 06:59 AM   #5
Registered: Feb 2003
Location: ???
Distribution: Mandriva 2006
Posts: 92

Rep: Reputation: 15
You can type this command in a terminal as root to disable it:

chkconfig --del numlock

It can also be disabled in the Mandrake Control Center, click on System > enable or disable system services.
Old 05-31-2005, 07:03 PM   #6
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi Tormented,

Thanks for your feedback.
Old 06-02-2005, 12:07 AM   #7
Registered: Sep 2003
Location: New Hampshire USA
Distribution: Mandriva 2006 & 2007 Power Pack Club
Posts: 178

Rep: Reputation: 30
Here is something that might help ya. Open up the Mandriva control center and go to services. Once the window shows the services on the system scroll down and look for numlock and uncheck start at boot.

I hope this helps ya.
Old 06-02-2005, 12:16 AM   #8
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi jchance,

Thanks for your tips.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lit forum ankhdragon General 6 10-31-2005 10:50 AM
How to check the status of NumLock & CapsLock in the keyboard prash.k Linux User Groups (LUG) 1 10-06-2005 04:40 PM
"numlock" and "capslock" freeze keyboard evilchild SUSE / openSUSE 2 07-04-2005 11:39 AM
Keyboard NumLock is always off at startup jborges Linux - Hardware 0 11-16-2004 05:04 PM
left numeric keyboard is typing numbers (problem with NumLock on/off) zstingx Linux - General 0 11-10-2003 10:59 AM > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 03:48 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration