LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-06-2003, 06:04 AM   #1
kiljoy001
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Rep: Reputation: 0
No sound


I have a problem. I have no sound in linux. I have no clue what to do either. And yes, I'm a complete n00b.
ps -A results:
PID TTY TIME CMD
1 ? 00:00:04 init
2 ? 00:00:00 keventd
3 ? 00:00:00 kapmd
4 ? 00:00:00 ksoftirqd_CPU0
5 ? 00:00:00 kswapd
6 ? 00:00:00 bdflush
7 ? 00:00:00 kupdated
8 ? 00:00:00 mdrecoveryd
12 ? 00:00:00 kjournald
109 ? 00:00:00 devfsd
205 ? 00:00:00 khubd
444 ? 00:00:00 kjournald
706 ? 00:00:00 eth0
1008 ? 00:00:00 dhcpcd
1080 ? 00:00:00 portmap
1096 ? 00:00:00 syslogd
1104 ? 00:00:00 klogd
1152 ? 00:00:00 rpc.statd
1169 ? 00:00:00 gpm
1188 ? 00:00:00 ypserv
1355 ? 00:00:01 xfs
1411 ? 00:00:00 apmd
1430 ? 00:00:00 rpc.ypxfrd
1460 ? 00:00:00 kdm
1478 ? 00:00:00 atd
1491 ? 00:01:03 X
1502 ? 00:00:00 saslauthd
1519 ? 00:00:00 kdm
1520 ? 00:00:00 named
1524 ? 00:00:00 named
1525 ? 00:00:00 named
1531 ? 00:00:00 named
1532 ? 00:00:00 named
1547 ? 00:00:00 ntpd
1568 ? 00:00:00 sshd
1591 ? 00:00:00 xinetd
1636 ? 00:00:00 cupsd
1752 ? 00:00:00 nfsd
1753 ? 00:00:00 lockd
1754 ? 00:00:00 rpciod
1755 ? 00:00:00 nfsd
1756 ? 00:00:00 nfsd
1757 ? 00:00:00 nfsd
1758 ? 00:00:00 nfsd
1759 ? 00:00:00 nfsd
1760 ? 00:00:00 nfsd
1761 ? 00:00:00 nfsd
1773 ? 00:00:00 rpc.mountd
1789 ? 00:00:00 rwhod
1798 ? 00:00:00 rwhod
1807 ? 00:00:00 rpc.yppasswdd
1948 ? 00:00:00 master
1962 ? 00:00:00 pickup
1963 ? 00:00:00 nqmgr
2095 ? 00:00:00 httpd-perl
2096 ? 00:00:00 httpd-perl
2097 ? 00:00:00 httpd-perl
2098 ? 00:00:00 httpd-perl
2108 ? 00:00:00 httpd-perl
2110 ? 00:00:00 httpd
2117 ? 00:00:00 advxsplitlogfil
2118 ? 00:00:00 httpd
2119 ? 00:00:00 httpd
2120 ? 00:00:00 httpd
2121 ? 00:00:00 httpd
2158 ? 00:00:00 proftpd
2174 ? 00:00:00 crond
2254 ? 00:00:00 lisa
2408 tty1 00:00:00 mingetty
2409 tty2 00:00:00 mingetty
2410 tty3 00:00:00 mingetty
2411 tty4 00:00:00 mingetty
2412 tty5 00:00:00 mingetty
2413 tty6 00:00:00 mingetty
2542 ? 00:00:00 startkde
2646 ? 00:00:00 kdeinit
2649 ? 00:00:01 kdeinit
2652 ? 00:00:00 kdeinit
2654 ? 00:00:01 kdeinit
2679 ? 00:00:00 kdeinit
2691 ? 00:00:00 kwrapper
2694 ? 00:00:00 kdeinit
2700 ? 00:00:03 kdeinit
2709 ? 00:00:04 kdeinit
2712 ? 00:00:08 kdeinit
2718 ? 00:00:00 kdeinit
2721 ? 00:00:00 kdeinit
2726 ? 00:00:00 korgac
2728 ? 00:00:00 kalarmd
2779 ? 00:00:01 artsd
2784 ? 00:00:02 kdesu
2788 ? 00:00:00 kdesud
2831 pts/2 00:00:00 su
2834 pts/2 00:00:00 kdesu_stub
2837 ? 00:00:02 harddrake2
2971 ? 00:00:00 kdeinit
2975 ? 00:00:00 oafd
2982 ? 00:00:00 bonobo-moniker-
3007 ? 00:00:00 evolution-alarm
3070 ? 00:00:00 kdeinit
3115 ? 00:00:00 wombat
3135 ? 00:00:11 kdeinit
3169 ? 00:00:34 kdeinit
3223 ? 00:00:00 kdeinit
3225 ? 00:00:00 kdeinit
3226 ? 00:00:00 kdeinit
3231 ? 00:00:00 kdeinit
3233 ? 00:00:00 kdeinit
3242 ? 00:00:00 kdeinit
3244 ? 00:00:00 kdeinit
3251 ? 00:00:02 kdeinit
3252 ? 00:00:00 kdeinit
3261 ? 00:00:00 kdeinit
3263 ? 00:00:00 kdeinit
3265 ? 00:00:00 kdeinit
3267 ? 00:00:00 kdeinit
3271 ? 00:00:00 kdeinit
3278 ? 00:00:00 kdeinit
3280 ? 00:00:00 kdeinit
3282 ? 00:00:00 kdeinit
3286 ? 00:00:00 kdeinit
3288 pts/3 00:00:00 bash
3319 pts/3 00:00:00 ps
Hardrake Soundcard entry:
VT8233 [AC97 Audio Controller]

It's obvious that the system has detected my IDE soundcard... but why isn't it using it ?

lol
 
Old 09-06-2003, 06:25 AM   #2
sharkee
Member
 
Registered: Jul 2003
Location: Australia
Distribution: Kubuntu 5.10 Ubuntu Dapper
Posts: 220

Rep: Reputation: 30
Killjoy001
Mandrake often has sound muted by default. In 9.1 i had to switch muted with Aumix you can find this in multimedia>Sound.
Regards Sharkee
 
Old 09-07-2003, 11:24 PM   #3
kiljoy001
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
It doesn't work and

I'm using 9.0 not 9.1... It does not work. I have no sound... what the heck is going on here...
 
Old 09-08-2003, 04:27 AM   #4
sharkee
Member
 
Registered: Jul 2003
Location: Australia
Distribution: Kubuntu 5.10 Ubuntu Dapper
Posts: 220

Rep: Reputation: 30
Killjoy001
sorry no other idea.No experience with 9.0. Can anyone Please Help!!!!!
Regards Sharkee
 
Old 09-08-2003, 04:37 AM   #5
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Rep: Reputation: 15
If you have an on-board sound card like AC'97, I wonder.
If it's the situation, then rechoose the via8_cxxx as your sound card driver.
May it work.
 
Old 09-08-2003, 06:20 AM   #6
oobe
Member
 
Registered: Sep 2003
Distribution: slackware
Posts: 85

Rep: Reputation: 16
go to konsole sign is as root "su" then type "sndconfig" it should reprobe your sound devices if it doesnt work it will ask you to select your sound card and test it you could try this nut it takes trial and error unless you know the exact details it helps to find out your sound card detials example i have a crystal wdm audio codec but linux calls it a cs4235 sound card. i also have closed sndconfig and reopened it when it wasnt successfull and ran it a second time and it worked.
 
Old 09-09-2003, 07:14 AM   #7
kiljoy001
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Original Poster
Rep: Reputation: 0
argh...

sndconfig: command not found.

man....
 
Old 09-09-2003, 08:02 AM   #8
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Rep: Reputation: 15
sorry, I give wrong name of via8_cxxx. Instead, it should be via82cxxx_audio. I had the same problem, but when I use this driver, everything is OK. You should check what driver you currently use. Type 'lsmod' in konsole to list all your driver.
 
Old 09-09-2003, 08:24 AM   #9
howzat
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Rep: Reputation: 0
sound is muted by default in mandrake 9.1 use aumix to fix it and yeh i got the via82xxx_audio card but with mine it worked just as well with the other via82x? driver as well.
 
Old 09-09-2003, 09:49 AM   #10
kamstrup
Member
 
Registered: Aug 2003
Location: Aarhus, Denmark
Distribution: Slackware, Ubuntu
Posts: 122

Rep: Reputation: 15
Become root with 'su'. Then type 'lspcidrake | grep AUDIO' (this runs the program lspcidrake and sends all output to the filtering program, grep which sorts out all lines not containg AUDIO). This will show you all (detected) sound cards you have.

Also try 'draksound' as root. This should give you a graphical interface for sound driver selection.

If you're still clueless return the output of 'lsmod' and 'lspcidrake | grep AUDIO' to this thread.

greetings, kamstrup
 
Old 09-10-2003, 01:03 AM   #11
oobe
Member
 
Registered: Sep 2003
Distribution: slackware
Posts: 85

Rep: Reputation: 16
go to cmd prompt and type sndconfig as root firts type su then yuor password it should work

Last edited by oobe; 09-17-2003 at 02:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
ALSA MIDI: Sound fonts for NVIDIA/NForce Soundstorm on-board sound vharishankar Linux - Hardware 6 09-04-2007 12:37 PM
FC2: Sound Card (SiS SI7012) Detect But Donot Play Sound rajanaeem Linux - Hardware 0 10-22-2004 03:41 PM
How to make a sound on Realtec ALC-650 card sound on a Shuttle ST62K? Laurent Linux - Hardware 0 05-30-2004 11:57 AM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 07:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration