LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 03-18-2011, 03:47 PM   #1
NirvanaII
Member
 
Registered: Jun 2005
Posts: 139

Rep: Reputation: 18
No alsa sound


Just installed an old live CD of Mandriva 2009.0 I created a while back, but getting no joy sound-wise out of xmame or mplayer. Youtube, and another game I tested worked out fine however. Running mplayer with an alsa output gives me silence, but no error message:

Code:
[stuart@localhost ~]$ mplayer -ao alsa /media/disk/Music/Yeah\ Yeah\ Yeahs/its_blitz/*
MPlayer SVN-1.rc2.23.r28791.2plf2009.1-4.3.2 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /media/disk/Music/Yeah Yeah Yeahs/its_blitz/01_zero.mp3.
Audio only file format detected.
Clip info:
 Title:
 Artist: Yeah Yeah Yeahs
 Album: It's Blitz
 Year:
 Comment:
 Genre: Unknown
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [libmad] libmad mpeg audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:  11.4 (11.3) of 266.0 (04:26.0)  1.3%
Here's what i've got installed relating to alsa (in name):

Code:
[root@localhost stuart]# rpm -qa | grep alsa
alsa-plugins-pulse-config-1.0.19-1mdv2009.1
libalsa-plugins-pulseaudio-1.0.19-1mdv2009.1
libalsa-plugins-1.0.19-1mdv2009.1
libalsa2-1.0.19-1mdv2009.1
alsa-utils-1.0.19-1mdv2009.1
libalsa-oss0-1.0.17-3mdv2009.1
libalsa2-devel-1.0.19-1mdv2009.1
libalsa-data-1.0.19-1mdv2009.1
alsa-plugins-doc-1.0.19-1mdv2009.1
[root@localhost stuart]#
Pulse audio is enabled.
 
Old 03-18-2011, 04:14 PM   #2
NirvanaII
Member
 
Registered: Jun 2005
Posts: 139

Original Poster
Rep: Reputation: 18
Addendum:

I have since - on remembering instruction somebody once gave - disabled PA and removed the alsa-plugins-pulse-config-1.0.19-1mdv2009.1 package. Unfortunately on reboot I now have no sound at all. Reinstating the package(s) and writing over the old conf file hasn't brought the sound back. Alsa gets routed through PA when enabled so I had hoped disabling and removing the aforementioned would help me - but apparently not!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Slackware 9 12-04-2008 07:29 AM
Slackware 12 + ALC268 + Alsa-driver 1.0.18 = ALSA Error =No Sound (Tried erverything) morphynoman Linux - Hardware 2 11-12-2008 12:48 PM
problem with ALSA, no sound through alsa, oss works SB Live! 5.1 Michalxo Linux - Hardware 2 01-21-2007 05:24 AM
Alsa sound *jumpy*: alsa-space: xrun of at least 11.449 msecs. resetting stream qwijibow Linux - General 6 04-22-2006 07:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 04:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration