LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Nic card -> cable internet modem no internet connection (https://www.linuxquestions.org/questions/mandriva-30/nic-card-cable-internet-modem-no-internet-connection-230236/)

zeshan_b 09-14-2004 09:51 PM

Asked my ISP Comcast on how to connect the linux box
 
Chris.8510 > Thank you for contacting Comcast technical support. Can you please verify your name, phone number, and the details of your Comcast internet service issue?

Zeshan> hi trying to connect a linux box and need to know DHCP_Hostname=

Zeshan> do you still use CC host name
Zeshan> http://www.astro.umd.edu/~teuben/linux/comcast.html

Chris.8510 > Please wait one moment while I bring up your information, and research your issue for you.
Chris.8510 > I'm sorry, Comcast isn't licensed to support 3rd party hardware installations. You will need to contact the manufacturer for assistance. The only thing I can tell you is that you need to set it for use with a dynamic IP address. Sorry for the inconvenience.

Zeshan> Thanks for your help
Chris.8510 > Thank you for contacting Comcast. Enjoy the rest of your evening.
Zeshan> this isn't third party hard ware
Zeshan> only the software is third party
Zeshan> it's a compaq presario 5011CL
Zeshan> all I want to know is that if you use a hostname that begins with cc
Chris.8510 > We aren't licensed to support 3rd party software either. What is your linux box for?
Zeshan> school assignments
Zeshan> ok I won't waste your time
Zeshan> thanks anyway

Chris.8510 > I meant what does it do. Regardless, we don't know what they are looking for when they ask for a hostname. You will need to contact them.

Chris.8510 > Thank you for contacting Comcast.

zeshan_b 09-15-2004 12:38 PM

Problem Solved
 
Thanks for putting up with me. The problem is solved now.

The cable modem had the mac address of my windows PC stored and that was one reason I couldn't log on to the net with mandrake linux.

I unpluged the Cable Modem and left it unpluged for a minute or two. I pluged the Cable back in and then edited the network configuration files. Comcast is gives dynamic ip address. I edited the following network configuration files:

/etc/sysconfig/network/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=dhcp
BROADCAST=
IPADDR=
NETMASK=
NETWORK=
ONBOOT=yes
GATEWAY=
TYPE=Ethernet
USERCTL=no
PEERDNS=yes
MII_NOT_SUPPORTED=yes
WIRELESS_ENC_KEY=""
DHCP_HOSTNAME=
NEEDHOSTNAME=no

/etc/sysconfig/network*

NETWORKING=yes
GATEWAY=

/etc/sysconfig/

search
nameserver
nameserver
nameserver

Remember this is for dynamic host not static and that is why you have to leave most fields blank. Now you can restart your computer and it should work.

I used some other sources on the net but this really helped me out:
http://www.astro.umd.edu/~teuben/linux/comcast.html

I am posting this via mandrake linux.

-Zeshan_B

bruno buys 09-15-2004 12:46 PM

Glad you made it friend! Hope you enjoy mandrake!

joker20 09-16-2004 11:53 AM

can you do a netconfig???, i had a problem similar but when i did a netconfig and setup the domain name my internet started working

JustAGuy 09-23-2004 03:06 AM

Someone may be able to expand on this, but i believe you may be running into a bug with dhclient, or perhaps a bug on the ISP side. Trying switching your DHCP client to pump and see if it make a difference.

See this article: http://www.tldp.org/HOWTO/Net-HOWTO/x1444.html

While it deals with the server side more, it does point out that certain clients can be "picky", and when a DHCP protocol violation occurs, all you see is that nothing responds to the broadcasts.

I wish I could be more specific, but it has been a while. I do remember that after tearing my hair out for a while, I tried using different clients, and one did the trick for me without having to do more digging.
Seeing your issue though, reminds me that I need to actually use my brain and find what's causing the problem...mebbe it's my brain.
:rolleyes:

JustAGuy 09-23-2004 03:07 AM

Whoops...never mind. Guess I was way off...Blowtorch, anyone?:D

eugeny 09-26-2004 11:48 AM

Hello,
I had similar problem with networking. In my case it was just 2.6.xx kernel fault, so reinstalling with kernel 2.4.xx solved it.

To change kernel you need to press F1 at booting from cd, then write "alt1", then as usual.


All times are GMT -5. The time now is 03:23 PM.