-   Mandriva (
-   -   NewbieQ:Firefox/Thunderbird crash on startup (Mandrake 10.1) (

matsgl 12-05-2004 01:44 PM

NewbieQ:Firefox/Thunderbird crash on startup (Mandrake 10.1)
Hi all,
Am currently experiencing problems with Firefox1.0 and Thunderbird.. Following installation of a score of additional packages in Mandrake 10.1 Official yesterday (among others Mozilla and several other Internet and Multimedia packages), I am now unable to start up either Firefox or Thunderbird:

[matsgl@localhost matsgl]$ firefox
SCIM: im_module_init
free(): invalid pointer 0x8b2ba20!
free(): invalid pointer 0x8b2b9f8!
/usr/share/firefox-1.0/firefox-installer/ line 451: 9271 Segmentation fault "$prog" ${1+"$@"}

[matsgl@localhost matsgl]$ thunderbird
SCIM: im_module_init
/usr/share/thunderbird/thunderbird/ line 451: 9331 Segmentation fault "$prog" ${1+"$@"}

Tried a classical Windows solution (sorry about this - I am a Linux newbie with capital N..) - uninstalled Mozilla to see if that would solve the problem, but no luck.

Any tips or ideas much appreciated!

opjose 12-05-2004 02:58 PM

Eh, let me guess...

You DID NOT install these from the provided RPM's or use the URPMI sources?

Or am I wrong?

matsgl 12-05-2004 03:04 PM

To clarify:
Firefox and T-bird were installed from tarballs. All other packages that I installed the other day were installed from the Mandrake 10.1 Official iso's.


opjose 12-05-2004 03:07 PM

Yup that's the problem...

Don't do it this way...

Instead first uninstall what you've tried to install...

You may be able to

make uninstall

in the directory where you unpacked the tarballs.

The follow the directions at to set up your urpmi sources

Once done

urpmi firefox


Much easier, and it works!

matsgl 12-05-2004 03:21 PM


Thanks for the help - I was not aware of urpmi... :o
However, 'make install' does not work - any ideas on how I can remove these progs?


opjose 12-05-2004 05:55 PM

Look through the Makefile in the same directory and see if there is anything which will automatically delete the files.

nafan 12-06-2004 11:43 AM

Just a thought, but did you run Firefox and Thunderbird as root after you installed using the tarballs?

If you didn't, both will refuse to run or bomb out. The first run of the programs needs to be as root to allow both programs to complete some configuring specific to your machine.

matsgl 12-11-2004 07:47 AM


Pardon this late follow-up of your advice, but better late than never I guess... I took your advice and configured the urpmi sources with the help of easyurpmi. Could you explain how urpmi works with respect to new installs and updates - does it search for the latest stable version among all the defined sources and then install the suitable one?

My problem with Firefox and Thunderbird remains - I could not do an uninstall and ended up following the uninstall instructions for Firefox/Thunderbird from (i.e. just delete the directory!). However, upon trying to re-install from tarball I get an error message and the progs cannot be re-installed. So I tried to install via urpmi after having defined the sources. This did not work either (I was asked for iso2 and inserted it but it got spat out and I was asked for iso2 again - no luck). So now I'm a bit stumped as to what to do - urpmi/rpmdrake seem like fantastic facilities and I will try and learn how to utilise them, but how can I sort my problems out so that I can install Firefox and Thunderbird again?


matsgl 12-11-2004 08:04 AM

Quick follow-up to my previsou message:

I just tried to install a theme using rmpdrake but get exactly the same behaviour as before - I'm asked to insert iso2 and when I do it's spat out and I'm to insert iso2 again..? Has this got to do with the configuration of urpmi?


opjose 12-11-2004 09:56 AM

Re: URPMI command line

URPMI searches the defined sources for the latest applicable version of the file or files which you are trying to install.

If a match is found it will attempt to install it. If a partial match is found or the result is ambiguous, you are prompted to the possible choices.

One a match is found the data for the particular RPM is searched to determine if there are requisite RPM's which must also be installed first. If everything it is already in place it will "download" the file from the source and attempt to install it.

If dependancies arise, the requisite RPM's are also downloaded from the source to be installed.

If in turn the dependancies require other RPM's, those too are downloaded for installation and added to the pending install list.

URPMI gives precendence to locally available files... hence the prompt for CD2.

However URPMI is not able to determine the validity of your ISO so it keeps prompting for you to install it.

If you followed the instructions in the link on my sig, you also set up a "remote" MAIN source which is basically a superset of what is contained on your CD's or DVD's.

That means that you could

urpmi.removemedia CD2

(or whatever it's actually called, just run urpmi.removemedia by itself to see...) to eliminate the prompt for the CD's.

You can do this for all of the CD's if you wish and thereafter URPMI will draw from the respositories instead.

Once you have Mandrake set up, this may be advisable just for ease, if you have a fast connection.

You CAN always add the CD's back in with the Media Manager if you choose to do so.

You should UNINSTALL the programs you attempted to install from the Tarballs if possible...

e.g. make uninstall

Then rely upon URPMI for anything you want.

RPMDRAKE (or as it appears in the Menu as "INSTALL SOFTWARE") is merely a gui to URPMI and can also be used for all of this once the sources are properly set up.

RPMDRAKE will also display all of the software available to you on the repositories.

You'll find that there is far more available this way than even on the Powerpack DVD's.

Remember to periodically run

urpmi.update -a

periodically to update your sources to reflect new changes or additions.

matsgl 12-12-2004 04:55 AM


Many thanks for sharing your knowledge on this! I've removed the cd's from the media list and installing apps using urpmi now works fine! What a fantastic tool!

However, regarding the the problems with firefox and thunderbird, these still remain. I previously tried to uninstall but got a message to the effect that no uninstall file existed. And the official mozilla instructions says to simply delete the application directory(ies) (which I have done). Now, I have tried to re-install both these programs using urpmi - I get no error during the install but I can't see that they are installed ('locate thunderbird' does not indicate that the app has been installed anywhere)?

I realise that the problems are caused by the fact that I have not properly uninstalled the programs.. Any ideas on how I can get rid of them?

Again, thanks for your help!


opjose 12-12-2004 10:57 AM

The "Locate" database is updated nightly via crontab.

Since you've made changes to your system, the database does not reflect these changes yet.

To force an update as root type

updatedb &

It will take 4-8 minutes to run in the background. Don't close the open window during this time...

(Note: if you want to you can also type

nohup updatedb &

which will circumvent the need to keep the window open...)

Then try the locate command.

Also after installing any packages it may take a few minutes before the new items appear on the menu.

If you intalled them from RPM's you'll probably find them now on your menu.

matsgl 12-12-2004 12:50 PM


I feel stupic now.. Shortly after posting my last message the apps were available through the menu. I also ran updatedb and can now see the locations when using the locate command.

Many thanks - have learnt some useful tricks this weekend!


theGerbil 01-04-2005 11:34 AM


I also have this problem :(

Can you tell me if you managed to resolve your issue if so which actions solved it.

Many thanks

the Gerbil

matsgl 01-04-2005 05:05 PM

My problems were solved thanks to the input from Opjose. I learnt to use urpmi and simply re-installed the progs (after having removed the installed directories, as instructed by the Mozilla team - see Firefox/Thunderbird support pages) and that was it. I now always use urpmi when installing and only install tarballs if no rpm:s are available.

Hope this helps - good luck and check out the posts and websites ponted to by Opjose. Some useful stuff there.

All the best,

All times are GMT -5. The time now is 12:31 PM.