Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.


  Search this Thread
Old 01-21-2005, 02:16 PM   #1
Registered: Jan 2004
Location: Georgia
Distribution: Debian Etch
Posts: 99

Rep: Reputation: 15
Newbie Problems: RAM, Sound, and codecs

Well... just started using Mandrake 10.1 on my laptop, and everything's finally starting to work out ok. Only a couple of problems still going on, and so I had a few questions regarding them.

1. Main problem: KDE is eating up a lot of RAM. The computer is about 3 years old, 256mb of RAM, but at idle KDE is consuming like 170-190mbs. Any options I can set to kill some of the little programs draining it? I've looked through the process list, but I don't know them quite well enough to decide what to kill.

2. Built in speakers are not working. No matter how high I turn up the volume. I've tried a couple of programs, most of the built in ones including Mplayer.

3. Been trying to find a good codec pack for Mplayer, other than the one that comes with the install. I d/l and watch a good bit of anime, and a lot of the files simply will not run.

Thanks for any help.
Old 01-21-2005, 02:41 PM   #2
Registered: Mar 2004
Location: Austria
Distribution: Ubuntu 6.0.6, CentOS, Fedora, Debian
Posts: 47

Rep: Reputation: 15
1. 256MB Ram should be enough. Killing apps from KDE won't be any good I think. Try to turn off unused services, which helps quite a bit should you run into memory problems.
Try running "free -m" and look at the values below free. In my case there are 235MB physical RAM free. Linux chaches pretty much everything into RAM, but flushes these buffers in case a program requires more memory.
$ free -m
             total       used       free     shared    buffers     cached
Mem:           503        497          6          0         18        211
-/+ buffers/cache:        268        235
Swap:         1023          0       1023
2. First of all, check that you don't have your audio channels muted. To do so open the mixer application (I think it's "kmixer" on KDE).

3. goto . You'l find the codecs for quite a lot of formats there. There are no other codec packs that I know of.
Old 01-21-2005, 02:49 PM   #3
Senior Member
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
To disable services, do this:

1) go to Mandrake Control Center

Boot Services (I believe - I'm at work with Windows 2000)

Then Services and you should be able to see what is booting up in Mandrake. Click on INFO and it will tell you what it does. I disabled a lot of services and my computer boots up quicker and uses less memory.


You can just press CTRL+ESC and you will see a list of services running. YOu can click on one and 'kill' it, if you know what it does.

2) type kmix in the console to open up your volume settings. Click on ADVANCE and play around with those advance settings and see if that works. Also go to the Mandrake Control Center --> Hardware and see if your sound card is detected or not.

3) Go to the mplayer website listed above me and download the codecs to /usr/lib/win32. That is where the codecs go. YOu may need to be in root mood to copy files into that directory.
Old 01-21-2005, 04:36 PM   #4
Registered: Jan 2004
Location: Georgia
Distribution: Debian Etch
Posts: 99

Original Poster
Rep: Reputation: 15
Well now i'm getting a strange error trying to get sound:

Sound server informational message:
Error while initializing the sound driver
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null outpust device.

And Kmix says that there is no driver, so i guess i'll have to figure this thing out. It is a laptop... maybe it's because it's onboard.

EDIT: and having no look finding Mandrake Control Center.

EDIT 2: Just placed in the codecs also, and I went to check MPlayer's optoins on the codecs... I told it to set the Video Codec family to FFmpeg's libavcodec family, hope that's the right setting.

EDIT 3: I gotta stop forgetting stuff: trying to run something in mplayer causes the error:

Fatal Error!
Error opening/initializing the selected video-out (vo) device.

Last edited by Dillius; 01-21-2005 at 04:57 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie needs help installing audio codecs through proxy NeoLives Ubuntu 1 12-03-2005 04:00 PM
[Newbie] Installing new codecs on mencoder binary? johngcarlsson Linux - Software 1 11-19-2004 01:23 AM
Newbie Slackware CDROM & Sound Problems SML Slackware 4 02-18-2004 02:18 PM
Newbie - Sound Problems with Xine sergeantroach Linux - Software 15 08-26-2003 12:25 PM
Newbie sound card problems Jetscream Linux - Newbie 0 11-03-2002 07:25 PM > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 08:02 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration