-   Mandriva (
-   -   New install: Blank useless desktop (

fuchikoma 02-19-2005 05:56 PM

New install: Blank useless desktop (resolved)

I've just been installing Mandrake 10.1 for the past couple days straight now, and I'm at wits end about how to get a window manager running?

When I boot my PC, it goes through the normal startup process, then starts Xorg, at which point I have a blank blue desktop with the Mandrake logo on it.

I've checked Mandrake's documentation, but it always seems to assume I'll automatically get a graphical login screen, login, and start KDE/Gnome without problems.

If it's important, I'm dual-booting with Windows XP, loading Linux via MS's boot.ini. I'm not willing to let LILO or Grub install to the MBR because every time I've tried a version of Linux, it's met with resounding failure, and when trying to pry the bootloader off, my Windows partition always comes with it because nothing short of a low-level format will completely remove the loader.

I'm also using a GeForce FX 5200 Go, but there appears to be support for the FX series...


nafan 02-19-2005 06:52 PM

Microsoft's own fdisk program will remove the lilo/grub bootloader. Make sure that your windows partition is the active or bootable partition in linux, then boot from a dos floppy and type "fdisk /mbr" at the command prompt. Job done! :)

To help us sort your Xorg problem we will need some more information. Switch to one of the virtual terminals (Ctrl+Alt+F[1-6]) and login as root. Shut down the display manager (if it's already running) by typing "service dm stop" and type 'startx' to start an individual Xorg session. If this fails, the error messages will be printed to the terminal screen. This is usually a helpful starting point in fixing Xorg problems.

On a side note, when you installed mandrake, did you enable the automatic login feature?
Also check that /etc/inittab contains the following:

If this is set to less than 5, the display manager will not be started. If you have the bootsplash from mandrake installed it may display a blue mandrake background on virtual terminals, the same as is displayed in the Display manager login screen. If this is set as "id:3:initdefault:" issue the command "init 5" and see if the display manager starts on virtual terminal 7.

If it does, switch back to the VT you logged in on as root, and edit the inittab file changing the 3 to a 5.

fuchikoma 02-19-2005 10:37 PM

nafan, thanks for the advice!

Actually, I'd kept working on it after I posted the question, and though I'm not sure this was what fixed it, I reinstalled and chose all the same options, but told it to automatically log me into KDE. I don't want auto-login, so I didn't choose it before, but this time, it loaded KDE as documented. I went straight for the control center and disabled automatic login, and now it gives me the X login frontend like it should.

Unfortunately, now that I've reinstalled, I couldn't tell you how it was set up, but thanks again for the info. I've seen this happen with other distributions, and I was really curious about how I could start troubleshooting from that point, even as far as just stopping the display manager, so your advice was definitely not wasted.

About the bootloaders though, my experience was with a much older copy of LILO. I tried "fdisk /mbr" back then, but it just severely corrupted LILO, rendering it unusable (and scattering visual elements of the text-based window all over the screen.) It sounds hard to believe, but I suppose MS's interpretation of the MBR was a bit different from everyone else's... it was like LILO was only partially overwritten, and after that, nothing could make use of the disk. I see that the rescue option on the Mandrake DVD has an option to restore the Windows bootloader, but this time around, I decided to install Grub on the same partition that contains /boot/, and copy the bootable code to my NTFS partition so I can load Linux via my BOOT.INI. It was a bit of extra effort, but it's working great, and now I don't have to worry about what happens if I want to reclaim the Linux partitions later. :)

All times are GMT -5. The time now is 07:58 PM.