LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   New install 9.1 no root user at login screen (https://www.linuxquestions.org/questions/mandriva-30/new-install-9-1-no-root-user-at-login-screen-88883/)

glennl 09-03-2003 02:16 PM

New install 9.1 no root user at login screen
 
Installed 9.1 and during the install created the root user password. But when logging in there is no root user to select. What do I have to do to get it to show up in the list?

This wasn't an issue with 8.

Thanks,
Glenn

contrasutra 09-03-2003 02:24 PM

Yeah, Mandrake hides the Root user on KDM to begin with. Its pretty stupid.

In LILO, type in the name of the Linux entry, followed by "init 3", like:

Linux init 3

and that will boot into Text mode where you can log in as root.

Once logged in, create another user with the "adduser" command.

Then you can log on through KDM as the user. To be able to see the root user on KDM (I dont recommend it), change that option in the "KDE Control Center" or "Mandrake Control Centre".

michaelk 09-03-2003 02:26 PM

The option to show root for logon is in the MDK control center but I can't remember exactly where.

Its a security thing. For most people using su in a console for root access is all you need.

Oddball79 09-03-2003 02:29 PM

the reason why is that the default graphical log in menu doesn't allow you to type in the name of the account that you want to log into. You can change this in the comand center by choosing a different log in screen. I don't know of any log in that will give you a pretty icon for root, but you can change it to one that allows you to manually type the user's name.

that and there's always logging in as root at a non-graphical command prompt or use su.

And once again, never use root unless you have to, and then immediately log out, blah blah blah...

RockmanExe 09-03-2003 03:38 PM

Go through the k menu to: configuration/kde/other/login manager and in 'users' tab uncheck 'root' as hidden user, that should work when you log out

oski 09-03-2003 03:39 PM

I had the same problem. I found the fix in a thread. Mandrake Control Center>Hardware>Select Display Manager>Switch from MdkKDM to KDM. Maybe you'll be prompted to install a package, I don't remember exactly the name, perhaps was kdm.mdk.rpm, do it. With this fix you'll find a place where to write manually the username (root) and password.


All times are GMT -5. The time now is 08:31 PM.