-   Mandriva (
-   -   Network not working after upgrade 9.2 to 10 official (

NLG 05-27-2004 01:22 PM

Network not working after upgrade 9.2 to 10 official
I am posting this from my 9.2 desktop machine. I have an IBM R50 laptop which I have been dual-booting XP and Mdk9.2 with for a couple of months now. The nic is the gigabit ethernet and worked fine under 9.2 right out of the box. When I did an upgrade to 10.0 official, everything else seems to work fine or even better except that I can't get the nic to work properly.

Things I have tried.
1. rebooting. sometimes, most of the time in fact, when booting the screen shows "OK" for everything until the eth0, then "Bringing up interface Eth0: [FAILED]" I checked MCC and it is set to start at boot. Even if I start it manually with "ifconfig eth0 up" I can't get to the net.
2. In MCC I removed the network connection and created a new one for eth0. DHCP is working as the laptop gets an IP and NetMask and the Gateway is correct. Also in MCC, the hardware shows up as ehternet and it has the correct e1000 module - which is correct as far as I know.
3. Typing "ifconfig" brings up the correct information(as compared to my working 9.2 machine). It shows both eth0 and lo. If I use "netstat -ie" it gives the following error... "error fetching interface information: Device not found" As I said, "ifconfig" shows the IP, NetMask, and MAC address and if I try "netstat -r" I get correct route info (as compared to my working pc). I can not fathom why ifconfig and MCC sees the hardware but netstat does not.
4. I tried not using Shorewall, I had it configured under 9.2, but that didn't change anything.

If I open the Opera browser and try to go to any site it returns the error "Network socket blocking", for which I have no clue as to its' meaning.

Can anyone give me some help sorting this out?

NLG 06-03-2004 10:54 AM

Still need help
Wow. 40 views and nobody here has a suggestion? I also posted this on, and have not gotten any help there either. So much for the vaunted linux-users support community. I would have thought I might at least get a "what is the output of the 'such-and-such' command from the command line?" type question.
I may just downgrade back to 9.2. This is not a very encouraging sign for Mandrake.

Ph0enix2003 06-03-2004 11:20 AM

Alright, let me take a stab it.
First of all "netstat -ie" by itself will always return an error because of the "-i" switch. You need to include the device name with it so it should look something like this: "netstat -ie eth0".

Try setting the IP address on the NIC manually by using ifconfig. it should look something like this "ifconfig eth0 inet netmask up" (just to make sure it works).
After that, perhaps, you need to add the default route "route add default gw" and make sure that your /etc/resolv.conf is listing the correct DNS servers. If it's not, add them (ie: nameserver

It looks like your configuration got hosed during the upgrade. I'm not sure which file Mandrake keeps it's network interface information in sicne I'm new to the mdk distro myself. Anyone? ...Bueller? ...but you should be able to use " drakconf" to set it up.

The error message you get while eth0 is starting up has to do with hotplugging being enabled - it does not affect the way your NIC operates. You can disable hotplugging from drakconf as well.

I wouldn't give up on Mandrake because of this just yet. Post back and tell us how you made out with the above.

NLG 06-10-2004 10:19 PM

Victory is mine!
I disabled hotplugging as suggested and now the eth0 always shows "OK" at boot. That didn't fix everything, so I perused /etc and noticed that my old hosts file was renamed hosts.mdkorig or something, so I fixed that and now I am typing this from my laptop.
Thanks to Ph0enix2003 for the tips and the encouragement.
I am a bit late replying back, but I wanted to make sure it would keep working after rebooting into XP and back first, and I had some other stuff to do.
I also seem to have my browser, Opera 7.23, is still giving me some of those wacky "network socket blocking" error popups about 1/4 of the time when I try to visit a site, so it may not be totally fixed.
The netstat -ie eth0 command still returns the same error as before, too.

alainhenry 06-11-2004 03:48 AM

I am stuck with the same problem (and others...) with Mandrake 10.
For info, there is a complete thread on the etho [failed] topic in alt.os.linux.mandrake.

rubberist 06-12-2004 12:46 PM

Network socket blocked in Opera
Apparently this is related to the ipsec service. Turn this off from starting at boot time solves the problem. Because I'm a newbie to Linux myself though I don't know what other implications this has.....

NLG 06-12-2004 05:03 PM

Yes, IPSEC. I have also seen a post indicating FreeSWAN does it too.
I no longer have the intermittent connection wackyness. YEA!

barrys 06-13-2004 09:49 AM

If your in man 10 it's easy.

System -configuration -control center- network&internet-newconnection-lanconnection
click on the listing of the eth0 device listed,
click next
click next next
it will say "newconnection and -specify your network chip- your device, click on next and then accept everything it should install
everything without problems.

(Should this not work for you then do it all again, but first do the remove device and delete

NLG 06-13-2004 12:40 PM

things about the upgrade, misc. info
Actually, barrys, that didn't fix it - as I stated in my original post.
The problem was that IPSEC was starting at boot and interfering. I have also read that FreeSwan can do the same. The way to fix this problem is to set those services to not start at boot.

As an aside, I now have Shorewall up and running again and everything is working as it should. The upgrade also disabled the "tap-to-click" function of the synaptic's touchpad, but I never used it anyway - much prefer the point-stick and associated buttons.

My hosts file is a copy from, which blocks almost every ad server there is on the net - I have added only 3 more to it in 4 weeks. I really enjoy not seeing crappy blinking banner ads all the time. I never can recall clicking on any of the darn things, so no loss. I recommend installing this hosts file on any pc that goes to the internet, it is very simple.

Since I did an upgrade and not a clean install, I didn't have the mbr problem common to many installs which hoses the ability to dual boot back to windows. I have edited my lilo.conf(yes, I ran /sbin/lilo) to clean up some things though, since it gave me a huge menu of choices.
Also, it preserved my apm settings so I am still using apm instead of acpi. I know acpi is improved in this new kernel, but the apm support works fine for me so I kept it for now.
When I did the upgrade I also used the High-Mem support since I now have 1280MB of system RAM. I just love seeing the correct info in Gkrellm now. I recommend using Gkrellm to anyone who wants to have a good, configurable system monitor.

All times are GMT -5. The time now is 01:54 AM.