-   Mandriva (
-   -   network device down (

varun_saa 03-08-2007 12:08 AM

network device down

I am on mandriva2006 powerpack.

My network is totally down. I don't

Somebody has messed up some file.

When I use the command ' service network restart'
I get the following error :

" bringing back loopback interface: arping:
socket: address family not supported by protocol

Error, some other host already uses address "

My etc/host file is as follows : localhost

192.168.xx.xx fileserver

Can anybody help out ?

Thanks in advance.


camorri 03-09-2007 09:34 AM

Would you post the results of the command '/sbin/ifconfig' ( Without the quotes ). Please also describe the network connection, how many network interfaces you have on the system, and any other information you think may be relevant. Is this a wored or wireless connection?

varun_saa 03-10-2007 04:42 AM

Basically cards were working. All of
sudden the network stopped.

I think somebody blew something.

ifcfg-eth0 & ifcfg-eth1 were missing and I
created them manually.

The MB is a intel 945 with onboard lan which
I am not using.

I have 2 Compex giga ethernet cards.

/sbin/ifconfig gives only loopback device details

lspci show the cards.

lsmod does not list the cards.

cat /proc/interrupts - no cards listed.

cat /proc/net/dev - no cards listed.

Cards are working using Knoppix liveCD.

No wireless connection.

I hope that was useful


camorri 03-10-2007 06:12 AM

Since the cards are working with Knoppix, this would indicate this is not hardware related, things like IRQ conflict, defective cards, or a cabling issue. So, with that in mind, a few questions.

Can you see the cards if you open MCC and look at the hardware? Since lspci shows the card, I suspect it will show up through MCC. If it does, try running the configuration tool through MCC.

If it does not show up, in MCC, do you know the name of the driver that worked with the card? If yes, try using modprobe to load the driver. If it loads, you can try and configure the card with ifconfig command.

Let me know how far you can get, and if you need some help with the commands.

varun_saa 03-12-2007 08:53 AM

In mcc/hardware card are shown and

' e100 ' is the module for the onboard lan

and ' sk98lin ' for the giga ethernet cards.

Loading manually thru' mcc does not work .

And modprobe e100 or modprobe sk98lin

gives the following error :

FATAL : module e100 not found

And /sbin/insmode e100 gives :

can't read e100 : no such file or directory

I wonder what happened to the mudules.

Anything else that I can try ?



camorri 03-12-2007 10:53 AM

Here is the location drivers are installed.


This is on my Mandriva 2006 system. If the drivers are not there, somehow the packages have been removed, or deleted.

First, have a look to see if you can find the drivers in the above location. If not, try the command 'locate e100' to see if the locate database knows where they are. If you get a message the data base is more than 8 days old, then run as root 'updatedb' ( without the quotes ), after the update, try to locate the files again.

If you do not have the drivers, you will need to install them. Since your internet connection is not working, use package management and install them from your install CD's.

It may take a bit of looking to find out which package has the drivers.

ernie 03-13-2007 12:22 AM

As an addendum to 'camorri's' post:

The graphical Software Installer (I think it is Install Software in MDV 2006) has a search function which can be useful when searching for a package containing a specific file.

Enter your search term in the text entry field near the top of the window. In the Find in drop down list select from Name, Description, or File Name, then press the "Search" button to the right.

In this situation, you should start with the File Name choice, then try Description. The Name option will probably be fruitless, but you can try if you want to in the name of thoroughness :).


varun_saa 03-13-2007 12:43 AM

Thanks Camorri,

I ran updatedb.

I ran locate and it located both e100
and sk98lin drivers.

But still modprobe or /sbin/insmode give
the same error.

I checked manually the drivers are there.

So where does it leave us now ?


camorri 03-13-2007 03:38 AM


lsmod does not list the cards.
I went back and read through your posts. The above quote, lsmod lists modules, not cards. If either driver is loaded, it would show up as a driver name, probably e100 and sk98lin would be what I would expect to see listed.

Would you have a look as the output of lsmod and see if the drivers are listed?

We know the drivers are still on your system, and you have re-created the /etc/sysconfig/network-scripts/ifcfg-eth0 file and /etc/sysconfig/network-scripts/ifcfg-eth1 files.

If the drivers are not listed with lsmod, would you try again to modprobe each driver, and cut and paste the error information to this file. Please use cut and paste, do not just re-type it. There has to be an error that is being overlooked.

varun_saa 03-13-2007 05:41 AM

No lsmod does not list any modules.

It should show something like :

8139too 22880 0
mii 5664 1 8139too

If the mudules are loaded.

But lspci clearly show the card details.

I removed one card and it gave an error
that card not found. So basically cards
are detected but for some funny reason
the modules are not being loaded.


# modprobe sk98lin
FATAL: Module sk98lin not found

I can't copy but I exactly written.

A very strange mess up.


camorri 03-13-2007 08:39 AM


modprobe looks in the module directory /lib/modules/`uname -r` for all the modules and other file
The above is a quote from the man page for modprobe. For some reason your system is not finding the modules you located.

As root run the command 'uname -r' this will give you the name of the linux kernel, and part of the path the kernel is looking in for the modules.

If this system has had a kernel installed, it may be the kernel is not looking in the correct path for the modules. What we need to see is, the path where the driver is, and the path the kernel looks are the same. My system shows :


root /lib/modules/2.6.12-12mdk/kernel/drivers/net/sk98lin 09:32:59 > ls

This is where the module sk98lin.ko is, and uranme - r shows :


uname -r

Note the third directory is kernel version dependent. Do these match on your system?

varun_saa 03-13-2007 10:41 AM

Yes it is same for me also.


[root@slashome varun]# uname -r


camorri 03-13-2007 01:31 PM

At this point I'm at a loss to explain why you are unable to load the ethernet drivers. They are there, and modprobe can't find them. It appears that a kernel update was not done.

May I suggest you start a new thread, reference this one. I can only hope that someone else see it, and can help out more.

One last thought, I checked directory and file permissions out to the e100 driver. Here is how my system is set up.


ls -dl /lib
drwxr-xr-x 11 root root 4096 Dec 28 14:35 /lib
cliff ~ 02:27:01 > ls -dl /lib/modules
drwxr-xr-x 3 root root 4096 Dec 26 2005 /lib/modules
cliff ~ 02:27:20 > ls -dl /lib/modules/2.6.12-12mdk
drwxr-xr-x 3 root root 4096 Dec 28 2005 /lib/modules/2.6.12-12mdk
cliff ~ 02:27:36 > ls -dl /lib/modules/2.6.12-12mdk/kernel
drwxr-xr-x 10 root root 4096 Dec 26 2005 /lib/modules/2.6.12-12mdk/kernel
cliff ~ 02:27:44 > ls -dl /lib/modules/2.6.12-12mdk/kernel/drivers
drwxr-xr-x 33 root root 4096 Dec 26 2005 /lib/modules/2.6.12-12mdk/kernel/drivers
cliff ~ 02:27:53 > ls -dl /lib/modules/2.6.12-12mdk/kernel/drivers/net
drwxr-xr-x 17 root root 4096 Dec 26 2005 /lib/modules/2.6.12-12mdk/kernel/drivers/net
cliff ~ 02:28:01 > ls -l /lib/modules/2.6.12-12mdk/kernel/drivers/net/e100.ko.gz
-rw-r--r-- 1 root root 16254 Sep 9 2005 /lib/modules/2.6.12-12mdk/kernel/drivers/net/e100.ko.gz
Just check each directory, and make sure root can has rwx permissions. The Driver is still a gz file, so I think the rw is O.K. there.

varun_saa 03-13-2007 09:48 PM

Thanks a lot Camorri,

I did learn from it.


jolphil 03-14-2007 07:45 AM

I did a check on my Mandriva system,and I do not have a e100
but do have a e1000
I don't know enough about it if thats important or not..
Sorry to jump in..

All times are GMT -5. The time now is 08:45 PM.