-   Mandriva (
-   -   MS migrant (newbie stuck) (

JimboJuggs 03-29-2005 04:15 PM

MS migrant (newbie stuck)

I have recently installed Mandrake 10.1 Official on my PC and set up as a dual boot system.
Initially I was very pleased as the process was smooth and almost flawless.

But....I'm now having problems as I'm starting to get more adventurous and I seem to be going in circles trying to sort things out.

So, if anybody can spare me some time, I would be grateful if the following points could be clarified for me.

1st. I couldn't connect to the Internet as the speedtouch 330 modem did not would not set up- However following some postings in this forum got the modem up and running, however I now get 'Bringing up interface ppp0 [FAILED]' on boot and 'Stopping Loopback [Failed]' on shutdown. This doesn't seem to cause any problems but should it / can it be fixed.

2nd. I configured via the Terminal RPMDrake and installed my favorite browser and email progs- Firefox(v1.0) and Thunderbird (v0.8). I wanted TB to have a global account so that two users could access the same email address, but I could not select another file above the home directorys (no permissions). I then tried to set the local folders to that of TB (v1.0) in my windows system, but the required location failed to budge from its default, with out error messages. So I removed TB (v0.8) and downloaded from Mozilla the latest version TBv1.
Now, the website says, extract the zip type file and run Thunderbird. I couldn't find Thunderbird.exe? checked forum again and it seems the thunderbird file needs to be placed into /opt/ folder but Konquer tells me I don't have permission. How do I get permission to copy the files there?

3rd. As regards the permissions, what are all the groups listed in the User Manager app used for? Do I need to select any?

I know it is a long list but any assistance would be gratefully received.

Padma 03-29-2005 04:38 PM

1) Yeah, it probably *should* be fixed, but I have no ideas to give you on this one. :(

2) The won't be a "Thunderbird.exe" file. not unless you are trying to run a Windows version in Linux! ;) I don't have TB myself, but I am sure the file name is just "thunderbird". ".exe" files are a Windows thing. As for permissions, just "su" to root, and you will have the permissions to put files where you need them.

3) The groups are there to allow multiple "users" to have specific access to various files. Most of these "users" are system processes ona normal machine. A "real" user can be assigned to multiple groups to allow specific access, and you can make your own groups, as necessary, to allow access to your own files. If you really want, I could go into quite a detailed discussion about users and groups, and how they can be used to help manage your file system.

RanDrake10 03-29-2005 04:46 PM

All folders other than /home/user should have root access only (for security). With Mandrake 10.1 from a user account, you should be able to open a terminal type "su" enter password for root, then type "konqueror" (with KDE this will run as root the GUI way) Be careful with this you can screw up your system as root. The "cp" command from a terminal is better.

AndrewB 03-30-2005 02:55 PM


you can screw up your system as root
and dont i know it :D hehe


justintime32 03-30-2005 03:18 PM

On my machine, I have a folder called "apps" in the /home/ directory, with permissons for anyone to acces the files and modify them. I don't use thunderbird, so I don't know if it stores the emails in the same directory, but you may want to give this a try. If you did, the command would most likely be "/home/apps/thunderbird/thunderbird"

JimboJuggs 03-31-2005 02:30 PM

Padma, Randrake10, Justin,

Thanks for your time and efforts.
I've know installed thunderbird email!!!!!
I'm slowly coming round to Linux thinking.

I installed by running "ark" from the terminal as root. I extracted the downloaded file to \usr\local and the followed this thread:
and Viola, or as the French say Dan-aaar.

Great advise, it good to know people can and do help!
Padma, I would be intrested to know what eash of the user group settings are as I cant seem to find this information.

Thanks again.

Lakota 03-31-2005 06:26 PM

In regards to your question #1 on original post:

Eth 0 Failed on bootup, is not an issue as far as I can tell as long as connection works when boot completed, if it bugs you, going into Mandrake Control Center, then into network, disable network hotplugging and you will then see an OK for eth 0 on boot up. I am assuming the "ppp0 [FAILED]' on boot" but cannot make sure before posting as I have not used dsl on linux in about 2.5 years, is the same issue I see when Eth 0 fails with my cable internet, yet stills works fine.

I played with this due to the Failed message bothering me a year or so ago, and found for me better to see Failed message due to having network hotplugging enabled. As best I understand it, it is a feature to autoconfigure your network. When I did play with it back then, I found I could unplug ethernet and plug back in and it worked with no manual configuration (dhcp), but with network hotplugging disabled, would not autoconfigure when unplugged and plugged back in.

also a link on user groups, maybe of interest:

Padma 04-01-2005 10:55 AM

Nice link, Lakota. :)

All times are GMT -5. The time now is 02:58 PM.