LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   mounting windows share with write permissions (https://www.linuxquestions.org/questions/mandriva-30/mounting-windows-share-with-write-permissions-544135/)

gw1500se 04-07-2007 05:55 PM

mounting windows share with write permissions
 
I am trying to mount a windows share on my 2007.0 box and cannot come up with the right parameters to allow all users rw access. It eems only root has rw and all others are ro. Here is my latest failed fstab entry:

//dap004/dap /mnt/dap004 smbfs rw,password=xxxxxxx,gid=500,umask=0002 0 0

Can someone give me the correct paramters to mout this rw for all users? TIA.

Junior Hacker 04-07-2007 10:17 PM

Do you have ntfs-3g installed in Mandriva 2007 which gives read/write support for ntfs partitions?
Also umask=0000

gw1500se 04-08-2007 10:20 AM

Thanks for the reply and the answer is no. That explains why my NTFS mounts are read only but does that also effect SMB mounts?

umask=0000 was another of my many failed attempts.

Junior Hacker 04-08-2007 04:48 PM

You know, I'm not exactly sure about that, based on b0uncer's reply in this thread link below, kind of a confusing response.

http://www.linuxquestions.org/questi...d.php?t=470301

ernie 04-09-2007 09:23 AM

Quote:

Samba uses SMB protocol (which Windows uses natively) so that works all right, no problem. You can copy a document to your friends computer over the lan if he's running XP and you're running Slackware, if you just have Samba installed and are granted access (like username/password if needed) to the shares.
As I read the first paragraph of the reply as quoted above, there is no confusion at all. You can read and write to a Windows share on your LAN using Samba provided you can successfully log in to the Windows computer. This has been true for quite a while.

The question of reliability only comes into play when a Linux system is trying to write directly to a partition formatted with the ntfs file system, usually on the same computer.

The difference is that when a Linux computer is writing to a Windows computer using samba, the Linux computer is not actually writing the data to the Windows partition. It is instead sending the information to the Windows computer, and Windows is writing the data.

When a Linux computer is writing data to a Windows partition on the same computer, the Windows OS is not running, so Linux has to write the data directly. This is where the trouble comes in. ntfs is a proprietary file system, and its specification is not publicly available. Microsoft can change it at any time. They have no obligation to provide the details of the ntfs specification to any third party (including the Open Source Community). As a result, any third party attempt to write to an ntfs volume will be an exercise of observation and guesswork at best. Even if the Open Source community learns to write successfully to an ntfs volume today, there is no guarantee it will work in future versions.

HTH,

Junior Hacker 04-09-2007 02:37 PM

Sounds about right

gw1500se 04-09-2007 05:20 PM

Thank you both but that does not solve my problem. I cannot write to the Windows share unless I'm root.

linckraker 04-11-2007 04:34 AM

hope this helps ya. w w w . justlinux.com/nhf/Filesystems/Mounting_smbfs_Shares_Permanently . html it would be a url but its not allowed as a first post and i only joined cause i was trying to help ya.

mokele 04-11-2007 06:31 AM

This is how I did it. I don't know how to adapt
this to Mandrake but the steps involved should
help. Also, keep in mind that I don't use the
fstab approach for mounting.

Good luck

-W

gw1500se 04-15-2007 08:59 AM

Thanks for the replies.

First to linckraker: That solution didn't seem to help. Although it was one of many I tried originally, I went back and tried it again. Still get the same error.

Second to mokele: You solution confused me a bit. First the "SOLVED" message referred me to at post from 2/21 and the last post in the thread seemed to be 2/5. Anyway I am hoping that was the one to which you referred. The confusing part was the suggestion that the group be changed in the directory on the Windows server. Since you got it working would you please clarify exactly what you did on the Windows server side? Thanks.

mokele 04-15-2007 03:10 PM

In the first post there is a section called "UPDATE 2/21/2007".
Instead of posting new reply, I update the first one and
mark it with dates so I can use them for future reference.

I clarified this in the SOLVED note.

What you have to read is whats written from "UPDATE 2/21/2007"
on, on first post.

If you still have problem please post. Keep in mind that I
don't use the fstab mounting approach. I rather mount my
shares manually or through a script.

-W


All times are GMT -5. The time now is 01:48 AM.