LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-08-2003, 10:04 AM   #16
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48

don't chage the entries in fstab, yet. I doubt that's the problem.

Quote:
I tried following the instructions to Terminals, then Konsole super user, but finished with a login command. However I don't know if the same information is available in the desktop cdrom icon, but I right clicked this and found "Permissions, User and Enter" ticked but nothing in the "None Group or Others"
It looks like non-root users do not have access permissions. To change this, start konqueror in super user mode - it's Applications -> File Tools ->File manager superuser mode). When it asks you for the password, give the root password (which you set up during installation; and sorry I said konsole last time; I meant konqueror)). Then you can change the permissions for your cdrom drive. Tick everything except under 'special'. I think this will solve it.
 
Old 09-08-2003, 03:39 PM   #17
MultiBooter
Member
 
Registered: Aug 2003
Distribution: Ubuntu 6.10 / SUSE 10.1
Posts: 56

Rep: Reputation: 15
If what quatsch recommends above doesn't work, then by all means change the entry to hdb. Start FileManager in SuperUser Mode (Applications|File tools) and then browse to /etc/fstab and open it. You can do this by either clicking on it or right-clicking on it and choosing a text editor. I would use Gedit. Find the line for your cdrom and change scd0 to hdb.

You could also open one of the terminals from you K menu and su to superuser and open the text editor from there and browse to etc to open fstab. Six of one...
 
Old 09-09-2003, 04:47 AM   #18
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
This Mandrake sure is complicated.
Firstly, about non root users. I only have one password, that as root login. Does this mean that I must have a user password, i.e that of another person, and is this why I am having problems?
 
Old 09-09-2003, 09:52 AM   #19
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
you mean you did not set up any users except root? Or do you mean you get logged in automatically as a non-root user? If the former, I'd urge you to set up a non-root user account and to use that.
 
Old 09-09-2003, 10:07 AM   #20
slapNUT
Member
 
Registered: Jun 2001
Location: Recycle Bin
Distribution: Linux & Everything else on VirtualBox
Posts: 144

Rep: Reputation: 15
Most likely if you change permissions in /mnt they will get changed back shortly (msec e.g. mandrake security). To change permissions of any system directory or file use Mandrake Control Center, click security, click permissions, select editable from the pulldown box, click add, now type in /mnt/cdrom/ in the box and set the the user/group then check the permissions. You'll have to rerun msec to make the changes happen:
/etc/cron.daily/msec
msec takes awhile to run but when it's finished the new permissions will be set.
 
Old 09-09-2003, 10:52 AM   #21
slapNUT
Member
 
Registered: Jun 2001
Location: Recycle Bin
Distribution: Linux & Everything else on VirtualBox
Posts: 144

Rep: Reputation: 15
The other way is to edit /var/lib/msec/security.conf and set the option
CHECK_PERMS=no
 
Old 09-09-2003, 08:33 PM   #22
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
Sorry quatsch, I am confusing not only you but myself also. I am logged under root as "root" and I do have a user name as well.
I followed slapNUT's directions and finished with Editable.....mnt/cdrom.....User=User ....Group=Admin...Permissions....7777. I clicked on save, nothing happened and so I exited. When you say rerun msec, would that be the Run Command in the Start Application as I tried this and nothing happened. How do I know if I have been successful? as I still have have the error when clicking on the cdrom icon, I do have a disk inserted when I try this. I looked at /var/lib/msec/security.conf. CHECK_PERMS and it already had =no.
While I was fumbling my way around, I went to ls -F /mnt/cdrom and found input/output error. Any clues here to my problem?
 
Old 09-10-2003, 12:00 AM   #23
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
I don't know if it was the changes I made on slapNUT's advice or the fiddling about in Mandrake control centre's Mount points just now, but I can now read my cdrom. Thanks to everybody for your help, now to decide whether to go on trying to get Lucent win modem working or buy an external type
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with mounting floppy and cdrom tyranus Debian 20 09-03-2005 07:56 AM
redhat 9, cdrom not mounting, floppy as well dtra Linux - Newbie 2 11-15-2004 05:46 AM
??? cdrom and floppy mounting rikkulinux Linux - Newbie 2 08-13-2003 04:57 PM
mounting floppy and cdrom drive jcb_dreamvsat Linux - Newbie 8 06-22-2003 10:31 AM
Needing help with mounting cdrom and floppy voitel Linux - Software 6 07-13-2001 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 02:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration