LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 09-06-2003, 06:45 AM   #1
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Rep: Reputation: 15
mounting cdrom and floppy


I would appreciate help with my cdrom and floppy. I have recently installed Mandrake 9.1., and I would imagine that the fstab file below should not have none against /mnt/cdrom and /mnt/floppy, would someone please explain how I go about getting them to work, also iso9660 is always mentioned along with cdroms, mine is iso8859. Would I be correct in saying /dev/scd0 is scussi, because I have a normal IDE cable

/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,umask=0 0 0
/dev/hda1 /mnt/win_c vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
/dev/hda5 /mnt/win_d vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0
 
Old 09-06-2003, 07:40 AM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
your fstab looks fine. The none is for supermount. The iso-8859 refers to the character coding, iso-9660 refers to the way the file-system is formatted so no conflicts there.

Have you actually tried inserting a floppy and CD and see if you can access them? If you can, there is no problem.
 
Old 09-06-2003, 10:35 AM   #3
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Quote:
Would I be correct in saying /dev/scd0 is scussi, because I have a normal IDE cable
Yes. /dev/scd0 is a SCSI device.
However, Mandrake is most likely using SCSI emulation in order to access your IDE CD-ROM. That's all.


To mount a CD-ROM, at the command line, type:
Code:
mount /dev/cdrom
The cdrom will be mounted in /mnt/cdrom

Don't forget to unmount, type:
Code:
umount /dev/cdrom
For the floppy, change cdrom to fd0.
The floppy will be mounted in /mnt/floppy
 
Old 09-06-2003, 10:44 AM   #4
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
Do you mean I delete everything in that row and type mount /dev/cdrom
 
Old 09-06-2003, 11:00 AM   #5
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
NO. Do not edit anything in fstab.

My previous post explains how to mount a cd-rom or a floppy from the command line (console).

If you are having problems with Mandrake's automounters.
Try the previous commands at the command line (console).
 
Old 09-06-2003, 11:44 AM   #6
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
I am green, I have not used any commands. What do you mean command line console. Please would you lead me step by step
 
Old 09-06-2003, 12:18 PM   #7
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
In Linux, there is something called a Console (the command line), this is where you will type commands.
In the Menu (and sub-menus), look for Console (or DrakConsole).
Take a look at this link.
http://doc.mandrakelinux.com/Mandrak...akconsole.html

From there, you will be able to type the commands from my previous post.


Also, if you insert a cd-rom or floppy in the drives, are you able to access them ?

CD-ROM is /mnt/cdrom
Floppy is /mnt/floppy
 
Old 09-06-2003, 12:41 PM   #8
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks for that Mathieu. Its time for bed here in Australia, and so I will give it a go in the morning
 
Old 09-06-2003, 03:06 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
you should NOT have to mount floppies and CDs maually in mandrake. If the supermount feature is working, you should see the contents of the floopy/CD when you put it into the drive. This is what supermount accomplishes.
 
Old 09-06-2003, 09:58 PM   #10
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks for the replies.
My floppy is working ok, but when I insert a cd disk and click on cdrom desktop icon, it takes me into Konqueror and there is an error "could not enter directory /mnt/cdrom"
 
Old 09-06-2003, 10:04 PM   #11
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks also for that Mandrake link Mathieu, thats just what I need to know about
 
Old 09-07-2003, 09:30 AM   #12
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
Quote:
My floppy is working ok, but when I insert a cd disk and click on cdrom desktop icon, it takes me into Konqueror and there is an error "could not enter directory /mnt/cdrom"
do you still get this? It's probably a permissions problem. Have you made changes to your fstab? If so, could you post the contents of the file /etc/fstab?

Also, open a konsole in superuser mode (there is an entry in the menu under terminals), right click on /mnt/cdrom and check if non-root users have permission to enter (it's under properties). If they don't just change it.
 
Old 09-07-2003, 10:44 PM   #13
mmodem
LQ Newbie
 
Registered: Aug 2003
Location: Portugal
Distribution: Mandriva
Posts: 21

Rep: Reputation: 15
Floppy BIG bug !

Hy quatsch

In konqueror when i change the floppy, it continues to show the conteud of the first floppy.

Someone told me to use supermount feature and that have some faults so then close that conqueror,remove the floppy, open a new knoqueror and insert the new floppt, but continues to show the conteud of the 1 floppy.

I already installed ths autofs rpm and configured it, and disable the supermount option for the fstab, and i continue to DONT get the conteud of the (new) floppy.

whats wrong, can u help me?

Here are the fstab and the auto.master, auto.misc and auto.net

auto.master:
# $Id: auto.master,v 1.2 1997/10/06 21:52:03 hpa Exp $
# Sample auto.master file
# Format of this file:
# mountpoint map options
# For details of the format look at autofs(8).
/misc /etc/auto.misc --timeout=60
/net /etc/auto.net --timeout=60

auto.misc:
# $Id: auto.misc,v 1.2 1997/10/06 21:52:04 hpa Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

kernel -ro,soft,intr ftp.kernel.org:/pub/linux
cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom
floppy -fstype=auto :/dev/fd0

# the following entries are samples to pique your imagination
#boot -fstype=ext2 :/dev/hda1

#floppy -fstype=ext2 :/dev/fd0
#e2floppy -fstype=ext2 :/dev/fd0
#jaz -fstype=ext2 :/dev/sdc1
#removable -fstype=ext2 :/dev/hdd

auto.net:
#!/bin/sh

# $Id: //depot/autofs-4.0/samples/auto.net#6 $

# Look at what a host is exporting to determine what we can mount.
# This is very simple, but it appears to work surprisingly well

key="$1"

# add "nosymlink" here if you want to suppress symlinking local filesystems
# add "nonstrict" to make it OK for some filesystems to not mount
opts="-fstype=nfs,hard,intr,nodev,nosuid,nonstrict"

# Showmount comes in a number of names and varieties. "showmount" is
# typically an older version which accepts the '--no-headers' flag
# but ignores it. "kshowmount" is the newer version installed with knfsd,
# which both accepts and acts on the '--no-headers' flag.
#SHOWMOUNT="kshowmount --no-headers -e $key"
#SHOWMOUNT="showmount -e $key | tail +2"

# Newer distributions get this right
SHOWMOUNT="showmount --no-headers -e $key"

$SHOWMOUNT | sort +0 | \
awk -v key="$key" -v opts="$opts" -- '
BEGIN { ORS=""; first=1 }
{ if (first) { print opts; first=0 }; print " \\\n\t" $1, key ":" $1 }
END { if (!first) print "\n"; else exit 1 }
'

and fstab:
/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,sync,unhide,umask=0,defaults 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,sync,unhide,umask=0,defaults 0 0
/dev/hda1 /mnt/disk1 ntfs iocharset=iso8859-15,umask=0 0 0
/dev/hdb1 /mnt/disk2 vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
/dev/hda5 /mnt/disk3 vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
/dev/fd0 /mnt/floppy auto umask=0,defaults 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0

I hope that i put here everything needed for u can help me
 
Old 09-07-2003, 10:45 PM   #14
mmodem
LQ Newbie
 
Registered: Aug 2003
Location: Portugal
Distribution: Mandriva
Posts: 21

Rep: Reputation: 15
Floppy BIG bug !

Quote:
Originally posted by quatsch
do you still get this? It's probably a permissions problem. Have you made changes to your fstab? If so, could you post the contents of the file /etc/fstab?

Also, open a konsole in superuser mode (there is an entry in the menu under terminals), right click on /mnt/cdrom and check if non-root users have permission to enter (it's under properties). If they don't just change it.
_______________________________________________________

Hy quatsch

In konqueror when i change the floppy, it continues to show the conteud of the first floppy.

Someone told me to use supermount feature and that have some faults so then close that conqueror,remove the floppy, open a new knoqueror and insert the new floppt, but continues to show the conteud of the 1 floppy.

I already installed ths autofs rpm and configured it, and disable the supermount option for the fstab, and i continue to DONT get the conteud of the (new) floppy.

whats wrong, can u help me?

Here are the fstab and the auto.master, auto.misc and auto.net

auto.master:
# $Id: auto.master,v 1.2 1997/10/06 21:52:03 hpa Exp $
# Sample auto.master file
# Format of this file:
# mountpoint map options
# For details of the format look at autofs(8).
/misc /etc/auto.misc --timeout=60
/net /etc/auto.net --timeout=60

auto.misc:
# $Id: auto.misc,v 1.2 1997/10/06 21:52:04 hpa Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

kernel -ro,soft,intr ftp.kernel.org:/pub/linux
cd -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom
floppy -fstype=auto :/dev/fd0

# the following entries are samples to pique your imagination
#boot -fstype=ext2 :/dev/hda1

#floppy -fstype=ext2 :/dev/fd0
#e2floppy -fstype=ext2 :/dev/fd0
#jaz -fstype=ext2 :/dev/sdc1
#removable -fstype=ext2 :/dev/hdd

auto.net:
#!/bin/sh

# $Id: //depot/autofs-4.0/samples/auto.net#6 $

# Look at what a host is exporting to determine what we can mount.
# This is very simple, but it appears to work surprisingly well

key="$1"

# add "nosymlink" here if you want to suppress symlinking local filesystems
# add "nonstrict" to make it OK for some filesystems to not mount
opts="-fstype=nfs,hard,intr,nodev,nosuid,nonstrict"

# Showmount comes in a number of names and varieties. "showmount" is
# typically an older version which accepts the '--no-headers' flag
# but ignores it. "kshowmount" is the newer version installed with knfsd,
# which both accepts and acts on the '--no-headers' flag.
#SHOWMOUNT="kshowmount --no-headers -e $key"
#SHOWMOUNT="showmount -e $key | tail +2"

# Newer distributions get this right
SHOWMOUNT="showmount --no-headers -e $key"

$SHOWMOUNT | sort +0 | \
awk -v key="$key" -v opts="$opts" -- '
BEGIN { ORS=""; first=1 }
{ if (first) { print opts; first=0 }; print " \\\n\t" $1, key ":" $1 }
END { if (!first) print "\n"; else exit 1 }
'

and fstab:
/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,sync,unhide,umask=0,defaults 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,sync,unhide,umask=0,defaults 0 0
/dev/hda1 /mnt/disk1 ntfs iocharset=iso8859-15,umask=0 0 0
/dev/hdb1 /mnt/disk2 vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
/dev/hda5 /mnt/disk3 vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
/dev/fd0 /mnt/floppy auto umask=0,defaults 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0

I hope that i put here everything needed for u can help me
 
Old 09-08-2003, 02:14 AM   #15
jimdene
Member
 
Registered: Jul 2003
Posts: 35

Original Poster
Rep: Reputation: 15
I trust the last two replies are in the wrong place and were not meant for me.
I tried following the instructions to Terminals, then Konsole super user, but finished with a login command. However I don't know if the same information is available in the desktop cdrom icon, but I right clicked this and found "Permissions, User and Enter" ticked but nothing in the "None Group or Others"
I loaded Mandrake on a spare pc just as a comparison, the cdrom accepts my cds, and my fstab for this, is as shown below. The difference being no windows installed and unlike this computer, only one hard drive.
The cdrom on both pcs is on the slave of the harddrives and the spare I can understand as being /dev/hdb,
Should I attempt to change this pc to /dev/hdb, instead of /dev/scd0, if so would I use a text editor to do so?


/dev/hda6 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda8 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,umask=0 0 0
/dev/hda1 /mnt/win_c vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
/dev/hda5 /mnt/win_d vfat iocharset=iso8859-15,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda7 swap swap defaults 0 0


Spare PC

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/hdb,fs=auto,ro,--,iocharset=iso8859-15,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with mounting floppy and cdrom tyranus Debian 20 09-03-2005 07:56 AM
redhat 9, cdrom not mounting, floppy as well dtra Linux - Newbie 2 11-15-2004 05:46 AM
??? cdrom and floppy mounting rikkulinux Linux - Newbie 2 08-13-2003 04:57 PM
mounting floppy and cdrom drive jcb_dreamvsat Linux - Newbie 8 06-22-2003 10:31 AM
Needing help with mounting cdrom and floppy voitel Linux - Software 6 07-13-2001 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 05:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration