-   Mandriva (
-   -   Mounted cdrom content contains garbage (

Luna-tic 01-31-2010 04:38 PM

Mounted cdrom content contains garbage

I am using Mandriva 2008.1 Spring Free with KDE3.5. I have this problem that some CDs when mounted their directory contains one or a few files with garbage characters for their filenames and nothing more. I've tried mounting it manually with these


mount /dev/cdrom0 /mnt/cd
mount -t iso9660 /dev/cdrom0 /mnt/cd
mount -t iso9660 /dev/cdrw0 /mnt/cd

None had any different results. I also tried mounting and re-mounting a couple of times. Would be very grateful for any assistance.


konzo 02-01-2010 03:28 AM

Which locale do you use?
Give output of locale

David the H. 02-01-2010 03:40 AM

Is there anything special about these disks? Do they contain foreign language material, for example? Is it the same characters every time, or do they appear randomly?

One thing about the iso9660 filesystem is that the basic filenames are restricted to the old dos-like 8.3 format. But there are two forms of extensions that provide long filenames and permissions features. Windows uses the Joliet extensions, and Unix/Linux has Rock Ridge. It's possible that these extended filenames are in a different language encoding from the one you have set up as a default, or there's some problem in reading the extensions.

Take a look at the iso9660 section in the mount man page and try a few of the options there, particularly the utf8 option.

It's also possible that the disks are just corrupted in some way, such that your drive is unable to read those sectors correctly. If you can, try them out on a different system and see if they work there.

All times are GMT -5. The time now is 10:00 PM.