-   Mandriva (
-   -   Mount an external ntfs usb hard disk (

dmpop 07-05-2004 03:35 PM

Mount an external ntfs usb hard disk

Sorry if my question is silly, but I'm a complete Linux newbie, so please bare with me. I run Mandrake 10.0, and I'm having troubles mounting an external usb disk (NTFS-formated). When I try to connect to computer's USB port, nothing happens. What should I do?

Thank you!


Andrew Benton 07-05-2004 04:59 PM

Plug it in and then open a terminal and enter the command dmesg . Look for something like

usb 1-5: new high speed USB device using address 2
scsi2 : SCSI emulation for USB Mass Storage devices
  Vendor: IC25N020  Model: ATCS04-0          Rev: CA2O
  Type:  Direct-Access                      ANSI SCSI revision: 02
SCSI device sda: 39070080 512-byte hdwr sectors (20004 MB)
sda: assuming drive cache: write through
 sda: sda1
Attached scsi disk sda at scsi2, channel 0, id 0, lun 0
USB Mass Storage device found at 2

The details will be different but the important bit is the line
sda: sda1
It's seen an sda disk and it's calling it sda1. So if I open a terminal and become root I can
mount /dev/sda1 /some/empty/folder

lausianne 07-11-2004 10:59 AM

I have the same problem. I can mount the hd (fs=subfs), but get the message "no medium" found" when I try to list the directory. When entering the folder and list the files, it's empty.
The hd has 200 GB. Another 120 GB external usb hd works without problems under the same conditions.

Any hint would be highly appreciated ...
(Suse 9.1, Kernel 2.6)


lausianne 07-11-2004 12:49 PM

After an hour or so of browsing the archives and trying all I found, this is what worked for me:

mount -t ntfs /dev/sda1 /mnt/exhdd

(sorry, don't remember the thread, should be easy to find again ...)

The device and mount point must be adjusted, of course.
I thought I had tried this already and it didn't work, but ...


mfdarvesh 03-12-2008 05:11 AM

Thanks, trying to solve my problem too

D3M0L1SHER 03-03-2013 10:45 AM

cannot mount external ntfs hard disk in RHEL 6
wen i connect my 1 tb hdd....
1.i typed command - dmesg

2.den after dat i noticed dat code- sdb:sdb1

3. bt didnt understood ur answer..
confused btween mount -t ntfs/dev/sdb1/
mount /dev/sdb1/----?????

Plz reply n tell me wat to do....

All times are GMT -5. The time now is 01:12 AM.