LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Missing lib files! (https://www.linuxquestions.org/questions/mandriva-30/missing-lib-files-124753/)

stonehurstX11 12-10-2003 08:31 PM

Missing lib files!
 
Hi
I am running Mandrake 9.2 and have run into a few annoying problems with missing lib files. There appears to be some missing libs: called libstdc++ and lib6.2-2.so.3. Or could this could be one whole lib file. For example, when I try to get The Flash player plugin for Netscape to work, I get this errorin the terminal:

...failed to initialize shared library /usr/local/netscape/plugins/libflashplayer.so [libstdc++-lib6.2-2.so.3: cannot open shared library object file: Not such file or directory.]

This appears to be a problem with lib(s) libstdc++-lib6.2-2.so.3. Not only for Flash, TCL/TK fails to work w/o these files.

Any ideas?

qwijibow 12-10-2003 09:36 PM

The problem is you are missing those library files you mentioned.
Install them, that should fix the problem...

if you are using an rpm based distro rpmfind.com will have them.
if not, just get the source for the packages rpmfind.net gives and compile urself.

adhara 12-10-2003 10:56 PM

Hi,

I have the same problem.

There is a file named libstdc++2.10-2.96-0.82mdk.i586.rpm on the installation disks. I have been advised to try it.. the reason I am yet to do so is because I am having trouble with my install disks :( so need to fix that problem first.

If it works.. let me know

stonehurstX11 12-11-2003 02:43 PM

I installed libstdc++2.10-2.96-0.83mdk.i586.rpm and it worked! Thanks so much! :^)

qwijibow 12-14-2003 05:14 AM

this type of thing is very common in linux because of its modular structure.
most of the time when you install somthing from he net you will need to solve 1 or dependency's but its easy when you know what you have to do.

AceTech747 12-15-2003 02:48 AM

I understand you have to solve the dpendency to get certain rpm's to work. I am having such a problem doing this though. I searched rpmfind.net for the different dependencies needed for a rpm. The when I tried installing the rpm containing the dependency it tells me that it is already installed with a higher version on the red-carpet program. So if there already installed why is the original rpm claiming a dependency? I run into dependancy problems all of the time. It is frustrating to try to install a program and not be able to do it because of dependencies. Then I have to jerk around trying to get the things to install and have made no progress. What am I doing wrong? I've tried all methods....command line, redhat package installer, and red-carpet. None of them with good luck. I think it would be easier and more resoursful to put the single dependency instead of an entire package. Probobaly harder too though. The only thing I am guessing is that the rpm is not finding the dependency and it is already installed. I think I have to link it or something. I have seen something with a Path command....could this be what I need to do. I have spent nearly 10 hours trying to set-up fluxbox. The install of the fluxbox went well. But getting it to load is another story. I found an rpm to install the fluxbox in the window manager for the sessions. No luck because of the dependeny though. Alright, I hope you guys can help me understand what i'm doing wrong. I think I have a basic knowledge of the rpm and dependencies. For some reason they are being difficult.

qwijibow 12-15-2003 06:29 AM

the strange thins about dependecy's, is when you are a newbie, they are the most complicated things in the world.
when i was new it took me forever to solve package dependency's

now, after doing it for a few months it has become second nature.
i dont know why, it seems im using the same methods as i did when i was new...
but now im slightly experianced,, it just seems to work.. its second nature.

all i can say is...
search google.com/linux or fpmfind.net like you are doing.

and install the dependency,
and try Uvh, instead of ivh, especially if you get conflit errors.

i couldnt install fluxbo when i was new, i eventually gave up...
but a few weeks ago, without even thinking about it i just did it.

anyway, if u post the error messages, maybe som1 can find a problem.

AceTech747 12-15-2003 12:56 PM

Here are the Dependencies for the Fluxbox window manager rpm:

Fluxbox]# rpm -Uvh fluxbox-0.1.14-1.i386.rpm
error: Failed dependencies:
libXinerama.so.1 is needed by fluxbox-0.1.14-1
libexpat.so.1 is needed by fluxbox-0.1.14-1
libstdc++.so.2.10 is needed by fluxbox-0.1.14-1


I downloaded all of these.....installed them.....and still get the same message.

AceTech747 12-15-2003 01:04 PM

I get this message when I try to install the packages for the original package containing the dependencies:

rpm -Uvh *.rpm
warning: libstdc++-2.10.0-30.i386.rpm: V3 DSA signature: NOKEY, key ID e01260f1
warning: package XFree86-libs = 4.3.0-2.90.43 was already added, replacing with
XFree86-libs <= 4.3.99.901-2
error: Failed dependencies:
XFree86-common = 4.3.99.901 is needed by XFree86-libs-4.3.99.901-2
libstdc++.so.5 is needed by (installed) groff-1.18.1-20
libstdc++.so.5 is needed by (installed) libwvstreams-3.70-8
libstdc++.so.5 is needed by (installed) pspell-0.12.2-16
libstdc++.so.5 is needed by (installed) aspell-0.33.7.1-21
libstdc++.so.5 is needed by (installed) vconfig-1.6-2
libstdc++.so.5 is needed by (installed) wvdial-1.53-9
libstdc++.so.5 is needed by (installed) ttmkfdir-3.0.9-1
libstdc++.so.5 is needed by (installed) ghostscript-7.05-32
libstdc++.so.5 is needed by (installed) hpijs-1.3-32
libstdc++.so.5 is needed by (installed) fam-2.6.8-9
libstdc++.so.5 is needed by (installed) cdrdao-1.1.7-4
libstdc++.so.5 is needed by (installed) openoffice-libs-1.0.2-4
libstdc++.so.5 is needed by (installed) gnome-spell-0.5-5
libstdc++.so.5 is needed by (installed) pilot-link-0.11.5-4
libstdc++.so.5 is needed by (installed) Maelstrom-3.0.5-8
libstdc++.so.5 is needed by (installed) XFree86-Mesa-libGLU-4.3.0-2
libstdc++.so.5 is needed by (installed) chromium-0.9.12-21
libstdc++.so.5 is needed by (installed) tuxracer-0.61-19
libstdc++.so.5 is needed by (installed) openoffice-1.0.2-4
libstdc++.so.5 is needed by (installed) openjade-1.3.1-12
libstdc++.so.5 is needed by (installed) xpdf-2.01-8
libstdc++.so.5 is needed by (installed) qtcups-2.0-15
libstdc++.so.5 is needed by (installed) doxygen-1.2.18-3
libstdc++.so.5 is needed by (installed) swig-1.1p5-22
libstdc++.so.5 is needed by (installed) autorun-3.10-1
libstdc++.so.5 is needed by (installed) htdig-3.2.0-16.20021103
libstdc++.so.5 is needed by (installed) switchdesk-kde-3.9.8-15
libstdc++.so.5 is needed by (installed) gnucash-1.8.1-3
libstdc++.so.5 is needed by (installed) octave-2.1.40-4
libstdc++.so.5 is needed by (installed) arts-1.1-7
libstdc++.so.5 is needed by (installed) kdelibs-3.1-10
libstdc++.so.5 is needed by (installed) kdegames-3.1-4
libstdc++.so.5 is needed by (installed) grip-3.0.4-5
libstdc++.so.5 is needed by (installed) gstreamer-plugins-0.6.0-6
libstdc++.so.5 is needed by (installed) kdebase-3.1-12
libstdc++.so.5 is needed by (installed) kdeartwork-3.1-3
libstdc++.so.5 is needed by (installed) kdegraphics-3.1-4
libstdc++.so.5 is needed by (installed) kdemultimedia-3.1-4
libstdc++.so.5 is needed by (installed) kdeaddons-3.1-4
libstdc++.so.5 is needed by (installed) kdenetwork-3.1-5
libstdc++.so.5 is needed by (installed) kdeutils-3.1-4
libstdc++.so.5 is needed by (installed) kdepim-3.1-5
libstdc++.so.5 is needed by (installed) kdeadmin-3.1-3
libstdc++.so.5 is needed by (installed) koffice-1.2.1-7
libstdc++.so.5 is needed by (installed) tetex-1.0.7-66
libstdc++.so.5 is needed by (installed) XFree86-Mesa-libGLU-4.3.0-2.90.43
libstdc++.so.5 is needed by (installed) kdelibs-3.1-12
libstdc++.so.5 is needed by (installed) ghostscript-7.05-32.1
libstdc++.so.5 is needed by (installed) kdebase-3.1-15
libstdc++.so.5 is needed by (installed) kdegraphics-3.1-5
libstdc++.so.5 is needed by (installed) hpijs-1.3-32.1
libstdc++.so.5 is needed by (installed) xpdf-2.01-11
libstdc++.so.5 is needed by (installed) sip-3.5-2
libstdc++.so.5 is needed by (installed) PyQt-3.5-5
libstdc++.so.5 is needed by (installed) arts-devel-1.1-7
libstdc++.so.5 is needed by (installed) kdbg-1.2.6-2
libstdc++.so.5 is needed by (installed) kdesdk-3.1-3
libstdc++.so.5 is needed by (installed) kdevelop-2.1.5-6
libstdc++.so.5 is needed by (installed) kdelibs-devel-3.1-12
libstdc++.so.5(CXXABI_1.2) is needed by (installed) groff-1.18.1-20
libstdc++.so.5(CXXABI_1.2) is needed by (installed) libwvstreams-3.70-8
libstdc++.so.5(CXXABI_1.2) is needed by (installed) pspell-0.12.2-16
libstdc++.so.5(CXXABI_1.2) is needed by (installed) aspell-0.33.7.1-21
libstdc++.so.5(CXXABI_1.2) is needed by (installed) wvdial-1.53-9
libstdc++.so.5(CXXABI_1.2) is needed by (installed) ttmkfdir-3.0.9-1
libstdc++.so.5(CXXABI_1.2) is needed by (installed) hpijs-1.3-32
libstdc++.so.5(CXXABI_1.2) is needed by (installed) fam-2.6.8-9
libstdc++.so.5(CXXABI_1.2) is needed by (installed) cdrdao-1.1.7-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) openoffice-libs-1.0.2-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) pilot-link-0.11.5-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) Maelstrom-3.0.5-8
libstdc++.so.5(CXXABI_1.2) is needed by (installed) XFree86-Mesa-libGLU-4.3.0-2
libstdc++.so.5(CXXABI_1.2) is needed by (installed) chromium-0.9.12-21
libstdc++.so.5(CXXABI_1.2) is needed by (installed) tuxracer-0.61-19
libstdc++.so.5(CXXABI_1.2) is needed by (installed) openoffice-1.0.2-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) openjade-1.3.1-12
libstdc++.so.5(CXXABI_1.2) is needed by (installed) xpdf-2.01-8
libstdc++.so.5(CXXABI_1.2) is needed by (installed) doxygen-1.2.18-3
libstdc++.so.5(CXXABI_1.2) is needed by (installed) swig-1.1p5-22
libstdc++.so.5(CXXABI_1.2) is needed by (installed) autorun-3.10-1
libstdc++.so.5(CXXABI_1.2) is needed by (installed) htdig-3.2.0-16.20021103
libstdc++.so.5(CXXABI_1.2) is needed by (installed) gnucash-1.8.1-3
libstdc++.so.5(CXXABI_1.2) is needed by (installed) octave-2.1.40-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) arts-1.1-7
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdelibs-3.1-10
libstdc++.so.5(CXXABI_1.2) is needed by (installed) grip-3.0.4-5
libstdc++.so.5(CXXABI_1.2) is needed by (installed) gstreamer-plugins-0.6.0-6
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdebase-3.1-12
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdegraphics-3.1-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdemultimedia-3.1-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdenetwork-3.1-5
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdeutils-3.1-4
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdepim-3.1-5
libstdc++.so.5(CXXABI_1.2) is needed by (installed) koffice-1.2.1-7
libstdc++.so.5(CXXABI_1.2) is needed by (installed) tetex-1.0.7-66
libstdc++.so.5(CXXABI_1.2) is needed by (installed) XFree86-Mesa-libGLU-4.3.0-2.90.43
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdelibs-3.1-12
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdebase-3.1-15
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdegraphics-3.1-5
libstdc++.so.5(CXXABI_1.2) is needed by (installed) hpijs-1.3-32.1
libstdc++.so.5(CXXABI_1.2) is needed by (installed) xpdf-2.01-11
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdesdk-3.1-3
libstdc++.so.5(CXXABI_1.2) is needed by (installed) kdevelop-2.1.5-6
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) groff-1.18.1-20
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) libwvstreams-3.70-8 libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) pspell-0.12.2-16
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) aspell-0.33.7.1-21
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) wvdial-1.53-9
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) ttmkfdir-3.0.9-1
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) hpijs-1.3-32
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) fam-2.6.8-9
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) cdrdao-1.1.7-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) openoffice-libs-1.0.2-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) pilot-link-0.11.5-4 libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) Maelstrom-3.0.5-8
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) XFree86-Mesa-libGLU-4.3.0-2
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) chromium-0.9.12-21
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) tuxracer-0.61-19
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) openoffice-1.0.2-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) openjade-1.3.1-12
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) xpdf-2.01-8
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) doxygen-1.2.18-3
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) swig-1.1p5-22
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) autorun-3.10-1
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) htdig-3.2.0-16.20021103
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) gnucash-1.8.1-3
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) octave-2.1.40-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) arts-1.1-7
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdelibs-3.1-10
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdegames-3.1-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) gstreamer-plugins-0.6.0-6
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdebase-3.1-12
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdeartwork-3.1-3
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdegraphics-3.1-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdemultimedia-3.1-4 libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdeaddons-3.1-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdenetwork-3.1-5
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdeutils-3.1-4
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdepim-3.1-5
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdeadmin-3.1-3
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) koffice-1.2.1-7
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) tetex-1.0.7-66
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) XFree86-Mesa-libGLU-4.3.0-2.90.43
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdelibs-3.1-12
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdebase-3.1-15
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdegraphics-3.1-5
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) hpijs-1.3-32.1
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) xpdf-2.01-11
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) PyQt-3.5-5
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) arts-devel-1.1-7
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdesdk-3.1-3
libstdc++.so.5(GLIBCPP_3.2) is needed by (installed) kdevelop-2.1.5-6
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) aspell-0.33.7.1-21
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) ttmkfdir-3.0.9-1
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) gnucash-1.8.1-3
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) arts-1.1-7
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdelibs-3.1-10
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdebase-3.1-12
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdeartwork-3.1-3
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdemultimedia-3.1-4
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdeaddons-3.1-4
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdeutils-3.1-4
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdeadmin-3.1-3
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) koffice-1.2.1-7
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdelibs-3.1-12
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdebase-3.1-15
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdesdk-3.1-3
libstdc++.so.5(GLIBCPP_3.2.2) is needed by (installed) kdevelop-2.1.5-6
libstdc++ = 3.2.2-5 is needed by (installed) libstdc++-devel-3.2.2-5
libstdc++ = 3.2.2 is needed by (installed) gcc-c++-3.2.2-5
XFree86-libs = 4.3.0-2.90.43 is needed by (installed) XFree86-xfs-4.3.0-2.90.43
XFree86-libs = 4.3.0-2.90.43 is needed by (installed) XFree86-4.3.0-2.90.43
XFree86-libs = 4.3.0-2.90.43 is needed by (installed) XFree86-twm-4.3.0-2.90.43
XFree86-libs = 4.3.0-2.90.43 is needed by (installed) XFree86-devel-4.3.0-2.90.43


What do you guys think?

qwijibow 12-15-2003 04:09 PM

LOL......

solved !!!!!

you have a recent linux distro (redhat 9)
which provides recent librarys...

you are trying to install a very very out of date fluxbox...
which needs very very out of date librarrys,
which redhat doesnt have)

by downloading and attempting to install the dependency's
you are trying to downgrade linux, which would cripple all the recent programs
(as listed in your last post)

the solution........
throw away fluxbox version 0.1
and download a recent fluxbox version 0.9.x

always make sure the software u are trying to install is up to date....
or u might get inpossible dependency's that cant be solved :)


All times are GMT -5. The time now is 11:43 AM.