LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 10-24-2004, 01:34 PM   #1
fuzzhead85
Member
 
Registered: Aug 2003
Posts: 42

Rep: Reputation: 15
mdk10.1 on a R51, nolapic problems


previously with mdk10, i used the nolapic option with lilo to get my laptop to power down correctly, and now that ive upgraded to 10.1, when i select nolapic the computer hangs after lilo, noapic can be enabled with no side-effects, but it doesnt help with the shutdown issue, and ideas?
 
Old 10-24-2004, 08:21 PM   #2
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Using noapic doesn't preclude enabling acpi or apm.

Either of these deal with actually powering down your machine.

Determine which one your machine uses by checking your machine specs.

Then enable the one it utilizes and DISABLE the other.

Also if you run acpi also make sure that the acpi daemon is set to run at startup.
 
Old 10-25-2004, 11:23 AM   #3
fuzzhead85
Member
 
Registered: Aug 2003
Posts: 42

Original Poster
Rep: Reputation: 15
acpi is the only power managment running, set to start at boot, yet the computer wont shutdown properly, it shuts everything down except the fan and the harddrive, when i was running mdk10, enabling nolapic solved my problems, but now when i enable that, it wont get past lilo, maybe im confused by your response, could you clairify?
 
Old 10-25-2004, 11:41 AM   #4
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Ok I'll rephrase.

If nolapic was working under the old version but is not now under the new, you could try utilizing noapic instead and see if this "takes".

Using noapic does not interfere with acpi which is what is used to actually shut down the machine.

ACPI tells Linux how it can halt the system.

If you cannot get a clean shutdown, then something may be interfering.

With ACPI enabled and Linux booted up, hit ALT-F1 to get to the console screen and log in as root.

As root type in

service dm stop

then

init 1

which should put you into single user mode after flushing the disk caches.

Now try powering off the machine by directly issuing the poweroff command.

e.g.

poweroff -h

If that doesn't work try again with just

poweroff
 
Old 10-25-2004, 07:42 PM   #5
fuzzhead85
Member
 
Registered: Aug 2003
Posts: 42

Original Poster
Rep: Reputation: 15
i tried both poweroff and poweroff -h under init1 with noapic, no luck, any other ideas?
 
Old 10-26-2004, 09:36 AM   #6
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
What type of laptop/machine is it?

Also try EXACTLY the same thing but at boot choose Linux in non-framebuffer mode so that X windows NEVER starts up.

There is another thread on exactly this issue btw.
 
Old 10-27-2004, 01:32 PM   #7
fuzzhead85
Member
 
Registered: Aug 2003
Posts: 42

Original Poster
Rep: Reputation: 15
its an ibm r51 laptop, what is the other thread called?
 
Old 10-27-2004, 03:58 PM   #8
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
The other thread was about an Acer Laptop... identical problem.

Yeah your laptop will not function properly without the nolapic parameter.

You may want to switch to a different kernel, either an older or newer one by download an RPM from one of the cooker, devel, or 10.0 repositories.

For more info:

http://forums.gentoo.org/viewtopic.php?t=205355

If you notice he had to utilize a special diff to the kernel before it would work.
 
Old 10-27-2004, 04:53 PM   #9
fuzzhead85
Member
 
Registered: Aug 2003
Posts: 42

Original Poster
Rep: Reputation: 15
thanks for the help, tonight or tommorow ill have some time on my hands to play with different kernels
 
Old 10-29-2004, 02:24 AM   #10
lairdsquared
LQ Newbie
 
Registered: Oct 2004
Location: Windsor CA
Distribution: Mandrake 10.1
Posts: 2

Rep: Reputation: 0
Hey fuzzhead85,

I was hangin on ACPI: IRQ9:. In my lilo.conf I changed my append line to show apic=off and it booted finally. I haven't tried shutting it down yet but if it doesn't power down properly I'll just hold the power button, pull the plug or get my hammer. Hope that helps. I had to run my install cd again as an upgrade instead of an install to get to my lilo.conf.
 
Old 10-29-2004, 02:29 AM   #11
lairdsquared
LQ Newbie
 
Registered: Oct 2004
Location: Windsor CA
Distribution: Mandrake 10.1
Posts: 2

Rep: Reputation: 0
This is what my append line in lilo says:

append="noapic devfs=nomount acpi=off splash=silent"

If you use your install cd you will come to the post install configuration screen where you can select lilo config. On the second page of the lilo config you can modify the appen for the kernel.
 
Old 10-29-2004, 01:31 PM   #12
opjose
Senior Member
 
Registered: Sep 2004
Location: Outlying D.C.
Distribution: Mandriva
Posts: 2,090

Rep: Reputation: 46
Fuzzhead

Are you sure your machine supports ACPI? Is it APM instead?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
noapic or nolapic any differnce? shanenin Linux - Software 2 04-01-2005 04:53 AM
r51 shutdown problems fuzzhead85 Linux - Laptop and Netbook 2 12-17-2004 04:01 AM
acpi=noirq nolapic kernel appends aus9 Linux - Laptop and Netbook 0 11-09-2004 09:24 AM
thinkpad r51 and mdk10, shutdown problems fuzzhead85 Mandriva 3 08-10-2004 09:10 PM
how to add nolapic to the boot params biotek1 Linux - Laptop and Netbook 6 12-13-2003 02:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 10:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration