LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices


Reply
  Search this Thread
Old 04-27-2004, 10:26 AM   #1
rockybalboa
LQ Newbie
 
Registered: Apr 2004
Posts: 5

Rep: Reputation: 0
MDK 9.2 XServer trashed


I'm posting this to see if this has occurred for anyone else and to get any suggestions that might help. Since installing Mandrake 9.2 I have not had the Xserver run while being used for more than 5 minutes. Every desktop locks up solid. No keyboard response or anything, completely locked.
-I thought it was bad NVidia generic driver. I updated and got a whole new mess of problems on top of old ones.
-I have run XFdrake about 100 times and tried all options available, including going from XFree 3.xx to 4.xx and back.
-Thought it could be my USB mouse, swapped to PS2 mouse, no change.
-Have been unable to reinstall the NVidia drivers because the thing crashes before I can get it done, and I can't work well enough at the command line to do it.
-I have tried KDE,Gnome, IceWM, WindowMaker and whatever else came with this release of Mandrake. All lock up the same. Mozilla seems to work longer than anything, konqueror crashes as soon as it's opened.
-Command line functions all seem to work, but I don't work deep enough to really stress test things.
-I've read and reread XFree86.x.log.x and seem to have standard faults, kernel module wasn't installed at first, then failed to initialize GLX extension.
-Modified config file manually about 5 times.

I'm now wondering if there was a problem with my install, although it went easier than I had anticipated.
Are there crash logs anywhere? Aside from the XFree86.x.x.x bunch?
Is there a way to completely delete X and all things associated for a fresh reinstall? Would complete reinstall of Mandrake be better.

I will skip posting my XFree logs because my errors have been duplicated numerous times elsewhere, but their fixes don't seem to help me.
Thanks,
Dan
P.S. Not sure if this is affecting it at all but, I've never gotten sound to work yet. I always see some ALSA fault but haven't tried a fix yet.
3 hours later Instructions from another Mandrake guru--------------
The sh*t just keeps getting deeper.
I followed your instructions and this is what I got.
When running the first rpm NVIDIA_kernel-1.0-3123.mdk81up.i386.rpm I got this:
"kernel=2.4.8.26mdk is needed for installation"

And then the install dropped back to the prompt.
I'm running, kernel 2.4.22-10.
I will say that I downloaded my Mandrake 9.2 ISOs off an Asian server about two weeks ago, is there a possibility that I have been doing all this with an outdated kernel or something? Or is Mandrake not identifying my kernel right?
Anyway, I'm out of ideas for now. I was going to go out and look for other NVIDIA rpms but thought better of it. I was running the "nv" driver with the original problem. However I did try the XFree86 4.x.x GeForce3 (generic) driver at one point and got the same results so I switched back to the "nv"
Dan
P.S. The NVIDIA rpms require that the basic driver and the GLX be installed seperately. However this was not the case with the tars I loaded the other night, or I did it wrong from the beginning.
Remember though that I originally started trying to update to cure the same problem I have now (lockups).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver-xorg config warning: migrating xserver-xfree86 templates doctorwebbox Debian 9 07-27-2005 07:24 PM
MDK 10 - xserver crashes after first post-install reboot wutzin Mandriva 3 07-17-2004 06:07 AM
MDK 10 upgrade trashed SAMBA confused_bof Linux - Newbie 0 05-16-2004 02:38 AM
Newbie Install-Mandrake XServer trashed rockybalboa Linux - General 0 04-26-2004 12:21 PM
Compaq Armada 7360DMT, MDK 9.1, Video/Xserver probs EuroJovi Linux - Laptop and Netbook 6 11-04-2003 09:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva

All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration