LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   MDK 9.1 Fatal Error in Stage 1: Exec Format Error (https://www.linuxquestions.org/questions/mandriva-30/mdk-9-1-fatal-error-in-stage-1-exec-format-error-88775/)

Beano 09-03-2003 07:24 AM

MDK 9.1 Fatal Error in Stage 1: Exec Format Error
 
:newbie:

When I tried to install Mandrake from CD (ISOs downloaded from the internet) I got the following message:
Code:

error in exec of stage2 :-(
trying to execute '/usr/bin/runinstall2' from the installtion volume,
the following fatal error occurred
FATAL ERROR IN STAGE1: Exec format error

I can't recover from this.
You may reboot your system.

at which point I had to reset and come back to WinXP

System Specs
  • Asus A7V333 MoBo
    Athlon XP 2100+
    256MB DDR RAM (PC2100)
    Ricoh CDRW

Has anyone any idea what I can do? I searched about google with no joy.

kamstrup 09-04-2003 09:46 AM

This sounds very much like a corrupt cd. Either the download or the actual burning must have gone wrong. I have installed lots of Mandrake versions on all sorts of computers (or what just resembled computers) and have never got any such error.

greetings, kamstrup

Xolo 09-12-2004 09:52 AM

Hmm, I get the exact same error message when trying to install Mandrake 9.0 over NFS,
and the files were copied off of the commercial Powerpack I bought a long time ago.
I tracked it to the file 'runinstall2', which is an empty file. I suspect that the installation
process expects to see some commands in that file but since it is empty, it barfs and halts.
I could not find a non-empty 'runinstall2' file on any Mandrake 9.0 disk I have in
my posession, commercial or download version. they are all 0 bytes and produce
the same error. It would be a great help if someone could just list the contents of this
file or put it up for download somewhere.

otish1000c 09-12-2004 10:18 AM

i have never dealt with this issue, but if it helps, here's the contents to that file. this is from 10.0 official, CD #1. it's a perl program. the runinstall2 file is on CD1->Mandrake/mdkinst/usr/bin. it's symlinked to install2 in that same directory, which in turn is symlinked to CD1->/Mandrake/mdkinst/usr/bin/perl-install/install2. again, no idea what this does or if it helps, but here's the contents.........

Code:

#!/usr/bin/perl
BEGIN {
   
    (my $f = __FILE__) =~ s|install2$|list_modules.pm|;
    -e $f or symlink '../kernel/list_modules.pm', $f;
}

use lib qw(/usr/bin/perl-install .);
use install2;

$::testing = $ENV{PERL_INSTALL_TEST};
$::isStandalone = 0;

install2::main(@ARGV);

c::_exit(0);

otis

Xolo 09-12-2004 10:58 AM

Excellent.. i'll try that right now, thanks a lot :)

Edit: Edited the file, and the error changed to an I/O Error.
one step further but not at the goal yet ;)

Xolo 09-12-2004 03:04 PM

I got suspicious.. there are about 20 more files on my cd's that are zero bytes :(
no wonder I can't install over NFS.. makes me wonder though how in the world
I was able to use these disks to install workstations and servers in the first place??


All times are GMT -5. The time now is 02:46 AM.