LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   MDK 10.1 CE and gcc-c++ (https://www.linuxquestions.org/questions/mandriva-30/mdk-10-1-ce-and-gcc-c-262347/)

ducttapeBigSexy 12-03-2004 10:51 PM

MDK 10.1 CE and gcc-c++
 
I've been working on this problem for a while, and I am completely lost and getting pretty frustrated!

Whenever I try to compile a C++ program, I get the error that it can't find a suitable C++ compiler. In addition, I've tried installing rpm-build 4.2.2, and it gives me the following error:

Quote:

Some package requested cannot be installed:
rpm-build-4.2.2-15mdk.i586 (due to unsatisfied gcc-c++)
I've installed the entire development directory in the package manager, but I'm still having these problems.

If it makes any difference, the only thing I've really changed under it is that I'm running the 2.4 enterprise kernel (the one shipped with 10.1) instead of the default 2.6 kernel (I'm trying to make a LiveCD with the mklivecd scripts from www - linuxminicd - org / mklivecd /, and I know live cds don't play too well with the 2.6 kernel).

Any ideas on what I can do?

ducttapeBigSexy 12-04-2004 11:21 PM

Just an update, I've tried running Mandrake under the default 2.6 kernel that's included with it, and I also installed the kernel source (idk if it's true, but I've heard that many c++ programs require the kernel to be installed for the programs to compile). I'm still getting the same errors whenever I try to compile a program ("configure: error: C++ preprocessor "/lib/cpp" fails sanity check") and when I try to install rpm-build.

If it makes any difference at all (I doubt it does), I'm running this under VMware 4.5.2 under Windows XP Home SP2.

I am seriously out of ideas (switching to the 2.6 kernel was my last lead I had). Do you think I should just try and figure out how to install gcc myself? I want to try to keep that option until the end b/c from what I've read, installing gcc manually is a huge pain in the neck.

ducttapeBigSexy 12-05-2004 02:39 PM

Well, I figured it out on my own. Apparently MDK 10.1 CE doesn't really come with gcc (or it's just really outdated). I just downloaded gcc, gcc-cpp, and gcc-c++ off of pbone.net and it's working great. Ah well - thanks anyway!

ben_build#2.1.0 12-05-2004 06:44 PM

for anyone trying this, configure urpmi (read the sticky on top of this forum) and type in "urpmi gcc-c++". (without the quotes). It solved my problem.


All times are GMT -5. The time now is 10:20 PM.