LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-04-2007, 03:23 PM   #1
kd5eax
LQ Newbie
 
Registered: Nov 2006
Posts: 27

Rep: Reputation: 15
Exclamation Many problems with Mandriva 07 x86_64, on installation, and post installation


I have tried to install Mandriva 07 on my machine several times now, and when i mean several, it's way past 30... , Well.. Half the time the installer freezes after the user authentication, the other half the time i get a mememory segmentation error, and NONE of the time does my mouse work, nor does it recognise my SATA drive.... I have sussessfully got the os up and running once.. but no matter what i tried, i couldent get my mouse, or soundcard to work..

Heres my hardware layout, as im shure it will be helpfull to anyone that tries to assist me
mouse = Logitech M-UV55a
video = ati radeon x300
sound = soundblaster audigy 24bit
proc = amd athelon 64 3500+
ram = 2.5 gigs
hard drives = 1 120 gig SATA running as master on SATA channel 1 , 2 IDE Drives, one 80 gig, and one 250 gig. Ive partitioned the 250 gig drive in half, and installing mandriva on half of the 250.

*im using the alsa driver emuk1 dirver set.. i think thats how it's spelled, anyways, when i try to change drivers, sounddrake locks up, and when i try to enable my sound i get an error sayin that dev/dsp dosent exist.. so logged into a root shell, and made the directory, now, when i tried to enable the audio, it just repeats starting the audio, over.. and over again.. also, i have a printer port installed in the pci buss... its not configured, and im not shure where to obtain a driver for it, but its possiable it could be interacting with the sound card, or the usb buss... my usb buss reports that theres no devices attached.. wich is odd, because i have a mouse, a webcam, and a line6 ux1 on the usb buss.. i've tried unplugging everything but the mouse.. and that dosent seem to help any, im going to try uninstalling the parallel printer port to see if that remidies some of my ailments.. if my guestimations are correct harddrake could be somehowe getting the two mixed up.. .. Any and all suggestions are quite welcome in resolving my issues, im doing the best i can do on my own to do so, but help is much appriceated as im quite unfamilliar with a linux system, though i do learn very fast. Again, Thanks in advance for any assistance.



: Removed the parallel printer pci card.. made no difference what so ever... ya.. im lost here.. HELP!!
Ok, i was able to get my sound going finialy, turns out that root was the only account that had permission to acess sound... *shruggs*... On to the mouse... Im doing my best to solve my issues on my own, as a person learns so much from doing so..


Ok, i've tried the solution pesented in the linux\answers section for my mouse issues.. And heres what i've come up with.. i cant save the file with the method described because of privlage rejection.. even though i log into root.. so i tried it in a root shell with vi, and everytime i save it, and reopen it. the lines i edited are back to their origional values.. any help .. anyone?

Last edited by kd5eax; 02-06-2007 at 10:00 PM.
 
Old 02-07-2007, 01:00 AM   #2
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
Open MCC (System / Configuration / Configure your computer).

Click the Hardware option in the list at the left.

Click 'Set up the pointing device (Mouse, Touchpad)'

Select either the default (Any PS2 or USB mouse), or search for your mouse under USB (you can choose one which most closely describes your mouse).

Click 'OK'. You should get a configuration image where you can move the mouse cursor, click the buttons and move the wheel (if there is one).

Click 'OK' or 'Save' to accept the configuration.

HTH,
 
Old 02-07-2007, 04:02 PM   #3
kd5eax
LQ Newbie
 
Registered: Nov 2006
Posts: 27

Original Poster
Rep: Reputation: 15
Post Tried that

Ernie, Ty for your assistance, ive tried that several times, and choose each setting ... to no avial.. in harddrake my usb shows that its installed but im not shure if it's supposted to show anything plugged up to it.. However, while switching harddrives in my bios, as im still not able to access my SATA wich i have windows installed on, i noticed USB legacey support was set to auto.. i changed it to Enabled, and when i booted back into windows it took windows a few seconds to pick the mouse back up, its possiable that the bios setting needs to be enabled for mandriva to pick it up, as mandriva possiably dosent auto enable usb legacey.. I'll be booting back into mandriva in a few hours, to see if this helps with my situation any, but again, Ty for your reply.
 
Old 02-07-2007, 05:39 PM   #4
ernie
Senior Member
 
Registered: Nov 2001
Location: Toledo, Ohio - USA
Distribution: Mageia 1
Posts: 1,079
Blog Entries: 4

Rep: Reputation: 70
You can 'look' at the hardware installed on the USB bus with a package named 'usbview' from the 'main' media source. I no longer see it in the menu system, so after you install the package, oprn a terminal window and enter:

usbview

to run it.

HTH,
 
Old 02-07-2007, 06:59 PM   #5
kd5eax
LQ Newbie
 
Registered: Nov 2006
Posts: 27

Original Poster
Rep: Reputation: 15
In Configure System/KDE/Hardware/USB Devices ... it lists NO devices.. in HardDrake, it lists 2 usb busses (wich is correct), and the drivers installed for them.... Something tells me either the usb buss isent enabled, or the drivers for such are incorrect. Ive tred to do this :

This is a known bug in the Linux Magazine version. (Why not join the club and contribute support and get the best version with all the drivers??)

from:
http://www.linux-magazine.com/issue/...tallation.html

First launch

Some USB mice may not work with the default Mandriva configuration. If your USB mouse does not operate properly after the installation, Mandriva may be using the wrong device file. In that case, try the following:

1. At the login screen, type your user name, then press [Tab] to move the next field, and enter your user password.

2. Press [Alt-F2] and enter this

kdesu "kwrite /etc/X11/xorg.conf"

in the quick start window. In the dialog box that then appears, enter the root password to assume administrative privileges.

3. Press [Ctrl-F] and select input as a search key. The first match is located in the Section "Input Device".

4. In the following line,

Option "Device" "/dev/mouse"

replace /dev/mouse with /dev/input/mouse0 (Figure 2), and then press [Ctrl-S] to save the file. Press [Alt-F4] to quit the editor.

Figure 2: If the mouse pointer fails to respond, you will need to modify the device file setting in the configuration file for the graphical interface.

Now all you need to do is relaunch the graphical interface to get your mouse working. The easiest way of doing this is to press [Ctrl-Alt-Backspace].

But my mods to the xorg.conf file isent saved, and kdesu loggs in as root, but when i try to save my changes it says that i cant due to file permission or space limitations... *Shruggs* .. Hope this helps in diagnosing my problems..
 
Old 02-09-2007, 10:17 PM   #6
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 129Reputation: 129
Hmm, I have Mandriva installed on 2 pcs & one one is rather similar to yours (Athlon 3800, 1GB DDR400, Radeon 300, Logitech Mouse (PS2), PATA & SATA) and it installed without a single problem. I did have more trouble installing on my other pc (C2D6600, 2GB DDR2, Radeon 1600, SATA); this turned out to be due to xorg.conf, which failed to save any changes I made. Until I decided to edit in non-graphical mode - which may be precisely what you need to do too.

Here's how:

- Boot into failsafe mode
- Sign in as root
- type: vi /etc/X11/xorg.conf
This brings up your xorg.conf in read-only mode; to edit you need to type: i
Now you can scroll through your xorg.conf and make any required adjustments (be careful! If you make an error, you may be unable to get back into your graphical environment!)
- When you are done editing, press "ESC" (=exit editing mode)
- save your changes by typing: :w (=write)
- press Enter
- type: :q (=quit vi)
- press Enter
You should be back at the command line. You can now reboot by typing reboot
or you could log into your graphical environment by typing
init 5
 
  


Reply

Tags
mouse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best copasetic installation of mandriva 2007 x86_64 and Microsoft Windows Xp Home kd5eax Mandriva 17 08-24-2007 10:39 PM
post-installation problems with internet connection maddog39 Slackware 1 12-09-2006 11:05 AM
Screen and Sound Problems Post-Suse Installation spicyohaggis Linux - Software 2 08-29-2004 12:21 AM
Post-installation problems with RedHat 7.2 Iccyh Linux - Software 7 01-06-2002 05:35 PM
RH 7.2 Post Installation Problems !!! srivamsi Linux - Software 0 11-28-2001 10:52 PM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration