LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Mandriva (https://www.linuxquestions.org/questions/mandriva-30/)
-   -   Mandy 10.0 Now here's another funny thing! (https://www.linuxquestions.org/questions/mandriva-30/mandy-10-0-now-heres-another-funny-thing-171195/)

vdemuth 04-17-2004 02:11 AM

Mandy 10.0 Now here's another funny thing!
 
OK,
Followed the threads for the knotify problem, and the choose external->artsplay works for me to. So I go into control centre and choose notifications for say kde events. I choose an event, it could be anything, and enable the play sound box. Then I browse for a sound, which by default opens /usr/share/sounds, with the filter set to show all supported files. But, the directory viewer only shows other sub directories, and files ending with the .ogg extension. If I set the filter to show WAV Audio, it displays no files, even though all of the sound event files are in this directory, and are .wav files. Does this mean that .wav files aren't supported, or is this another Mandy feature!!
Also, and I don't know if this is connected, or whether to start another thread, in my previous incarnation of Mandy 9.0/9.2, when I browsed my PC using konqueror, and I simply hovered my mouse over an audio file, be it .wav, .ogg, .mp3 etc, then the file would just play. Now I have to click on it and choose which application to use. Again, is this something new. If it is, then it seems to be a retrograde step IMHO. If this facility is still available, can anyone tell me how?, or has KDE lost the ability to do this as part of it's evolution.

dredgemortle 04-17-2004 02:46 AM

Easy answer for your second question:
go to view-preview-and check sound files in Konqueror. That should make the hover over sound work.
The reason it's off by default this time around IMO is that it can turn on at inopportune moments like when you click a movie to watch and the pointer falls on a sound file after so that you've got two audios mixing together.

vdemuth 04-17-2004 03:05 AM

Half way there then
 
OK, So far that has sort of worked. Now when I hover over .ogg and .mp3 files, they play automatically as I have been used to. Still does nothing though with .wav files. Do you have any more suggestions.

TIA

beejayzed 04-17-2004 05:14 AM

Konqueror bug? Mandy 10 is out, with loads of bug fixes...

beejayzed 04-17-2004 05:15 AM

By the way, I don't experience that prob.

dredgemortle 04-17-2004 12:03 PM

Here's a thread re .wav problems that may help:

http://www.linuxquestions.org/questi...highlight=.wav

vdemuth 04-17-2004 01:50 PM

Tried that thread but no luck. Here is something else that may be connected. If I browse to a .wav file and then right click and look at the properties, then they are as follows:-

shutdown1.wav located in /usr/share/sounds

Type audio/x-pn-windows-pcm
Contents WAV Audio

Why is this not of type audio/wav?

This just gets stranger all the time.
All the .wav files on my PC that I have checked all show the same. Is this a bug perhaps?

beejayzed 04-17-2004 04:00 PM

No, that's just the mime-type.

vdemuth 04-18-2004 02:20 AM

OK, Have checked out and read up on mime types, and now I'm even more confused. When I look at my file associations, using .wav as a filter, I have several different mime types using that extension.
i.e. audio/wav, audio/x-wav, audio/x-pn-windows-pcm/asm etc. I have tried all sorts to get any audio from .wav files including setting all/none of the above to a combination of:- use embedded player, use external player and use settings for group audio. What do you suggest I try next?

beejayzed 04-18-2004 04:42 AM

You can't get knotify to play them or you can't get any program at all to play them?

vdemuth 04-18-2004 06:06 AM

Hello again,
I can't get any programme to play .wav files, but here is some more info for you.
If I log in as root, then everything works fine. As user running konqueror as root, no .wav files will play with any app. As root, the mime type for the .wav files on the system is audio/wav. As user the mime type for .wav files is audio/x-pn-windows-pcm. So, can I make the mime types under user the same as under root?, as this may well fix my problem.

beejayzed 04-18-2004 04:10 PM

Let me think..... In the mean time you can try opening them in a different desktop environment.

beejayzed 04-18-2004 05:46 PM

<See next post first>

Hmmm, Okay I did some investigating. Before you continue maybe you should try making another user and see if you have the same problem, not that it's dangerous or anything, it'll just save you some hassle.
Okay, I did a search for the word mime and found some config files:
Relevant ones being:
/usr/share/mimelnk/
/etc/mime-magic
/usr/share/misc/magic.mime
/usr/share/misc/file/magic.mime
There's probably some that I missed though.
Anyway, I compare the wav entries of /etc/mime-magic and /usr/share/misc/magic.mime, they both have the same entry for wav:
0 string RIFF audio/x-wav

The entry for wav in /etc/mime.types is: audio/x-wav wav
and the entry in /usr/share/misc/file/magic.mime is:
>8 string WAVE audio/x-wav

Right, that's the troubleshooting I've done. Maybe you can try some more.
One more thing, was this a new install of Mandrake? Something is definitely broken here, coz I don't know much about mimetypes, so I can't really suggest anything useful.

beejayzed 04-18-2004 06:33 PM

I found these in my search results:
/usr/bin/restorekdemimetypes.pl
/usr/bin/savekdemimetypes.pl

That might just work.

vdemuth 04-19-2004 01:25 AM

Hello again,
It turns out that this is a bug in Mandy 10.0 According to the developers of KDE, there is no mime type audio/x-pn-windows-pcm recognised or incorporated into it. I have safely renamed that offending mime type with no adverse effects, and my system is now responding as I would expect it to do.
Thank you very much for your help, it has been a worthwhile learning experience.


All times are GMT -5. The time now is 03:50 AM.